summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-05-16 22:10:38 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-05-16 22:10:38 +0000
commit8b34276425a1a313cc7c3cde228d2c97c3bdae26 (patch)
treecab4f99c7f58b184e93e4b96cd0362bdc27b8122 /app-text
parentRestrict tests for gstreamer external plugins, they don't work with the split... (diff)
downloadgentoo-2-8b34276425a1a313cc7c3cde228d2c97c3bdae26.tar.gz
gentoo-2-8b34276425a1a313cc7c3cde228d2c97c3bdae26.tar.bz2
gentoo-2-8b34276425a1a313cc7c3cde228d2c97c3bdae26.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xchm/ChangeLog10
-rw-r--r--app-text/xchm/files/xchm-1.16-gcc44.patch22
-rw-r--r--app-text/xchm/xchm-1.16.ebuild58
3 files changed, 88 insertions, 2 deletions
diff --git a/app-text/xchm/ChangeLog b/app-text/xchm/ChangeLog
index 9f73aaf5e727..3c8357b2c947 100644
--- a/app-text/xchm/ChangeLog
+++ b/app-text/xchm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/xchm
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/ChangeLog,v 1.7 2009/04/14 21:59:24 dirtyepic Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/ChangeLog,v 1.8 2009/05/16 22:10:38 dirtyepic Exp $
+
+*xchm-1.16 (16 May 2009)
+
+ 16 May 2009; Ryan Hill <dirtyepic@gentoo.org> +xchm-1.16.ebuild,
+ +files/xchm-1.16-gcc44.patch:
+ Version bump.
*xchm-1.15 (14 Apr 2009)
diff --git a/app-text/xchm/files/xchm-1.16-gcc44.patch b/app-text/xchm/files/xchm-1.16-gcc44.patch
new file mode 100644
index 000000000000..49b5483ea5ce
--- /dev/null
+++ b/app-text/xchm/files/xchm-1.16-gcc44.patch
@@ -0,0 +1,22 @@
+https://sourceforge.net/tracker/?func=detail&aid=2792822&group_id=87007&atid=581690
+
+--- xchm-1.16-orig/src/bitfiddle.inl
++++ xchm-1.16/src/bitfiddle.inl
+@@ -22,6 +22,7 @@
+ */
+
+
++#include <stdint.h>
+ #include <wx/string.h>
+
+
+--- xchm-1.16-orig/src/chmfile.h
++++ xchm-1.16/src/chmfile.h
+@@ -24,6 +24,7 @@
+ #define __CHMFILE_H_
+
+ #include <config.h>
++#include <stdint.h>
+ #include <chm_lib.h>
+ #include <wx/filefn.h>
+ #include <wx/string.h>
diff --git a/app-text/xchm/xchm-1.16.ebuild b/app-text/xchm/xchm-1.16.ebuild
new file mode 100644
index 000000000000..5e98701e4f60
--- /dev/null
+++ b/app-text/xchm/xchm-1.16.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/xchm-1.16.ebuild,v 1.1 2009/05/16 22:10:38 dirtyepic Exp $
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets flag-o-matic fdo-mime gnome2-utils
+
+DESCRIPTION="Utility for viewing Microsoft .chm files."
+HOMEPAGE="http://xchm.sf.net"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="nls"
+DEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:2.8"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ append-flags -fno-strict-aliasing
+}
+
+src_configure() {
+ econf ${myconf} \
+ $(use_enable nls) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS README ChangeLog
+
+ cp "${D}"/usr/share/pixmaps/xchm-32.xpm "${D}"/usr/share/pixmaps/xchm.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchm-*.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchmdoc*.xpm
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}