summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-04-19 09:23:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-04-19 09:23:07 +0000
commit8675af102ea92215fdab38ccc6bb236e3444eff5 (patch)
treec1437adae0b5ed2d095c8afe32ff78d39a38d09a /app-text
parentMask fontconfig non-maintainer ebuild (diff)
downloadgentoo-2-8675af102ea92215fdab38ccc6bb236e3444eff5.tar.gz
gentoo-2-8675af102ea92215fdab38ccc6bb236e3444eff5.tar.bz2
gentoo-2-8675af102ea92215fdab38ccc6bb236e3444eff5.zip
Version bump to the latest. Update license.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libwpd/ChangeLog9
-rw-r--r--app-text/libwpd/libwpd-0.9.7.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/app-text/libwpd/ChangeLog b/app-text/libwpd/ChangeLog
index da24172f80e4..721ba54b4273 100644
--- a/app-text/libwpd/ChangeLog
+++ b/app-text/libwpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libwpd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/ChangeLog,v 1.103 2012/10/24 14:50:54 scarabeus Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/ChangeLog,v 1.104 2013/04/19 09:23:07 scarabeus Exp $
+
+*libwpd-0.9.7 (19 Apr 2013)
+
+ 19 Apr 2013; Tomáš Chvátal <scarabeus@gentoo.org> +libwpd-0.9.7.ebuild:
+ Version bump to the latest. Update license.
24 Oct 2012; Tomáš Chvátal <scarabeus@gentoo.org> -libwpd-0.9.4.ebuild,
libwpd-0.9.6.ebuild:
diff --git a/app-text/libwpd/libwpd-0.9.7.ebuild b/app-text/libwpd/libwpd-0.9.7.ebuild
new file mode 100644
index 000000000000..9068024219ee
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.9.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/libwpd-0.9.7.ebuild,v 1.1 2013/04/19 09:23:07 scarabeus Exp $
+
+EAPI=5
+
+inherit alternatives eutils
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test +tools"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${RDEPEND}
+ !<app-text/libwpd-0.8.14-r1"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_with tools stream) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9]"
+ fi
+}
+
+pkg_postrm() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9]"
+ fi
+}