summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-21 16:19:59 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-21 16:19:59 +0000
commit80cb31ada928e9c31d0e4b56e2a4f147c708d929 (patch)
tree252b903304b592c1bac18b90c467382ab8d01cbc /app-text
parentversion bump (diff)
downloadgentoo-2-80cb31ada928e9c31d0e4b56e2a4f147c708d929.tar.gz
gentoo-2-80cb31ada928e9c31d0e4b56e2a4f147c708d929.tar.bz2
gentoo-2-80cb31ada928e9c31d0e4b56e2a4f147c708d929.zip
fixes for libwww
Diffstat (limited to 'app-text')
-rw-r--r--app-text/tetex/ChangeLog10
-rw-r--r--app-text/tetex/files/digest-tetex-1.0.7-r104
-rw-r--r--app-text/tetex/tetex-1.0.7-r10.ebuild166
3 files changed, 179 insertions, 1 deletions
diff --git a/app-text/tetex/ChangeLog b/app-text/tetex/ChangeLog
index c0c7908f41d5..9f003e9416e2 100644
--- a/app-text/tetex/ChangeLog
+++ b/app-text/tetex/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/tetex
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/tetex/ChangeLog,v 1.4 2002/04/24 18:27:26 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/tetex/ChangeLog,v 1.5 2002/06/21 16:19:59 seemant Exp $
+
+*tetex-1.0.7-r10 (20 Jun 2002)
+
+ 20 Jun 2002; Seemant Kulleen <seemant@gentoo.org> tetex-1.0.7-r10.ebuild
+ files/digest-tetex-1.0.7-r10 :
+
+ Fixed libwww configure option, so it now knows where to look for the
+ headers. This closes bug #3928 by fatwreckfan@hotmail.com (Mark Trolley)
*tetex-1.0.7-r9 (24 Apr 2002)
diff --git a/app-text/tetex/files/digest-tetex-1.0.7-r10 b/app-text/tetex/files/digest-tetex-1.0.7-r10
new file mode 100644
index 000000000000..b0dad1273c70
--- /dev/null
+++ b/app-text/tetex/files/digest-tetex-1.0.7-r10
@@ -0,0 +1,4 @@
+MD5 2c6da2a45096c2fdc41b8de6a8af1a52 teTeX-src-1.0.7.tar.gz 8040192
+MD5 984530be5cc0dd73738de9d0067bc130 teTeX-texmf-gg-1.0.3.tar.bz2 35037546
+MD5 12925188fdadcd6a970c21bba3269fc2 ec-ready-mf-tfm.tar.gz 386630
+MD5 37393316b285926214c247acd55db743 teTeX-french.tar.gz 268161
diff --git a/app-text/tetex/tetex-1.0.7-r10.ebuild b/app-text/tetex/tetex-1.0.7-r10.ebuild
new file mode 100644
index 000000000000..c661418dcfa6
--- /dev/null
+++ b/app-text/tetex/tetex-1.0.7-r10.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/tetex/tetex-1.0.7-r10.ebuild,v 1.1 2002/06/21 16:19:59 seemant Exp $
+
+TEXMFSRC="teTeX-texmf-gg-1.0.3.tar.bz2"
+
+S=${WORKDIR}/teTeX-1.0
+DESCRIPTION="teTeX is a complete TeX distribution"
+SRC_URI="ftp://sunsite.informatik.rwth-aachen.de/pub/comp/tex/teTeX/1.0/distrib/sources/teTeX-src-1.0.7.tar.gz
+ ftp://ftp.dante.de/pub/tex/systems/unix/teTeX/1.0/contrib/ghibo/${TEXMFSRC}
+ http://www.ibiblio.org/gentoo/distfiles/ec-ready-mf-tfm.tar.gz
+ http://www.ibiblio.org/gentoo/distfiles/teTeX-french.tar.gz"
+HOMEPAGE="http://tug.cs.umb.edu/tetex/"
+
+DEPEND="sys-apps/ed
+ sys-libs/zlib
+ X? ( virtual/x11 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ ncurses ( sys-libs/ncurses )
+ libwww? ( >=net-libs/libwww-5.3.2-r1 )"
+
+RDEPEND=">=sys-devel/perl-5.2
+ dev-util/dialog"
+
+
+src_unpack() {
+
+ unpack teTeX-src-1.0.7.tar.gz
+
+ mkdir ${S}/texmf
+ cd ${S}/texmf
+ echo ">>> Unpacking ${TEXMFSRC}"
+ tar xjf ${DISTDIR}/${TEXMFSRC}
+ echo ">>> Unpacking ec-ready-mf-tfm.tar.gz"
+ tar xzf ${DISTDIR}/ec-ready-mf-tfm.tar.gz -C ..
+ echo ">>> Unpacking teTeX-french.tar.gz"
+ tar xzf ${DISTDIR}/teTeX-french.tar.gz
+
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/teTeX-1.0-gentoo.diff || die
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/teTeX-1.0.dif || die
+
+ # Fix problem where the *.fmt files are not generated due to the LaTeX
+ # source being older than a year.
+# local x
+# for x in `find ${S}/texmf/ -type f -name '*.ini'`
+# do
+# cp ${x} ${x}.orig
+# sed -e '1i \\scrollmode' ${x}.orig > ${x}
+# rm -f ${x}.orig
+# done
+
+}
+
+src_compile() {
+
+ local myconf
+ use X \
+ && myconf="--with-x" \
+ || myconf="--without-x"
+
+ use libwww && ( \
+ myconf="${myconf} --with-system-wwwlib"
+ myconf="${myconf} --with-libwww-include=/usr/include"
+ )
+
+ use png \
+ && myconf="${myconf} --with-system-pnglib"
+
+
+ use ncurse \
+ && myconf="${myconf} --with-system-ncurses"
+
+
+ # Does it make sense to compile the included libwww with mysql ?
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=${S} \
+ --without-texinfo \
+ --without-dialog \
+ --with-system-zlib \
+ --disable-multiplatform \
+ --with-epsfwin \
+ --with-mftalkwin \
+ --with-regiswin \
+ --with-tektronixwin \
+ --with-unitermwin \
+ --with-ps=gs \
+ --enable-ipc \
+ --with-etex \
+ ${myconf} || die
+
+ make texmf=/usr/share/texmf || die
+}
+
+src_install() {
+
+ cd ${S}
+ dodir /usr/share/
+ cp -af texmf ${D}/usr/share
+ sed -e 's: \$(scriptdir)/mktexlsr: echo:' \
+ -e 's:\$(scriptdir)/texconfig init:echo:' \
+ Makefile > Makefile.install
+ make prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ datadir=${D}/usr/share \
+ mandir=${D}/usr/share/man/man1 \
+ infodir=${D}/usr/share/info \
+ texmf=${D}/usr/share/texmf \
+ -f Makefile.install \
+ install || die
+
+ dodoc PROBLEMS README
+ docinto texk
+ dodoc texk/ChangeLog texk/README
+ docinto kpathesa
+ cd ${S}/texk/kpathsea
+ dodoc README* NEWS PROJECTS HIER
+ docinto dviljk
+ cd ${S}/texk/dviljk
+ dodoc AUTHORS README NEWS
+ docinto dvipsk
+ cd ${S}/texk/dvipsk
+ dodoc AUTHORS ChangeLog INSTALLATION README
+ docinto makeindexk
+ cd ${S}/texk/makeindexk
+ dodoc CONTRIB COPYING NEWS NOTES PORTING README
+ docinto ps2pkm
+ cd ${S}/texk/ps2pkm
+ dodoc ChangeLog CHANGES.type1 INSTALLATION README*
+ docinto web2c
+ cd ${S}/texk/web2c
+ dodoc AUTHORS ChangeLog NEWS PROJECTS README
+ docinto xdvik
+ cd ${S}/texk/xdvik
+ dodoc BUGS FAQ README*
+
+ #fix for conflicting readlink binary:
+ rm ${D}/bin/readlink
+ #add /var/cache/fonts directory
+ dodir /var/cache/fonts
+
+ #fix for lousy upstream permisssions on /usr/share/texmf files
+ fowners root.root /usr/share/texmf/*
+}
+
+pkg_postinst() {
+
+ if [ $ROOT = "/" ]
+ then
+ echo ">>> Configuring teTeX..."
+ mktexlsr >/dev/null 2>&1
+ texlinks >/dev/null 2>&1
+ texconfig init >/dev/null 2>&1
+ texconfig confall >/dev/null 2>&1
+ texconfig font vardir /var/cache/fonts >/dev/null 2>&1
+ echo "*** use 'texconfig font rw' to allow all users to generate fonts ***"
+ fi
+}