summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-11 01:38:52 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-11 01:38:52 +0000
commit7e1cafd98695bdb913346ec4a4cabc5ee563f1bc (patch)
tree4de22eda4ae245f8244c7970c00e32555b254717 /app-text
parentVersion bump. (diff)
downloadgentoo-2-7e1cafd98695bdb913346ec4a4cabc5ee563f1bc.tar.gz
gentoo-2-7e1cafd98695bdb913346ec4a4cabc5ee563f1bc.tar.bz2
gentoo-2-7e1cafd98695bdb913346ec4a4cabc5ee563f1bc.zip
Version bump.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dos2unix/ChangeLog7
-rw-r--r--app-text/dos2unix/dos2unix-5.3.3.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index 840d525e30cd..ed6313e52752 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/dos2unix
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.83 2012/03/04 07:32:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.84 2012/03/11 01:38:52 radhermit Exp $
+
+*dos2unix-5.3.3 (11 Mar 2012)
+
+ 11 Mar 2012; Tim Harder <radhermit@gentoo.org> +dos2unix-5.3.3.ebuild:
+ Version bump.
04 Mar 2012; Justin Lecher <jlec@gentoo.org> -dos2unix-5.2.1.ebuild:
Clean old
diff --git a/app-text/dos2unix/dos2unix-5.3.3.ebuild b/app-text/dos2unix/dos2unix-5.3.3.ebuild
new file mode 100644
index 000000000000..33d85ebf8dd4
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-5.3.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.3.3.ebuild,v 1.1 2012/03/11 01:38:52 radhermit Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls"
+
+RDEPEND="
+ !app-text/hd2u
+ !app-text/unix2dos
+ virtual/libintl"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/^CC/s|=|?=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(use nls && echo "LDFLAGS_EXTRA=$(lintl)" || echo "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(use nls || echo "ENABLE_NLS=") install
+}