summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-21 20:34:57 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-21 20:34:57 +0000
commit7ddb890e970d9e07011cacdd4b16806c6edbd3f3 (patch)
tree167937705bdc91c69b8f6c9441f552f591544329 /app-text
parentslotmove net-im/choqok from 0 to 4 (diff)
downloadgentoo-2-7ddb890e970d9e07011cacdd4b16806c6edbd3f3.tar.gz
gentoo-2-7ddb890e970d9e07011cacdd4b16806c6edbd3f3.tar.bz2
gentoo-2-7ddb890e970d9e07011cacdd4b16806c6edbd3f3.zip
Initial import. Ebuild by me and Constantin Bergemann, bug #219138. Required for pidgintex but is useful on its own ;)
(Portage version: 2.1.7.15/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/mathtex/ChangeLog11
-rw-r--r--app-text/mathtex/mathtex-1.03.ebuild44
-rw-r--r--app-text/mathtex/metadata.xml16
3 files changed, 71 insertions, 0 deletions
diff --git a/app-text/mathtex/ChangeLog b/app-text/mathtex/ChangeLog
new file mode 100644
index 000000000000..23d35bf55bf8
--- /dev/null
+++ b/app-text/mathtex/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/mathtex
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mathtex/ChangeLog,v 1.1 2009/12/21 20:34:57 pva Exp $
+
+*mathtex-1.03 (21 Dec 2009)
+
+ 21 Dec 2009; Peter Volkov <pva@gentoo.org> +mathtex-1.03.ebuild,
+ +metadata.xml:
+ Initial import. Ebuild by me and Constantin Bergemann, bug #219138.
+ Required for pidgintex but is useful on its own ;)
+
diff --git a/app-text/mathtex/mathtex-1.03.ebuild b/app-text/mathtex/mathtex-1.03.ebuild
new file mode 100644
index 000000000000..c1698b33069a
--- /dev/null
+++ b/app-text/mathtex/mathtex-1.03.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mathtex/mathtex-1.03.ebuild,v 1.1 2009/12/21 20:34:57 pva Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="MathTeX lets you easily embed LaTeX math in your own html pages, blogs, wikis, etc"
+HOMEPAGE="http://www.forkosh.com/mathtex.html"
+SRC_URI="http://www.forkosh.com/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/dvipng
+ virtual/latex-base"
+DEPEND=""
+
+einfo_run_command() {
+ einfo "${@}"
+ ${@} || die
+}
+
+src_compile() {
+ einfo_run_command $(tc-getCC) \
+ ${CFLAGS} ${LDFLAGS} \
+ -DLATEX=\"/usr/bin/latex\" \
+ -DDVIPNG=\"/usr/bin/dvipng\" \
+ mathtex.c -o mathtex
+}
+
+src_install() {
+ dobin mathtex || die
+ dodoc README || die
+ dohtml mathtex.html || die
+}
+
+pkg_postinst() {
+ elog "To use mathtex in your web-pages, just link /usr/bin/mathtex"
+ elog "to your cgi-bin subdirectory!"
+}
diff --git a/app-text/mathtex/metadata.xml b/app-text/mathtex/metadata.xml
new file mode 100644
index 000000000000..ab1c52d05973
--- /dev/null
+++ b/app-text/mathtex/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+</maintainer>
+<longdescription>
+ MathTeX parses a LaTeX math expression and immediately emits the corresponding
+ gif (or png) image. It can be used as cgi program to embed LaTeX math in your
+ own html pages, blogs, wikis, etc. Just place an html img tag in your
+ document wherever you want to see the corresponding LaTeX expression. Take a
+ look at homepage for examples.
+</longdescription>
+</pkgmetadata>