summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-18 09:36:24 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-18 09:36:24 +0000
commit7ccd97a6b4c686718053047bd04f8bc14e6b8179 (patch)
tree3cd9f14490e0103c25189f53d4085978aca4ee75 /app-text
parentVersion bump, bug #437574 (diff)
downloadgentoo-2-7ccd97a6b4c686718053047bd04f8bc14e6b8179.tar.gz
gentoo-2-7ccd97a6b4c686718053047bd04f8bc14e6b8179.tar.bz2
gentoo-2-7ccd97a6b4c686718053047bd04f8bc14e6b8179.zip
Fix issue with incorrect parsing of '-g' compile flag in configure script. Thanks to Agostino Sarubbo for discovering this issue
(Portage version: 2.2.0_alpha140/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/rtf2html/ChangeLog6
-rw-r--r--app-text/rtf2html/rtf2html-0.2.0-r1.ebuild8
2 files changed, 12 insertions, 2 deletions
diff --git a/app-text/rtf2html/ChangeLog b/app-text/rtf2html/ChangeLog
index 5170ffcf8623..0ddd0461054e 100644
--- a/app-text/rtf2html/ChangeLog
+++ b/app-text/rtf2html/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/rtf2html
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/ChangeLog,v 1.5 2012/10/18 08:17:00 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/ChangeLog,v 1.6 2012/10/18 09:36:24 pinkbyte Exp $
+
+ 18 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> rtf2html-0.2.0-r1.ebuild:
+ Fix issue with incorrect parsing of '-g' compile flag in configure script.
+ Thanks to Agostino Sarubbo for discovering this issue
18 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> rtf2html-0.2.0-r1.ebuild:
Remove duplicate IUSE definition
diff --git a/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
index d39018182299..e981c4eec5b4 100644
--- a/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
+++ b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild,v 1.2 2012/10/18 08:17:00 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild,v 1.3 2012/10/18 09:36:24 pinkbyte Exp $
EAPI="4"
@@ -21,3 +21,9 @@ RDEPEND="${DEPEND}"
DOCS=( ChangeLog README )
PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+
+src_prepare() {
+ sed -i -e '/CFLAGS=$(echo $CFLAGS/d' configure || die 'sed on configure failed'
+
+ base_src_prepare
+}