summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-05-22 11:15:24 +0000
committerPeter Volkov <pva@gentoo.org>2007-05-22 11:15:24 +0000
commit7bf85559decd9edd5f41dde6baaa845fbb35427e (patch)
tree5ec0286201cb4716cdbe8069ffd0fefc4bb3f01c /app-text
parentfix itk patch name (diff)
downloadgentoo-2-7bf85559decd9edd5f41dde6baaa845fbb35427e.tar.gz
gentoo-2-7bf85559decd9edd5f41dde6baaa845fbb35427e.tar.bz2
gentoo-2-7bf85559decd9edd5f41dde6baaa845fbb35427e.zip
Version bump (bug #166016). Bug #97995 (mozilla-firefox crash when opening a djvu file using the djvu plugin reported by Amit Kotlovski <krallkrall AT gmail.com>) and bug #150492 (app-text/djvu breaks images with X option "Composite" enabled reported by <rpansky AT mail.ru>) should be fixed. Automatic QT dependency reported by Michal Kurgan <moloh AT gentoo.org> is fixed too.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/djvu/ChangeLog12
-rw-r--r--app-text/djvu/djvu-3.5.19.ebuild112
-rw-r--r--app-text/djvu/files/digest-djvu-3.5.193
-rw-r--r--app-text/djvu/metadata.xml14
4 files changed, 140 insertions, 1 deletions
diff --git a/app-text/djvu/ChangeLog b/app-text/djvu/ChangeLog
index 6640003d4d84..550af779859d 100644
--- a/app-text/djvu/ChangeLog
+++ b/app-text/djvu/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-text/djvu
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.58 2007/04/07 13:25:23 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.59 2007/05/22 11:15:24 pva Exp $
+
+*djvu-3.5.19 (22 May 2007)
+
+ 22 May 2007; <pva@gentoo.org> metadata.xml, +djvu-3.5.19.ebuild:
+ Version bump (bug #166016). Bug #97995 (mozilla-firefox crash when opening a
+ djvu file using the djvu plugin reported by Amit Kotlovski <krallkrall AT
+ gmail.com>) and bug #150492 (app-text/djvu breaks images with X option
+ "Composite" enabled reported by <rpansky AT mail.ru>) should be fixed.
+ Automatic QT dependency reported by Michal Kurgan <moloh AT gentoo.org> is
+ fixed too.
07 Apr 2007; Petteri Räty <betelgeuse@gentoo.org> -djvu-3.5.12.ebuild,
-djvu-3.5.14.ebuild, -djvu-3.5.14-r1.ebuild, -djvu-3.5.16.ebuild:
diff --git a/app-text/djvu/djvu-3.5.19.ebuild b/app-text/djvu/djvu-3.5.19.ebuild
new file mode 100644
index 000000000000..8e47576be2e3
--- /dev/null
+++ b/app-text/djvu/djvu-3.5.19.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.19.ebuild,v 1.1 2007/05/22 11:15:24 pva Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit fdo-mime nsplugins flag-o-matic eutils multilib toolchain-funcs autotools
+
+MY_P="${PN}libre-${PV}"
+
+DESCRIPTION="DjVu viewers, encoders and utilities."
+HOMEPAGE="http://djvu.sourceforge.net"
+SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="xml qt3 jpeg tiff debug threads nls nsplugin kde doc"
+
+DEPEND="jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( media-libs/tiff )
+ qt3? ( <x11-libs/qt-4 )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! use qt3; then
+ ewarn
+ ewarn "The standalone djvu viewer, djview, will not be compiled."
+ ewarn "Add \"qt3\" to your USE flags if you want it."
+ ewarn
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Do not strip binaries as portage does this for us. bug #135208
+ sed -i 's:${INSTALL_PROGRAM} -s:${INSTALL_PROGRAM}:' \
+ gui/djview/Makefile.in tools/Makefile.in xmltools/Makefile.in
+
+ # Fix compilaton with --as-needed. bug #132473
+ epatch "${FILESDIR}"/djvulibre-3.5.17-pthread-flag.patch
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_compile() {
+ # assembler problems and hence non-building with pentium4
+ # <obz@gentoo.org>
+ replace-flags -march=pentium4 -march=pentium3
+ echo LINGUAS=$LINGUAS
+
+ # When enabling qt it must be compiled with threads. See bug #89544.
+ if use qt3 ; then
+ QTCONF=" --with-qt --enable-threads "
+ elif use threads ; then
+ QTCONF=" --without-qt --disable-djview --enable-threads "
+ else
+ QTCONF=" --without-qt --disable-djview --disable-threads "
+ fi
+
+ # We install all desktop files by hand.
+ econf --disable-desktopfiles \
+ $(use_enable xml xmltools) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ $(use_enable nls i18n) \
+ $(use_enable debug) \
+ ${QTCONF} \
+ || die "econf failed"
+
+ if ! use nsplugin; then
+ sed -e 's:nsdejavu::' -i "${S}"/gui/Makefile || die
+ fi
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" plugindir=/usr/$(get_libdir)/${PLUGINS_DIR} install
+
+ dodoc README TODO NEWS
+
+ use doc && cp -r doc/ "${D}"/usr/share/doc/${PF}
+
+ # Install desktop files.
+ cd desktopfiles
+ insinto /usr/share/icons/hicolor/22x22/mimetypes && newins hi22-djvu.png image-vnd.djvu.png
+ insinto /usr/share/icons/hicolor/32x32/mimetypes && newins hi32-djvu.png image-vnd.djvu.png
+ insinto /usr/share/icons/hicolor/48x48/mimetypes && newins hi48-djvu.png image-vnd.djvu.png
+ insinto /usr/share/mime/packages && doins djvulibre-mime.xml
+ if use kde ; then
+ insinto /usr/share/mimelnk/image && doins vnd.djvu.desktop x-djvu.desktop
+ cp "${D}"/usr/share/mimelnk/image/{vnd.djvu.desktop,x-djvu.desktop}
+ sed -i -e 's:image/vnd.djvu:image/x-djvu:' "${D}"/usr/share/mimelnk/image/x-djvu.desktop
+ fi
+
+ insinto /usr/share/icons/hicolor/32x32/apps && newins hi32-djview3.png djvulibre-djview3.png
+ insinto /usr/share/applications/ && doins djvulibre-djview3.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/app-text/djvu/files/digest-djvu-3.5.19 b/app-text/djvu/files/digest-djvu-3.5.19
new file mode 100644
index 000000000000..3fb5fdd6713e
--- /dev/null
+++ b/app-text/djvu/files/digest-djvu-3.5.19
@@ -0,0 +1,3 @@
+MD5 0330d87ad337e408e21e1018eb511839 djvulibre-3.5.19.tar.gz 2380092
+RMD160 2eb9b5df021bb7121a051d3256999da27dd3b682 djvulibre-3.5.19.tar.gz 2380092
+SHA256 57ffa154f45de309b352ce53aa6618af2f8639d1e330470c3c955241d44ccd78 djvulibre-3.5.19.tar.gz 2380092
diff --git a/app-text/djvu/metadata.xml b/app-text/djvu/metadata.xml
index ba6a8a8800d5..04ed31687e86 100644
--- a/app-text/djvu/metadata.xml
+++ b/app-text/djvu/metadata.xml
@@ -2,4 +2,18 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>tex</herd>
+<maintainer>
+ <email>pva@gentoo.org</email>
+ <name>Peter Volkov</name>
+</maintainer>
+<longdescription>
+DjVu is a web-centric format and software platform for distributing documents
+and images. DjVu can advantageously replace PDF, PS, TIFF, JPEG, and GIF for
+distributing scanned documents, digital documents, or high-resolution pictures.
+DjVu content downloads faster, displays and renders faster, looks nicer on a
+screen, and consume less client resources than competing formats. DjVu images
+display instantly and can be smoothly zoomed and panned with no lengthy
+re-rendering. DjVu is used by hundreds of academic, commercial, governmental,
+and non-commercial web sites around the world.
+</longdescription>
</pkgmetadata>