summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-02-09 08:52:36 +0000
committerTim Harder <radhermit@gentoo.org>2011-02-09 08:52:36 +0000
commit7173a6990f0fad46bd1713fbc3d191f47546c50f (patch)
treed0e213761f1d18097c4a06941a180886f89afe98 /app-text
parentx86 stable wrt bug #353870 (diff)
downloadgentoo-2-7173a6990f0fad46bd1713fbc3d191f47546c50f.tar.gz
gentoo-2-7173a6990f0fad46bd1713fbc3d191f47546c50f.tar.bz2
gentoo-2-7173a6990f0fad46bd1713fbc3d191f47546c50f.zip
Version bump for bug #337531. Bump to EAPI 4, add examples USE flag, explicitly set RDEPEND="${DEPEND}", and fix parallel make issue.
(Portage version: 2.2.0_alpha22/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/highlight/ChangeLog11
-rw-r--r--app-text/highlight/files/highlight-3.3-parallel-make.patch11
-rw-r--r--app-text/highlight/highlight-3.3.ebuild57
3 files changed, 77 insertions, 2 deletions
diff --git a/app-text/highlight/ChangeLog b/app-text/highlight/ChangeLog
index 85affc24d26f..059d51851a3e 100644
--- a/app-text/highlight/ChangeLog
+++ b/app-text/highlight/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/highlight
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.33 2010/06/19 08:16:01 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.34 2011/02/09 08:52:35 radhermit Exp $
+
+*highlight-3.3 (09 Feb 2011)
+
+ 09 Feb 2011; Tim Harder <radhermit@gentoo.org> +highlight-3.3.ebuild,
+ +files/highlight-3.3-parallel-make.patch:
+ Version bump for bug #337531. Bump to EAPI 4, add examples USE flag,
+ explicitly set RDEPEND="${DEPEND}", and fix parallel make issue.
*highlight-3.0_beta (19 Jun 2010)
diff --git a/app-text/highlight/files/highlight-3.3-parallel-make.patch b/app-text/highlight/files/highlight-3.3-parallel-make.patch
new file mode 100644
index 000000000000..9d56c5e60eb5
--- /dev/null
+++ b/app-text/highlight/files/highlight-3.3-parallel-make.patch
@@ -0,0 +1,11 @@
+--- highlight-3.3/src/makefile.orig
++++ highlight-3.3/src/makefile
+@@ -103,7 +103,7 @@
+ highlight-gui: libhighlight.a ${GUI_OBJECTS}
+ cd gui-qt && \
+ ${QMAKE} 'DEFINES+=DATA_DIR=\\\"${HL_DATA_DIR}\\\" CONFIG_DIR=\\\"${HL_CONFIG_DIR}\\\" DOC_DIR=\\\"${HL_DOC_DIR}\\\"' && \
+- make
++ $(MAKE)
+
+ $(OBJECTFILES) : makefile
+
diff --git a/app-text/highlight/highlight-3.3.ebuild b/app-text/highlight/highlight-3.3.ebuild
new file mode 100644
index 000000000000..8843bffd7f15
--- /dev/null
+++ b/app-text/highlight/highlight-3.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.3.ebuild,v 1.1 2011/02/09 08:52:36 radhermit Exp $
+
+EAPI=4
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="converts source code to formatted text ((X)HTML, RTF, (La)TeX, XSL-FO, XML) with syntax highlight"
+HOMEPAGE="http://www.andre-simon.de/"
+SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="examples qt4"
+
+DEPEND="dev-lang/lua
+ qt4? ( x11-libs/qt-gui:4 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ myhlopts=(
+ "CXX=$(tc-getCXX)"
+ "DESTDIR=${D}"
+ "PREFIX=${EPREFIX}/usr"
+ "doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
+ "conf_dir=${EPREFIX}/etc/highlight/"
+ )
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+
+ sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
+ src/core/datadir.cpp || die
+
+ sed -i -e 's:-O2::' \
+ -e 's:CFLAGS:CXXFLAGS:g' \
+ src/makefile || die
+}
+
+src_compile() {
+ emake -f makefile "${myhlopts[@]}"
+ use qt4 && emake -f makefile "${myhlopts[@]}" gui
+}
+
+src_install() {
+ emake -f makefile "${myhlopts[@]}" install
+ use qt4 && emake -f makefile "${myhlopts[@]}" install-gui
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ rm -rf "${D}"/usr/share/doc/${PF}/examples
+ fi
+}