summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2010-03-09 17:40:34 +0000
committerSerkan Kaba <serkan@gentoo.org>2010-03-09 17:40:34 +0000
commit6a014caae218f8d8b541f0b92ecfc07ae1cc0cb9 (patch)
tree6f27149b258ca421afd17768fd4c51ab36b5c674 /app-text
parentVersion bump (bug #308493). (diff)
downloadgentoo-2-6a014caae218f8d8b541f0b92ecfc07ae1cc0cb9.tar.gz
gentoo-2-6a014caae218f8d8b541f0b92ecfc07ae1cc0cb9.tar.bz2
gentoo-2-6a014caae218f8d8b541f0b92ecfc07ae1cc0cb9.zip
Version bump. Fix upstream bug #12305.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enchant/ChangeLog10
-rw-r--r--app-text/enchant/enchant-1.5.0.ebuild66
-rw-r--r--app-text/enchant/files/enchant-1.5.0-zemberek.patch16
3 files changed, 90 insertions, 2 deletions
diff --git a/app-text/enchant/ChangeLog b/app-text/enchant/ChangeLog
index b3ddf417f78f..7b319b783240 100644
--- a/app-text/enchant/ChangeLog
+++ b/app-text/enchant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/enchant
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/ChangeLog,v 1.96 2009/04/12 21:04:12 bluebird Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/ChangeLog,v 1.97 2010/03/09 17:40:33 serkan Exp $
+
+*enchant-1.5.0 (09 Mar 2010)
+
+ 09 Mar 2010; Serkan Kaba <serkan@gentoo.org> +enchant-1.5.0.ebuild,
+ +files/enchant-1.5.0-zemberek.patch:
+ Version bump. Fix upstream bug #12305.
12 Apr 2009; Friedrich Oslage <bluebird@gentoo.org> enchant-1.4.2.ebuild:
Stable on sparc, bug #260063
diff --git a/app-text/enchant/enchant-1.5.0.ebuild b/app-text/enchant/enchant-1.5.0.ebuild
new file mode 100644
index 000000000000..9ac27a659bee
--- /dev/null
+++ b/app-text/enchant/enchant-1.5.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/enchant-1.5.0.ebuild,v 1.1 2010/03/09 17:40:33 serkan Exp $
+
+EAPI="1"
+inherit libtool confutils autotools
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="http://www.abisource.com/enchant/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="aspell +hunspell zemberek"
+
+COMMON_DEPENDS=">=dev-libs/glib-2
+ aspell? ( virtual/aspell-dict )
+ hunspell? ( >=app-text/hunspell-1.2.1 )
+ zemberek? ( dev-libs/dbus-glib )"
+
+RDEPEND="${COMMON_DEPENDS}
+ zemberek? ( app-text/zemberek-server )"
+
+# libtool is needed for the install-sh to work
+DEPEND="${COMMON_DEPENDS}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ confutils_require_any aspell hunspell zemberek
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix for upstream bug #12305
+ # http://bugzilla.abisource.com/show_bug.cgi?id=12305
+ epatch "${FILESDIR}"/${P}-zemberek.patch
+ sed -i -e 's:noinst_PROGRAMS:check_PROGRAMS:' tests/Makefile.am \
+ || die "unable to remove testdefault build"
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable aspell) \
+ $(use_enable hunspell myspell) \
+ $(use_enable zemberek) \
+ --disable-ispell \
+ --with-myspell-dir=/usr/share/myspell/
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO
+}
+
+pkg_postinst() {
+ ewarn "Starting with ${PN}-1.4.0 default spell checking engine has changed"
+ ewarn "from aspell to hunspell. In case you used aspell dictionaries to"
+ ewarn "check spelling you need either reemerge ${PN} with aspell USE flag"
+ ewarn "or you need to emerge myspell-<lang> dictionaries."
+ ewarn "aspell is faster but has less features then hunspell and most"
+ ewarn "distributions by default use hunspell only. Nevertheless in Gentoo"
+ ewarn "it's still your choice which library to use..."
+}
diff --git a/app-text/enchant/files/enchant-1.5.0-zemberek.patch b/app-text/enchant/files/enchant-1.5.0-zemberek.patch
new file mode 100644
index 000000000000..3a8da00cb273
--- /dev/null
+++ b/app-text/enchant/files/enchant-1.5.0-zemberek.patch
@@ -0,0 +1,16 @@
+--- enchant/trunk/src/zemberek/zemberek.cpp 2009/01/25 14:30:57 25545
++++ enchant/trunk/src/zemberek/zemberek.cpp 2009/10/26 14:11:04 28392
+@@ -43,10 +43,11 @@
+ g_error_free (Error);
+ return false;
+ }
+- proxy = dbus_g_proxy_new_for_name (connection,
++ proxy = dbus_g_proxy_new_for_name_owner (connection,
+ "net.zemberekserver.server.dbus",
+ "/net/zemberekserver/server/dbus/ZemberekDbus",
+- "net.zemberekserver.server.dbus.ZemberekDbusInterface");
++ "net.zemberekserver.server.dbus.ZemberekDbusInterface",
++ &Error);
+
+ dbus_g_connection_unref (connection);
+ if (proxy == NULL) {