summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-10-09 18:24:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-10-09 18:24:00 +0000
commit67f2e7afccd08250d8be0a9b346db4bd8dabf88b (patch)
treedd82d442ea21703e6f1a24ece3746458f0d58892 /app-text
parentAdd live ebuild and make 0.3.0-r1 and 9999 share all code, fix musepack depen... (diff)
downloadgentoo-2-67f2e7afccd08250d8be0a9b346db4bd8dabf88b.tar.gz
gentoo-2-67f2e7afccd08250d8be0a9b346db4bd8dabf88b.tar.bz2
gentoo-2-67f2e7afccd08250d8be0a9b346db4bd8dabf88b.zip
Bump to 3.5.22, fixes #287339
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/djvu/ChangeLog9
-rw-r--r--app-text/djvu/djvu-3.5.22.ebuild111
2 files changed, 118 insertions, 2 deletions
diff --git a/app-text/djvu/ChangeLog b/app-text/djvu/ChangeLog
index 062980a0f918..c0be9c1b5979 100644
--- a/app-text/djvu/ChangeLog
+++ b/app-text/djvu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/djvu
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.95 2009/04/15 16:53:46 ranger Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.96 2009/10/09 18:24:00 patrick Exp $
+
+*djvu-3.5.22 (09 Oct 2009)
+
+ 09 Oct 2009; Patrick Lauer <patrick@gentoo.org> +djvu-3.5.22.ebuild:
+ Bump to 3.5.22, fixes #287339
15 Apr 2009; Brent Baude <ranger@gentoo.org> djvu-3.5.21_p20090103.ebuild:
Marking djvu-3.5.21_p20090103 ppc64 for bug 262776
diff --git a/app-text/djvu/djvu-3.5.22.ebuild b/app-text/djvu/djvu-3.5.22.ebuild
new file mode 100644
index 000000000000..fa064e431e61
--- /dev/null
+++ b/app-text/djvu/djvu-3.5.22.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.22.ebuild,v 1.1 2009/10/09 18:24:00 patrick Exp $
+
+EAPI=1
+inherit fdo-mime nsplugins flag-o-matic eutils multilib toolchain-funcs confutils
+
+MY_P="${PN}libre-${PV#*_p}"
+
+DESCRIPTION="DjVu viewers, encoders and utilities."
+HOMEPAGE="http://djvu.sourceforge.net"
+SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="xml qt3 jpeg tiff debug nls nsplugin kde doc"
+
+RDEPEND="jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( media-libs/tiff )
+ qt3? ( x11-libs/qt:3 )"
+DEPEND="${RDEPEND}
+ qt3? ( nsplugin? ( x11-libs/libXt ) )"
+
+S=${WORKDIR}/${MY_P}
+
+LANGS="cs de en fr ja zh"
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+pkg_setup() {
+ if ! use qt3; then
+ ewarn
+ ewarn "The standalone djvu viewer, djview, will not be compiled."
+ ewarn "Add \"qt3\" to your USE flags if you want it."
+ ewarn
+ fi
+
+ confutils_use_depend_all nsplugin qt3
+}
+
+src_compile() {
+ local I18N
+ if use nls; then
+ for X in ${LANGS}; do
+ if use linguas_${X}; then
+ I18N="${I18N} ${X}"
+ fi
+ done
+ I18N="${I18N# }"
+ if test -n "$I18N"; then
+ I18N="--enable-i18n=${I18N}"
+ else
+ I18N="--enable-i18n"
+ fi
+ else
+ I18N="--disable-i18n"
+ fi
+
+ # We install all desktop files by hand.
+ econf --disable-desktopfiles \
+ $(use_with qt3 qt) \
+ $(use_enable xml xmltools) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ "${I18N}" \
+ $(use_enable debug) \
+ ${QTCONF}
+
+ if ! use nsplugin; then
+ sed -e 's:nsdejavu::' -i "${S}"/gui/Makefile || die
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" plugindir=/usr/$(get_libdir)/${PLUGINS_DIR} install
+
+ dodoc README TODO NEWS
+
+ use doc && cp -r doc/ "${D}"/usr/share/doc/${PF}
+
+ # Install desktop files.
+ cd desktopfiles
+ insinto /usr/share/icons/hicolor/22x22/mimetypes && newins hi22-djvu.png image-vnd.djvu.png || die
+ insinto /usr/share/icons/hicolor/32x32/mimetypes && newins hi32-djvu.png image-vnd.djvu.png || die
+ insinto /usr/share/icons/hicolor/48x48/mimetypes && newins hi48-djvu.png image-vnd.djvu.png || die
+ insinto /usr/share/mime/packages && doins djvulibre-mime.xml || die
+ if use kde ; then
+ insinto /usr/share/mimelnk/image && doins vnd.djvu.desktop || die
+ cp "${D}"/usr/share/mimelnk/image/{vnd.djvu.desktop,x-djvu.desktop}
+ sed -i -e 's:image/vnd.djvu:image/x-djvu:' "${D}"/usr/share/mimelnk/image/x-djvu.desktop
+ fi
+
+ if use qt3 ; then
+ insinto /usr/share/icons/hicolor/32x32/apps && newins hi32-djview3.png djvulibre-djview3.png || die
+ insinto /usr/share/applications/ && doins djvulibre-djview3.desktop || die
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}