summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-26 23:13:47 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-26 23:13:47 +0000
commit679c38c49482b3b0f510bb26b8d08882cf1f884f (patch)
tree1b2bb3169af7b1e90eecfee6a9a1d8e69a239710 /app-text
parentstable sparc, bug 301400 (diff)
downloadgentoo-2-679c38c49482b3b0f510bb26b8d08882cf1f884f.tar.gz
gentoo-2-679c38c49482b3b0f510bb26b8d08882cf1f884f.tar.bz2
gentoo-2-679c38c49482b3b0f510bb26b8d08882cf1f884f.zip
Add patch to fix gdk feature detection. Fixes bug 302332.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/ChangeLog8
-rw-r--r--app-text/poppler/files/poppler-0.12.3-gdk.patch20
-rw-r--r--app-text/poppler/poppler-0.12.3-r3.ebuild77
3 files changed, 104 insertions, 1 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index 8071310ad30d..1011cf9723d5 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.207 2010/01/26 00:41:54 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.208 2010/01/26 23:13:46 yngwin Exp $
+
+*poppler-0.12.3-r3 (26 Jan 2010)
+
+ 26 Jan 2010; Ben de Groot <yngwin@gentoo.org> +poppler-0.12.3-r3.ebuild,
+ +files/poppler-0.12.3-gdk.patch:
+ Add patch to fix gdk feature detection. Fixes bug 302332.
26 Jan 2010; Ben de Groot <yngwin@gentoo.org> -poppler-0.10.4.ebuild,
-poppler-0.10.5.ebuild:
diff --git a/app-text/poppler/files/poppler-0.12.3-gdk.patch b/app-text/poppler/files/poppler-0.12.3-gdk.patch
new file mode 100644
index 000000000000..d3881e075a8e
--- /dev/null
+++ b/app-text/poppler/files/poppler-0.12.3-gdk.patch
@@ -0,0 +1,20 @@
+--- glib/poppler-features.h.cmake.orig 2009-09-09 23:22:31.000000000 +0200
++++ glib/poppler-features.h.cmake 2010-01-26 23:36:17.518737903 +0100
+@@ -20,6 +20,7 @@
+ #define __POPPLER_FEATURES_H__
+
+ @CAIRO_FEATURE@
++@GDK_FEATURE@
+
+ #define POPPLER_MAJOR_VERSION (@POPPLER_MAJOR_VERSION@)
+ #define POPPLER_MINOR_VERSION (@POPPLER_MINOR_VERSION@)
+--- glib/CMakeLists.txt.orig 2010-01-26 23:40:40.719242931 +0100
++++ glib/CMakeLists.txt 2010-01-26 23:48:30.107752041 +0100
+@@ -13,6 +13,7 @@
+ endif (CAIRO_FOUND)
+
+ if (GDK_FOUND)
++ set (GDK_FEATURE "#define POPPLER_WITH_GDK 1")
+ add_definitions(${GDK2_CFLAGS})
+ endif (GDK_FOUND)
+
diff --git a/app-text/poppler/poppler-0.12.3-r3.ebuild b/app-text/poppler/poppler-0.12.3-r3.ebuild
new file mode 100644
index 000000000000..4fcb3ab1dffb
--- /dev/null
+++ b/app-text/poppler/poppler-0.12.3-r3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.12.3-r3.ebuild,v 1.1 2010/01/26 23:13:46 yngwin Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="http://poppler.freedesktop.org/"
+SRC_URI="http://poppler.freedesktop.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+abiword cairo cjk debug doc exceptions jpeg jpeg2k +lcms png qt4 +utils +xpdf-headers"
+
+COMMON_DEPEND=">=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ abiword? ( dev-libs/libxml2:2 )
+ cairo? ( dev-libs/glib:2
+ >=x11-libs/cairo-1.8.4
+ >=x11-libs/gtk+-2.14.0:2 )
+ jpeg? ( >=media-libs/jpeg-7:0 )
+ jpeg2k? ( media-libs/openjpeg )
+ png? ( media-libs/libpng )
+ qt4? ( x11-libs/qt-core:4
+ x11-libs/qt-gui:4 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ !dev-libs/poppler
+ !dev-libs/poppler-glib
+ !dev-libs/poppler-qt3
+ !dev-libs/poppler-qt4
+ !app-text/poppler-utils
+ cjk? ( >=app-text/poppler-data-0.2.1 )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-cmake-disable-tests.patch"
+ epatch "${FILESDIR}/${P}-fix-headers-installation.patch"
+ epatch "${FILESDIR}/${P}-gdk.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DWITH_Qt3=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ $(cmake-utils_use_enable abiword)
+ $(cmake-utils_use_enable lcms)
+ $(cmake-utils_use_enable jpeg2k LIBOPENJPEG)
+ $(cmake-utils_use_enable utils)
+ $(cmake-utils_use_enable xpdf-headers XPDF_HEADERS)
+ $(cmake-utils_use_with cairo)
+ $(cmake-utils_use_with cairo GTK)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with qt4)
+ $(cmake-utils_use exceptions USE_EXCEPTIONS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use cairo && use doc; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/* || die 'failed to install API documentation'
+ fi
+}