summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 18:13:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 18:13:30 +0000
commit652bd046a959d10dfb611c41e0a9ba6c8320ed3c (patch)
tree0f6146d6d05bb510850f9947434f2df90c067b29 /app-text
parentBump to 0.5.1_p6 with debian patches. Ebuild adapted by valli <gentoo@valli.o... (diff)
downloadgentoo-2-652bd046a959d10dfb611c41e0a9ba6c8320ed3c.tar.gz
gentoo-2-652bd046a959d10dfb611c41e0a9ba6c8320ed3c.tar.bz2
gentoo-2-652bd046a959d10dfb611c41e0a9ba6c8320ed3c.zip
Bump to 1.04, fixes #203796
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xmlformat/ChangeLog9
-rw-r--r--app-text/xmlformat/xmlformat-1.04.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/app-text/xmlformat/ChangeLog b/app-text/xmlformat/ChangeLog
index 44cc486724df..336713f2bb18 100644
--- a/app-text/xmlformat/ChangeLog
+++ b/app-text/xmlformat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xmlformat
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlformat/ChangeLog,v 1.8 2008/01/19 14:57:11 grobian Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlformat/ChangeLog,v 1.9 2009/02/15 18:13:30 patrick Exp $
+
+*xmlformat-1.04 (15 Feb 2009)
+
+ 15 Feb 2009; Patrick Lauer <patrick@gentoo.org> +xmlformat-1.04.ebuild:
+ Bump to 1.04, fixes #203796
19 Jan 2008; Fabian Groffen <grobian@gentoo.org> xmlformat-1.03.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/app-text/xmlformat/xmlformat-1.04.ebuild b/app-text/xmlformat/xmlformat-1.04.ebuild
new file mode 100644
index 000000000000..a65e53bb77a0
--- /dev/null
+++ b/app-text/xmlformat/xmlformat-1.04.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlformat/xmlformat-1.04.ebuild,v 1.1 2009/02/15 18:13:30 patrick Exp $
+
+DESCRIPTION="Reformat XML documents to your custom style"
+SRC_URI="http://www.kitebird.com/software/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.kitebird.com/software/xmlformat/"
+
+SLOT="0"
+LICENSE="xmlformat"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="ruby? ( virtual/ruby )
+ !ruby? ( dev-lang/perl )"
+IUSE="ruby doc"
+
+src_install() {
+ dobin xmlformat.pl
+
+ if use ruby
+ then
+ dobin xmlformat.rb
+ dosym /usr/bin/xmlformat.rb /usr/bin/xmlformat
+ else
+ dosym /usr/bin/xmlformat.pl /usr/bin/xmlformat
+ fi
+
+ dodoc BUGS ChangeLog LICENSE README TODO
+
+ if use doc
+ then
+ # APIs
+ cp -R docs/* ${D}/usr/share/doc/${PF}
+ fi
+}
+
+src_test() {
+ if use ruby
+ then
+ ./runtest all || die "runtest for ruby failed."
+ else
+ ./runtest -p all || die "runtest for perl failed."
+ fi
+}