summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-10 23:13:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-10 23:13:09 +0000
commit628efc54f31bdd4a5b83c303a83884683394041d (patch)
tree8a070a348323e2ad261a004d36bb3f71eed6a8b7 /app-text
parentConvert to multilib (only slot 2) and stack it for baselib r11 (diff)
downloadgentoo-2-628efc54f31bdd4a5b83c303a83884683394041d.tar.gz
gentoo-2-628efc54f31bdd4a5b83c303a83884683394041d.tar.bz2
gentoo-2-628efc54f31bdd4a5b83c303a83884683394041d.zip
Convert to multilib and stack it for baselib r11
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libpaper/ChangeLog7
-rw-r--r--app-text/libpaper/libpaper-1.1.24-r2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/app-text/libpaper/ChangeLog b/app-text/libpaper/ChangeLog
index bbdb1f05b6cd..19fc5dabd128 100644
--- a/app-text/libpaper/ChangeLog
+++ b/app-text/libpaper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libpaper
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libpaper/ChangeLog,v 1.57 2013/05/03 07:51:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libpaper/ChangeLog,v 1.58 2013/08/10 23:13:09 aballier Exp $
+
+*libpaper-1.1.24-r2 (10 Aug 2013)
+
+ 10 Aug 2013; Alexis Ballier <aballier@gentoo.org> +libpaper-1.1.24-r2.ebuild:
+ Convert to multilib and stack it for baselib r11
03 May 2013; Patrick Lauer <patrick@gentoo.org> libpaper-1.1.24-r1.ebuild:
Automake 1.13 fix
diff --git a/app-text/libpaper/libpaper-1.1.24-r2.ebuild b/app-text/libpaper/libpaper-1.1.24-r2.ebuild
new file mode 100644
index 000000000000..61a1ed8b2b22
--- /dev/null
+++ b/app-text/libpaper/libpaper-1.1.24-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libpaper/libpaper-1.1.24-r2.ebuild,v 1.1 2013/08/10 23:13:09 aballier Exp $
+
+EAPI=4
+
+inherit eutils autotools multilib-minimal
+
+MY_PV=${PV/_p/+nmu}
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="http://packages.debian.org/unstable/source/libpaper"
+SRC_URI="mirror://debian/pool/main/libp/libpaper/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+RDEPEND="abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r10
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DOCS=( README ChangeLog debian/changelog )
+
+src_prepare() {
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ dodir /etc
+ (paperconf 2>/dev/null || echo a4) > "${ED}"/etc/papersize \
+ || die "papersize config failed"
+
+ if ! has_version app-text/libpaper ; then
+ echo
+ elog "run e.g. \"paperconfig -p letter\" as root to use letter-pagesizes"
+ echo
+ fi
+}