summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-10-24 21:30:37 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-10-24 21:30:37 +0000
commit60ebf3145edb3a5ef7150c61424e960add0f8cf9 (patch)
tree216651160b54799d8a43274b546d4b1531e727ac /app-text
parentfixums? (diff)
downloadgentoo-2-60ebf3145edb3a5ef7150c61424e960add0f8cf9.tar.gz
gentoo-2-60ebf3145edb3a5ef7150c61424e960add0f8cf9.tar.bz2
gentoo-2-60ebf3145edb3a5ef7150c61424e960add0f8cf9.zip
teTeX had a data structure name conflict (option)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/tetex/files/digest-tetex-1.0.7-r34
-rw-r--r--app-text/tetex/files/teTeX-1.0-gentoo.diff44
-rw-r--r--app-text/tetex/tetex-1.0.7-r3.ebuild127
3 files changed, 175 insertions, 0 deletions
diff --git a/app-text/tetex/files/digest-tetex-1.0.7-r3 b/app-text/tetex/files/digest-tetex-1.0.7-r3
new file mode 100644
index 000000000000..2129b02e134c
--- /dev/null
+++ b/app-text/tetex/files/digest-tetex-1.0.7-r3
@@ -0,0 +1,4 @@
+MD5 2c6da2a45096c2fdc41b8de6a8af1a52 teTeX-src-1.0.7.tar.gz
+MD5 7811ed356cca07b16ea8422f00c3cd34 teTeX-texmf-1.0.2.tar.gz
+MD5 12925188fdadcd6a970c21bba3269fc2 ec-ready-mf-tfm.tar.gz
+MD5 37393316b285926214c247acd55db743 teTeX-french.tar.gz
diff --git a/app-text/tetex/files/teTeX-1.0-gentoo.diff b/app-text/tetex/files/teTeX-1.0-gentoo.diff
new file mode 100644
index 000000000000..e88767817ae8
--- /dev/null
+++ b/app-text/tetex/files/teTeX-1.0-gentoo.diff
@@ -0,0 +1,44 @@
+diff -r -C2 teTeX-1.0.orig/texk/gsftopk/gsftopk.c teTeX-1.0/texk/gsftopk/gsftopk.c
+*** teTeX-1.0.orig/texk/gsftopk/gsftopk.c Thu Apr 22 01:48:11 1999
+--- teTeX-1.0/texk/gsftopk/gsftopk.c Wed Oct 24 15:17:45 2001
+***************
+*** 407,411 ****
+ Boolean quiet = False;
+
+! struct option {
+ const char *longname;
+ short shortname;
+--- 407,411 ----
+ Boolean quiet = False;
+
+! struct xxx_option {
+ const char *longname;
+ short shortname;
+***************
+*** 415,419 ****
+ };
+
+! static const struct option options[] = {
+ {"test", 't', False, &test, True},
+ {"mapline", 0, True, &mapline, 0},
+--- 415,419 ----
+ };
+
+! static const struct xxx_option options[] = {
+ {"test", 't', False, &test, True},
+ {"mapline", 0, True, &mapline, 0},
+***************
+*** 1960,1965 ****
+ argp = argv;
+ while (++argp < argv + argc && (*argp)[0] == '-') {
+! const struct option *opt_ptr;
+! const struct option *opt;
+ char *arg = *argp + 1;
+
+--- 1960,1965 ----
+ argp = argv;
+ while (++argp < argv + argc && (*argp)[0] == '-') {
+! const struct xxx_option *opt_ptr;
+! const struct xxx_option *opt;
+ char *arg = *argp + 1;
+
diff --git a/app-text/tetex/tetex-1.0.7-r3.ebuild b/app-text/tetex/tetex-1.0.7-r3.ebuild
new file mode 100644
index 000000000000..a2c5861a1bc4
--- /dev/null
+++ b/app-text/tetex/tetex-1.0.7-r3.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/tetex/tetex-1.0.7-r3.ebuild,v 1.1 2001/10/24 21:30:37 chadh Exp $
+
+P=tetex-1.0.7
+A="teTeX-src-1.0.7.tar.gz teTeX-texmf-1.0.2.tar.gz ec-ready-mf-tfm.tar.gz teTeX-french.tar.gz"
+S=${WORKDIR}/teTeX-1.0
+DESCRIPTION="teTeX is a complete TeX distribution"
+SRC_URI="ftp://sunsite.informatik.rwth-aachen.de/pub/comp/tex/teTeX/1.0/distrib/sources/teTeX-src-1.0.7.tar.gz
+ ftp://sunsite.informatik.rwth-aachen.de/pub/comp/tex/teTeX/1.0/distrib/sources/teTeX-texmf-1.0.2.tar.gz"
+
+DEPEND="virtual/glibc sys-apps/ed
+ >=media-libs/libpng-1.0.9
+ libwww? ( >=net-libs/libwww-5.3.2-r1 )
+ X? ( virtual/x11 )"
+
+RDEPEND="virtual/glibc
+ >=sys-devel/perl-5.2
+ >=media-libs/libpng-1.0.9
+ X? ( virtual/x11 )"
+
+HOMEPAGE="http://tug.cs.umb.edu/tetex/"
+
+src_unpack() {
+
+ unpack teTeX-src-1.0.7.tar.gz
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/teTeX-1.0-gentoo.diff
+
+ cd ${S}
+ patch -p0 < ${FILESDIR}/teTeX-1.0.dif
+
+ mkdir texmf
+ cd texmf
+ tar xzf ${DISTDIR}/teTeX-texmf-1.0.2.tar.gz
+ tar xzf ${DISTDIR}/ec-ready-mf-tfm.tar.gz -C ..
+ tar xzf ${DISTDIR}/teTeX-french.tar.gz
+ patch -p0 < ${FILESDIR}/texmf.dif
+}
+
+src_compile() {
+
+ local myconf
+ if [ "`use X`" ]
+ then
+ myconf="--with-x"
+ else
+ myconf="--without-x"
+ fi
+
+ if [ "`use libwww`" ]
+ then
+ myconf="${myconf} --with-system-wwwlib"
+ fi
+ # Does it make sense to compile the included libwww with mysql ?
+
+ try ./configure --host=${CHOST} --prefix=/usr --bindir=/usr/bin \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=${S} \
+ --without-texinfo \
+ --without-dialog \
+ --with-system-ncurses \
+ --with-system-zlib \
+ --with-system-pnglib \
+ --enable-multiplatform \
+ --with-epsfwin \
+ --with-mftalkwin \
+ --with-regiswin \
+ --with-tektronixwin \
+ --with-unitermwin \
+ --with-ps=gs \
+ --enable-ipc \
+ --with-etex \
+ ${myconf}
+
+ try make texmf=/usr/share/texmf
+
+}
+
+src_install() {
+ cd ${S}
+ dodir /usr/share/
+ cp -af texmf ${D}/usr/share
+ sed -e "s:\$(scriptdir)/texconfig init:echo:" Makefile > Makefile.install
+ try make prefix=${D}/usr bindir=${D}/usr/bin \
+ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info \
+ texmf=${D}/usr/share/texmf -f Makefile.install install
+
+ dodoc PROBLEMS README
+ docinto texk
+ dodoc texk/ChangeLog texk/README
+ docinto kpathesa
+ cd ${S}/texk/kpathsea
+ dodoc README* NEWS PROJECTS HIER
+ docinto dviljk
+ cd ${S}/texk/dviljk
+ dodoc AUTHORS README NEWS
+ docinto dvipsk
+ cd ${S}/texk/dvipsk
+ dodoc AUTHORS ChangeLog INSTALLATION README
+ docinto makeindexk
+ cd ${S}/texk/makeindexk
+ dodoc CONTRIB COPYING NEWS NOTES PORTING README
+ docinto ps2pkm
+ cd ${S}/texk/ps2pkm
+ dodoc ChangeLog CHANGES.type1 INSTALLATION README*
+ docinto web2c
+ cd ${S}/texk/web2c
+ dodoc AUTHORS ChangeLog NEWS PROJECTS README
+ docinto xdvik
+ cd ${S}/texk/xdvik
+ dodoc BUGS FAQ README*
+
+ #fix for conflicting readlink binary:
+ rm ${D}/bin/readlink
+}
+
+
+pkg_postinst() {
+ if [ $ROOT = "/" ]
+ then
+ texconfig init
+ fi
+}
+