summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-07 03:32:55 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-07 03:32:55 +0000
commit5866b38b7d412cf149b5a8fe4ea7d262b026f6eb (patch)
treed1ef821ede0d99897504c9a88f0f71fc635e65a0 /app-text
parentset version border to peewee, update test phase, rm old (diff)
downloadgentoo-2-5866b38b7d412cf149b5a8fe4ea7d262b026f6eb.tar.gz
gentoo-2-5866b38b7d412cf149b5a8fe4ea7d262b026f6eb.tar.bz2
gentoo-2-5866b38b7d412cf149b5a8fe4ea7d262b026f6eb.zip
patch to fix broken test, update ebuild accordingly
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pytextile/ChangeLog6
-rw-r--r--app-text/pytextile/files/pytextile-2.1.8-sanitizer.patch15
-rw-r--r--app-text/pytextile/pytextile-2.1.8.ebuild6
3 files changed, 23 insertions, 4 deletions
diff --git a/app-text/pytextile/ChangeLog b/app-text/pytextile/ChangeLog
index c34ddaa01a56..1a25b070362f 100644
--- a/app-text/pytextile/ChangeLog
+++ b/app-text/pytextile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/pytextile
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/ChangeLog,v 1.32 2014/05/31 13:55:42 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/ChangeLog,v 1.33 2014/07/07 03:32:55 idella4 Exp $
+
+ 07 Jul 2014; Ian Delaney <idella4@gentoo.org>
+ +files/pytextile-2.1.8-sanitizer.patch, pytextile-2.1.8.ebuild:
+ patch to fix broken test, update ebuild accordingly
31 May 2014; Ian Delaney <idella4@gentoo.org> pytextile-2.1.8.ebuild:
add fix to test failings noted by Arfrever, fix typo
diff --git a/app-text/pytextile/files/pytextile-2.1.8-sanitizer.patch b/app-text/pytextile/files/pytextile-2.1.8-sanitizer.patch
new file mode 100644
index 000000000000..1a9e696f21e9
--- /dev/null
+++ b/app-text/pytextile/files/pytextile-2.1.8-sanitizer.patch
@@ -0,0 +1,15 @@
+https://github.com/textile/python-textile/commit/83c81db387fa5f0c5ca25c27b8bc36d105bce599
+diff --git a/textile/tools/sanitizer.py b/textile/tools/sanitizer.py
+index 83b6799..4fc8fb2 100644
+--- a/textile/tools/sanitizer.py
++++ b/textile/tools/sanitizer.py
+@@ -12,7 +12,7 @@ def sanitize(string):
+ p = html5lib.HTMLParser(tokenizer=sanitizer.HTMLSanitizer)
+ tree = p.parseFragment(string)
+
+- walker = treewalkers.getTreeWalker("simpletree")
++ walker = treewalkers.getTreeWalker("etree")
+ stream = walker(tree)
+
+ s = serializer.htmlserializer.HTMLSerializer(omit_optional_tags=False,
+
diff --git a/app-text/pytextile/pytextile-2.1.8.ebuild b/app-text/pytextile/pytextile-2.1.8.ebuild
index 718030fbcc30..b4cc1c5c5e9b 100644
--- a/app-text/pytextile/pytextile-2.1.8.ebuild
+++ b/app-text/pytextile/pytextile-2.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/pytextile-2.1.8.ebuild,v 1.2 2014/05/31 13:55:42 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/pytextile-2.1.8.ebuild,v 1.3 2014/07/07 03:32:55 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -26,9 +26,9 @@ RDEPEND=""
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${P}-sanitizer.patch )
+
python_prepare_all() {
- # https://github.com/ikirudennis/python-textile/issues/6
- sed -e 's:testSanitize:_&:' -i textile/tests/__init__.py || die
# This resolves a nasty race condition noted and observed by Arfrever
sed -e 's:with-id = 1::' -i setup.cfg || die
distutils-r1_python_prepare_all