summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-03 17:11:01 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-03 17:11:01 +0000
commit56eaf3a1a6b68c2fda4a5f613f9c54f500d18d7e (patch)
tree31ccab0ea7bdec93a3dda304dafc52dcf43f365f /app-text
parentper scarabeus, amd64/x86 stable wrt #365377 (diff)
downloadgentoo-2-56eaf3a1a6b68c2fda4a5f613f9c54f500d18d7e.tar.gz
gentoo-2-56eaf3a1a6b68c2fda4a5f613f9c54f500d18d7e.tar.bz2
gentoo-2-56eaf3a1a6b68c2fda4a5f613f9c54f500d18d7e.zip
Version Bump, notified by euscan
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bibutils/ChangeLog10
-rw-r--r--app-text/bibutils/bibutils-4.11.ebuild6
-rw-r--r--app-text/bibutils/bibutils-4.12.ebuild38
3 files changed, 49 insertions, 5 deletions
diff --git a/app-text/bibutils/ChangeLog b/app-text/bibutils/ChangeLog
index 6e21c92cf153..0c2f252ad047 100644
--- a/app-text/bibutils/ChangeLog
+++ b/app-text/bibutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/bibutils
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibutils/ChangeLog,v 1.10 2010/09/15 18:26:11 xarthisius Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibutils/ChangeLog,v 1.11 2011/05/03 17:11:01 jlec Exp $
+
+*bibutils-4.12 (03 May 2011)
+
+ 03 May 2011; Justin Lecher <jlec@gentoo.org> bibutils-4.11.ebuild,
+ +bibutils-4.12.ebuild:
+ Version Bump, notified by euscan
*bibutils-4.11 (15 Sep 2010)
diff --git a/app-text/bibutils/bibutils-4.11.ebuild b/app-text/bibutils/bibutils-4.11.ebuild
index cfed2c071fb6..64c93a77c335 100644
--- a/app-text/bibutils/bibutils-4.11.ebuild
+++ b/app-text/bibutils/bibutils-4.11.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibutils/bibutils-4.11.ebuild,v 1.1 2010/09/15 18:26:11 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibutils/bibutils-4.11.ebuild,v 1.2 2011/05/03 17:11:01 jlec Exp $
EAPI=2
inherit toolchain-funcs
MY_P="${PN}_${PV}"
DESCRIPTION="Interconverts between various bibliography formats using a common XML intermediate"
-HOMEPAGE="http://www.scripps.edu/~cdputnam/software/bibutils"
+HOMEPAGE="http://www.scripps.edu/~cdputnam/software/bibutils/"
SRC_URI="http://www.scripps.edu/~cdputnam/software/bibutils/${MY_P}_src.tgz"
LICENSE="GPL-2"
diff --git a/app-text/bibutils/bibutils-4.12.ebuild b/app-text/bibutils/bibutils-4.12.ebuild
new file mode 100644
index 000000000000..6ba86a9fbf41
--- /dev/null
+++ b/app-text/bibutils/bibutils-4.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibutils/bibutils-4.12.ebuild,v 1.1 2011/05/03 17:11:01 jlec Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="Interconverts between various bibliography formats using a common XML intermediate"
+HOMEPAGE="http://www.scripps.edu/~cdputnam/software/bibutils/"
+SRC_URI="http://www.scripps.edu/~cdputnam/software/bibutils/${MY_P}_src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # The custom configure script sucks, so we'll just do its
+ # job ourselves
+ rm -f Makefile configure || die "Failed to purge old Makefile"
+ sed \
+ -e "s:REPLACE_CC:CC=\"$(tc-getCC) ${CFLAGS}\":g" \
+ -e "s:REPLACE_RANLIB:RANLIB=\"$(tc-getRANLIB)\":g" \
+ -e "s:REPLACE_INSTALLDIR:\"${D}/usr/bin\":g" \
+ -e 's:REPLACE_POSTFIX::g' \
+ -e 's:make:$(MAKE):g' \
+ Makefile_start > Makefile \
+ || die "Failed to set up Makefile"
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install || die
+ dodoc ChangeLog || die
+}