summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-06-08 23:35:49 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-06-08 23:35:49 +0000
commit5332e051ae4196c6c2193236e220fd0cda249ac6 (patch)
tree621f5d02880d582a3567ccdf5a0e9a354068c003 /app-text
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-5332e051ae4196c6c2193236e220fd0cda249ac6.tar.gz
gentoo-2-5332e051ae4196c6c2193236e220fd0cda249ac6.tar.bz2
gentoo-2-5332e051ae4196c6c2193236e220fd0cda249ac6.zip
Version bump 0.14.0
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/ChangeLog8
-rw-r--r--app-text/poppler/poppler-0.14.0.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index cce6c70314dd..1cae1986560f 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.233 2010/06/08 12:17:08 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.234 2010/06/08 23:35:49 reavertm Exp $
+
+*poppler-0.14.0 (08 Jun 2010)
+
+ 08 Jun 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ +poppler-0.14.0.ebuild:
+ Version bump 0.14.0
08 Jun 2010; Fabian Groffen <grobian@gentoo.org> poppler-0.12.4-r3.ebuild:
Don't define _XOPEN_SOURCE on Solaris either, such that we can compile
diff --git a/app-text/poppler/poppler-0.14.0.ebuild b/app-text/poppler/poppler-0.14.0.ebuild
new file mode 100644
index 000000000000..d34b511608ca
--- /dev/null
+++ b/app-text/poppler/poppler-0.14.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.14.0.ebuild,v 1.1 2010/06/08 23:35:49 reavertm Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="http://poppler.freedesktop.org/"
+SRC_URI="http://poppler.freedesktop.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="+abiword cairo cjk curl cxx debug doc exceptions jpeg jpeg2k +lcms png qt4 +utils +xpdf-headers"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ abiword? ( dev-libs/libxml2:2 )
+ cairo? (
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.8.4
+ >=x11-libs/gtk+-2.14.0:2
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( >=media-libs/jpeg-7:0 )
+ jpeg2k? ( media-libs/openjpeg )
+ lcms? ( media-libs/lcms )
+ png? ( media-libs/libpng )
+ qt4? (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-libs/poppler
+ !dev-libs/poppler-glib
+ !dev-libs/poppler-qt3
+ !dev-libs/poppler-qt4
+ !app-text/poppler-utils
+ cjk? ( >=app-text/poppler-data-0.2.1 )
+"
+
+DOCS=(AUTHORS ChangeLog NEWS README README-XPDF TODO)
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DWITH_Qt3=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ $(cmake-utils_use_enable abiword)
+ $(cmake-utils_use_enable curl LIBCURL)
+ $(cmake-utils_use_enable cxx CPP)
+ $(cmake-utils_use_enable jpeg2k LIBOPENJPEG)
+ $(cmake-utils_use_enable lcms)
+ $(cmake-utils_use_enable utils)
+ $(cmake-utils_use_enable xpdf-headers XPDF_HEADERS)
+ $(cmake-utils_use_with cairo)
+ $(cmake-utils_use_with cairo GTK)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with qt4)
+ $(cmake-utils_use exceptions USE_EXCEPTIONS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use cairo && use doc; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/* || die 'failed to install API documentation'
+ fi
+}
+
+pkg_postinst() {
+ ewarn 'After upgrading app-text/poppler you may need to reinstall packages'
+ ewarn 'depending on it. If you have gentoolkit installed, you can find those'
+ ewarn 'with `equery d poppler`.'
+}