summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-07 06:15:06 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-07 06:15:06 +0000
commit4357428beacd68601c8c526fe7357991419aaf92 (patch)
tree4f51c977940b031020fe11b827a529fb111cf7bc /app-text
parentCorrected typo in SRC_URI; bug #70272. (Manifest recommit) (diff)
downloadgentoo-2-4357428beacd68601c8c526fe7357991419aaf92.tar.gz
gentoo-2-4357428beacd68601c8c526fe7357991419aaf92.tar.bz2
gentoo-2-4357428beacd68601c8c526fe7357991419aaf92.zip
Require dev-perl/XML-Parser only if doc USE flag is set; bug #69452.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sablotron/ChangeLog6
-rw-r--r--app-text/sablotron/sablotron-0.97.ebuild13
-rw-r--r--app-text/sablotron/sablotron-1.0.1.ebuild13
-rw-r--r--app-text/sablotron/sablotron-1.0.ebuild13
4 files changed, 26 insertions, 19 deletions
diff --git a/app-text/sablotron/ChangeLog b/app-text/sablotron/ChangeLog
index 0b6fd0c171db..31fe1b1babc8 100644
--- a/app-text/sablotron/ChangeLog
+++ b/app-text/sablotron/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/sablotron
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.34 2004/10/11 16:37:37 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.35 2004/11/07 06:15:06 usata Exp $
+
+ 07 Nov 2004; Mamoru KOMACHI <usata@gentoo.org> sablotron-0.97.ebuild,
+ sablotron-1.0.1.ebuild, sablotron-1.0.ebuild:
+ Require dev-perl/XML-Parser only if doc USE flag is set; bug #69452.
11 Oct 2004; Guy Martin <gmsoft@gentoo.org> sablotron-1.0.ebuild:
Marked stable on hppa.
diff --git a/app-text/sablotron/sablotron-0.97.ebuild b/app-text/sablotron/sablotron-0.97.ebuild
index ec4354d1f47e..af410a4a4eff 100644
--- a/app-text/sablotron/sablotron-0.97.ebuild
+++ b/app-text/sablotron/sablotron-0.97.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.97.ebuild,v 1.19 2004/07/13 23:40:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.97.ebuild,v 1.20 2004/11/07 06:15:06 usata Exp $
-inherit libtool
+inherit libtool flag-o-matic
S="${WORKDIR}/Sablot-${PV}"
DESCRIPTION="An XSLT Parser in C++"
@@ -14,8 +14,9 @@ SLOT="0"
IUSE="perl"
KEYWORDS="x86 sparc ppc hppa alpha amd64 ~mips"
-DEPEND=">=dev-libs/expat-1.95.6-r1
- dev-perl/XML-Parser"
+RDEPEND=">=dev-libs/expat-1.95.6-r1"
+DEPEND="${RDEPEND}
+ perl? ( dev-perl/XML-Parser )"
src_compile() {
local myconf=
@@ -28,14 +29,14 @@ src_compile() {
# rphillips
# fixes bug #3876
- export LDFLAGS="-lstdc++"
+ append-ldflags -lstdc++
econf ${myconf} || die "econf failed"
make || die
}
src_install() {
- einstall
+ einstall || die
dodoc README* RELEASE
dodoc src/TODO
}
diff --git a/app-text/sablotron/sablotron-1.0.1.ebuild b/app-text/sablotron/sablotron-1.0.1.ebuild
index 55d09b0d82c0..22a57a372b12 100644
--- a/app-text/sablotron/sablotron-1.0.1.ebuild
+++ b/app-text/sablotron/sablotron-1.0.1.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.1.ebuild,v 1.7 2004/08/02 02:50:04 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.1.ebuild,v 1.8 2004/11/07 06:15:06 usata Exp $
-inherit libtool gnuconfig
+inherit libtool gnuconfig flag-o-matic
MY_PN="Sablot"
MY_P="${MY_PN}-${PV}"
S=${WORKDIR}/${MY_P}
DESCRIPTION="An XSLT Parser in C++"
-HOMEPAGE="http://www.gingerall.com/charlie-bin/get/webGA/act/sablotron.act"
+HOMEPAGE="http://www.gingerall.com/charlie/ga/xml/p_sub.xml"
SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
# Sablotron can optionally be built under GPL, using MPL for now
@@ -18,8 +18,9 @@ SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc ~mips ~alpha arm ~hppa ~amd64 ~ia64 s390 ppc64"
IUSE="doc perl"
-DEPEND=">=dev-libs/expat-1.95.6-r1
- >=dev-perl/XML-Parser-2.3"
+RDEPEND=">=dev-libs/expat-1.95.6-r1"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-perl/XML-Parser-2.3 )"
DOCS="INSTALL README README_JS RELEASE src/TODO"
@@ -44,7 +45,7 @@ src_compile() {
# this is fixed for me with apache2, but keeping it in here
# for apache1 users and/or until some clever detection
# is added <obz@gentoo.org>
- export LDFLAGS="-lstdc++"
+ append-ldflags -lstdc++
econf ${myconf} || die "Configure failed"
emake || die "Make failed"
diff --git a/app-text/sablotron/sablotron-1.0.ebuild b/app-text/sablotron/sablotron-1.0.ebuild
index b39c864faa68..374519fc830a 100644
--- a/app-text/sablotron/sablotron-1.0.ebuild
+++ b/app-text/sablotron/sablotron-1.0.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.ebuild,v 1.11 2004/10/11 16:37:37 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.ebuild,v 1.12 2004/11/07 06:15:06 usata Exp $
-inherit libtool
+inherit libtool flag-o-matic
MY_PN="Sablot"
MY_P="${MY_PN}-${PV}"
S=${WORKDIR}/${MY_P}
DESCRIPTION="An XSLT Parser in C++"
-SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
HOMEPAGE="http://www.gingerall.com/charlie/ga/xml/p_sab.xml"
+SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
# Sablotron can optionally be built under GPL, using MPL for now
LICENSE="MPL-1.1"
@@ -18,8 +18,9 @@ SLOT="0"
IUSE="doc perl"
KEYWORDS="x86 sparc ~ppc hppa alpha amd64 ia64"
-DEPEND=">=dev-libs/expat-1.95.6-r1
- >=dev-perl/XML-Parser-2.3"
+RDEPEND=">=dev-libs/expat-1.95.6-r1"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-perl/XML-Parser-2.3 )"
DOCS="INSTALL README README_JS RELEASE src/TODO"
@@ -42,7 +43,7 @@ src_compile() {
# this is fixed for me with apache2, but keeping it in here
# for apache1 users and/or until some clever detection
# is added <obz@gentoo.org>
- export LDFLAGS="-lstdc++"
+ append-ldflags -lstdc++
econf ${myconf} || die "Configure failed"
emake || die "Make failed"