summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-05-19 10:22:30 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-05-19 10:22:30 +0000
commit419d21685a59d09ee73a76a5fd7a10e7a3710d0d (patch)
tree41225e98cb433636e1f37c658ee3c225dd6a62a4 /app-text
parentMove pkgconfig to DEPEND. (diff)
downloadgentoo-2-419d21685a59d09ee73a76a5fd7a10e7a3710d0d.tar.gz
gentoo-2-419d21685a59d09ee73a76a5fd7a10e7a3710d0d.tar.bz2
gentoo-2-419d21685a59d09ee73a76a5fd7a10e7a3710d0d.zip
Initial import of ssddiff, a C++ implementation of xmldiff.
(Portage version: 2.1.5)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ssddiff/ChangeLog10
-rw-r--r--app-text/ssddiff/Manifest5
-rw-r--r--app-text/ssddiff/files/ssddiff-0.2+gcc-4.3.patch24
-rw-r--r--app-text/ssddiff/metadata.xml8
-rw-r--r--app-text/ssddiff/ssddiff-0.2.ebuild44
5 files changed, 91 insertions, 0 deletions
diff --git a/app-text/ssddiff/ChangeLog b/app-text/ssddiff/ChangeLog
new file mode 100644
index 000000000000..9d3a9de19cba
--- /dev/null
+++ b/app-text/ssddiff/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/ssddiff
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ssddiff/ChangeLog,v 1.1 2008/05/19 10:22:30 flameeyes Exp $
+
+*ssddiff-0.2 (19 May 2008)
+
+ 19 May 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/ssddiff-0.2+gcc-4.3.patch, +metadata.xml, +ssddiff-0.2.ebuild:
+ Initial import of ssddiff, a C++ implementation of xmldiff.
+
diff --git a/app-text/ssddiff/Manifest b/app-text/ssddiff/Manifest
new file mode 100644
index 000000000000..c2e346136014
--- /dev/null
+++ b/app-text/ssddiff/Manifest
@@ -0,0 +1,5 @@
+AUX ssddiff-0.2+gcc-4.3.patch 620 RMD160 6c248f1b2e7860a0d31c14e6c78dda46350ceb49 SHA1 0c35d4fbe93b529a7d5aea06ff8569e43edf853d SHA256 6fed7007616da76f4de5769a3dd82b316f13b4af6225070c3bb9604454aee164
+DIST ssddiff-0.2.tar.bz2 86679 RMD160 005af16b657bde7b361076ea786ec3bec92738b0 SHA1 f9de7bbff61882adf64916da20545ce25637d1bf SHA256 2c0c3fe73d149f92b74005805c5b5135a47d88eea83493255c31ab931281b9be
+EBUILD ssddiff-0.2.ebuild 1193 RMD160 84fbe38e2f3cc652cdec367696a692699b0632c6 SHA1 5ad7ca33d271b1fb63cab4955b914586bca26182 SHA256 cb66e6b4e824c960253d8e9fba09260b6774c03e90a5b6ae48414f53dd08e3e6
+MISC ChangeLog 333 RMD160 209c53ebe2271f9ff3e97880f4d1ac4bb32a3e9d SHA1 5d1d3584c7ad3922772648f6f8385a30fd4693a8 SHA256 37d47d2b026e8836471a23d83e83d360b65f6d0fb0d5a4ac69278b0d9666b1e2
+MISC metadata.xml 233 RMD160 da5a1d3b7836dcebb5fec29696b5bfb583fe346c SHA1 1c7142c677598358888a6cfc6f6f65df2e8b6901 SHA256 4d1294dc1b2a6f96aa637a0b8d340bc67191103af0f15197d07fc62446b4a709
diff --git a/app-text/ssddiff/files/ssddiff-0.2+gcc-4.3.patch b/app-text/ssddiff/files/ssddiff-0.2+gcc-4.3.patch
new file mode 100644
index 000000000000..cc47387b7eaa
--- /dev/null
+++ b/app-text/ssddiff/files/ssddiff-0.2+gcc-4.3.patch
@@ -0,0 +1,24 @@
+Index: ssddiff-0.2/src/rel_count.h
+===================================================================
+--- ssddiff-0.2.orig/src/rel_count.h
++++ ssddiff-0.2/src/rel_count.h
+@@ -15,6 +15,7 @@
+ #include "rel_eqclass.h"
+ #include <vector>
+ #include <ext/hash_map>
++#include <climits>
+
+ using namespace std;
+
+Index: ssddiff-0.2/src/ustring.h
+===================================================================
+--- ssddiff-0.2.orig/src/ustring.h
++++ ssddiff-0.2/src/ustring.h
+@@ -17,6 +17,7 @@
+ #include <iostream>
+ #include <map>
+ #include <ext/hash_map>
++#include <cstring>
+
+ #include <libxml/tree.h> /* for xmlChar */
+
diff --git a/app-text/ssddiff/metadata.xml b/app-text/ssddiff/metadata.xml
new file mode 100644
index 000000000000..2d083ce3bc66
--- /dev/null
+++ b/app-text/ssddiff/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/ssddiff/ssddiff-0.2.ebuild b/app-text/ssddiff/ssddiff-0.2.ebuild
new file mode 100644
index 000000000000..5a288b34d96f
--- /dev/null
+++ b/app-text/ssddiff/ssddiff-0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ssddiff/ssddiff-0.2.ebuild,v 1.1 2008/05/19 10:22:30 flameeyes Exp $
+
+ALIOTH_ID=1469
+
+inherit eutils autotools
+
+DESCRIPTION="A diff application for semi-structured data (such as XML files)"
+HOMEPAGE="http://ssddiff.alioth.debian.org"
+SRC_URI="http://alioth.debian.org/download.php/${ALIOTH_ID}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}+gcc-4.3.patch"
+
+ # Avoid collision with xmldiff
+ sed -i -e 's/xmldiff/ssddiff/' src/Makefile.am \
+ || die "failed to rename binary"
+
+ # These are symlinks in the original tarball, recreate them as
+ # they point to automake 1.4 while we want, if possible, the
+ # last version in portage, while not everybody will have automake
+ # 1.4 available.
+ rm "${S}"/{missing,config.{sub,guess},mkinstalldirs,install-sh}
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README TODO AUTHORS NEWS ChangeLog
+}