summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-06-13 20:19:21 +0000
committerTim Harder <radhermit@gentoo.org>2015-06-13 20:19:21 +0000
commit3d73ffe9dc96a6e0ad0d22bfb6f0509249ea7916 (patch)
treea09dcbacbabddba764af1e3c6d663256dc82c25c /app-text
parentEAPI 5 bump. Fix bug 551988. (diff)
downloadgentoo-2-3d73ffe9dc96a6e0ad0d22bfb6f0509249ea7916.tar.gz
gentoo-2-3d73ffe9dc96a6e0ad0d22bfb6f0509249ea7916.tar.bz2
gentoo-2-3d73ffe9dc96a6e0ad0d22bfb6f0509249ea7916.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/yodl/ChangeLog7
-rw-r--r--app-text/yodl/yodl-3.05.01.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-text/yodl/ChangeLog b/app-text/yodl/ChangeLog
index 1bbbb9f918d2..06d4ac52ace5 100644
--- a/app-text/yodl/ChangeLog
+++ b/app-text/yodl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/yodl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/yodl/ChangeLog,v 1.23 2015/06/09 12:47:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/yodl/ChangeLog,v 1.24 2015/06/13 20:19:21 radhermit Exp $
+
+*yodl-3.05.01 (13 Jun 2015)
+
+ 13 Jun 2015; Tim Harder <radhermit@gentoo.org> +yodl-3.05.01.ebuild:
+ Version bump.
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/app-text/yodl/yodl-3.05.01.ebuild b/app-text/yodl/yodl-3.05.01.ebuild
new file mode 100644
index 000000000000..8707dc00948b
--- /dev/null
+++ b/app-text/yodl/yodl-3.05.01.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/yodl/yodl-3.05.01.ebuild,v 1.1 2015/06/13 20:19:21 radhermit Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Your Own Document Language: a pre-document language and tools to process it"
+HOMEPAGE="http://yodl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-util/icmake"
+
+src_prepare() {
+ sed -e "/DOC.* =/s/yodl\(-doc\)\?/${PF}/" \
+ -e "/COMPILER =/s/gcc/$(tc-getCC)/" \
+ -e "/CXX =/s/g++/$(tc-getCXX)/" \
+ -i INSTALL.im || die
+
+ sed -e "s/ar ru/$(tc-getAR) ru/" \
+ -e "s/ranlib/$(tc-getRANLIB)/" \
+ -i icmake/stdcompile || die
+}
+
+src_compile() {
+ ./build programs || die
+ ./build macros || die
+ ./build man || die
+ use doc && { ./build manual || die ; }
+}
+
+src_install() {
+ ./build install programs "${ED}" || die
+ ./build install macros "${ED}" || die
+ ./build install man "${ED}" || die
+ ./build install docs "${ED}" || die
+ use doc && { ./build install manual "${ED}" || die ; }
+}