summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-24 09:40:23 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-24 09:40:23 +0000
commit21f87827ca1862377b52ab1a543db6dd47de2cd7 (patch)
tree00960cd1787e86ec221119ff01b58f33f347f5eb /app-text
parentBump (diff)
downloadgentoo-2-21f87827ca1862377b52ab1a543db6dd47de2cd7.tar.gz
gentoo-2-21f87827ca1862377b52ab1a543db6dd47de2cd7.tar.bz2
gentoo-2-21f87827ca1862377b52ab1a543db6dd47de2cd7.zip
Bump to EAPI 4. Shorten the description. Use kde4 eclass specific var for handbook use flag. Fix .desktop file to pass validation.
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kding/ChangeLog11
-rw-r--r--app-text/kding/kding-0.6-r1.ebuild28
2 files changed, 36 insertions, 3 deletions
diff --git a/app-text/kding/ChangeLog b/app-text/kding/ChangeLog
index df1d27729850..7c494bc9d23c 100644
--- a/app-text/kding/ChangeLog
+++ b/app-text/kding/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/kding
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kding/ChangeLog,v 1.16 2011/01/30 12:42:03 tampakrap Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kding/ChangeLog,v 1.17 2012/08/24 09:40:23 johu Exp $
+
+*kding-0.6-r1 (24 Aug 2012)
+
+ 24 Aug 2012; Johannes Huber <johu@gentoo.org> +kding-0.6-r1.ebuild:
+ Bump to EAPI 4. Shorten the description. Use kde4 eclass specific var for
+ handbook use flag. Fix .desktop file to pass validation.
30 Jan 2011; Theo Chatzimichos <tampakrap@gentoo.org> kding-0.6.ebuild:
EAPI3
@@ -71,4 +77,3 @@
+files/kding-0.4.1-localization-de.patch, +metadata.xml,
+kding-0.4.1.ebuild:
Initial ebuild. Bug 189125, also thanks to Tobias Roeser (bug 124466).
-
diff --git a/app-text/kding/kding-0.6-r1.ebuild b/app-text/kding/kding-0.6-r1.ebuild
new file mode 100644
index 000000000000..9c60b3bed83d
--- /dev/null
+++ b/app-text/kding/kding-0.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kding/kding-0.6-r1.ebuild,v 1.1 2012/08/24 09:40:23 johu Exp $
+
+EAPI=4
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="de"
+inherit kde4-base
+
+DESCRIPTION="KDE port of Ding, a dictionary lookup program."
+HOMEPAGE="http://www.rexi.org/software/kding/"
+SRC_URI="http://www.rexi.org/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+PATCHES=( "${FILESDIR}"/${P}-dtd.patch )
+
+src_prepare() {
+ sed -e "/Encoding=UTF-8/d" \
+ -i resources/kding.desktop || die "fixing .desktop file failed"
+ sed -e "s/Office/Office;TextTools;Utility/" \
+ -i resources/kding.desktop || die "fixing .desktop file failed"
+
+ kde4-base_src_prepare
+}