summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2012-03-11 14:19:53 +0000
committerWolfram Schlich <wschlich@gentoo.org>2012-03-11 14:19:53 +0000
commit18be1b6d8897045967a3e588bbd2e684c2d67e4e (patch)
treeabbdf532e06725650a799c5af58d90c538615d57 /app-text
parentFix build failures due to atk underlinking. (diff)
downloadgentoo-2-18be1b6d8897045967a3e588bbd2e684c2d67e4e.tar.gz
gentoo-2-18be1b6d8897045967a3e588bbd2e684c2d67e4e.tar.bz2
gentoo-2-18be1b6d8897045967a3e588bbd2e684c2d67e4e.zip
keyworded ~amd64, respect LDFLAGS wrt bug #334459
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/utrac/ChangeLog10
-rw-r--r--app-text/utrac/files/Makefile.patch33
-rw-r--r--app-text/utrac/utrac-0.3.0-r1.ebuild28
3 files changed, 69 insertions, 2 deletions
diff --git a/app-text/utrac/ChangeLog b/app-text/utrac/ChangeLog
index 2a2eefd6f556..43eb6b66d01a 100644
--- a/app-text/utrac/ChangeLog
+++ b/app-text/utrac/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/utrac
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/utrac/ChangeLog,v 1.3 2009/09/23 16:42:36 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/utrac/ChangeLog,v 1.4 2012/03/11 14:19:53 wschlich Exp $
+
+*utrac-0.3.0-r1 (11 Mar 2012)
+
+ 11 Mar 2012; Wolfram Schlich <wschlich@gentoo.org> +utrac-0.3.0-r1.ebuild,
+ +files/Makefile.patch:
+ keyworded ~amd64, respect LDFLAGS wrt bug #334459
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> utrac-0.3.0.ebuild:
Remove virtual/libc
diff --git a/app-text/utrac/files/Makefile.patch b/app-text/utrac/files/Makefile.patch
new file mode 100644
index 000000000000..a127b1583e5f
--- /dev/null
+++ b/app-text/utrac/files/Makefile.patch
@@ -0,0 +1,33 @@
+diff -urN utrac-0.3.0.orig/Makefile utrac-0.3.0/Makefile
+--- utrac-0.3.0.orig/Makefile 2005-02-25 18:07:49.000000000 +0100
++++ utrac-0.3.0/Makefile 2012-03-11 15:16:32.072358827 +0100
+@@ -19,17 +19,17 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+-CC = gcc
++CC ?= gcc
+
+ #release :
+-CFLAGS = -Wall -O2 -DUT_DEBUG=1
++CFLAGS += -Wall -DUT_DEBUG=1
+
+ # debug
+ #CFLAGS = -Wall -g -DUT_DEBUG=1
+
+ LIBS = -lm
+
+-PREFIX_PATH = /usr/local
++PREFIX_PATH = ${DESTTREE}
+ LIB_PATH = ${PREFIX_PATH}/lib
+ INC_PATH = ${PREFIX_PATH}/include
+ BIN_PATH = ${PREFIX_PATH}/bin
+@@ -102,7 +102,7 @@
+ ###### COMMAND #####
+
+ utrac: utrac_cmd.o libutrac.a
+- $(CC) $^ $(LIBS) -o $@
++ $(CC) $^ $(LDFLAGS) $(LIBS) -o $@
+
+
+ ##### LIB #######
diff --git a/app-text/utrac/utrac-0.3.0-r1.ebuild b/app-text/utrac/utrac-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..cb4095dbc799
--- /dev/null
+++ b/app-text/utrac/utrac-0.3.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/utrac/utrac-0.3.0-r1.ebuild,v 1.1 2012/03/11 14:19:53 wschlich Exp $
+
+EAPI="4"
+inherit eutils
+
+IUSE=""
+DESCRIPTION="Universal Text Recognizer and Converter"
+HOMEPAGE="http://utrac.sourceforge.net/"
+SRC_URI="http://utrac.sourceforge.net/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/Makefile.patch
+}
+
+src_install() {
+ dobin utrac
+ doman utrac.1
+ dodoc README CHANGES CREDITS
+ dodir ${DESTTREE}/share/utrac
+ dolib.a libutrac.a
+ insinto ${DESTTREE}/share/utrac
+ doins charsets.dat
+}