summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-09-06 22:06:44 +0000
committerTim Harder <radhermit@gentoo.org>2012-09-06 22:06:44 +0000
commit137b5b1b215e7ba47b70a24176a0d632744c5fa0 (patch)
treeb9def385510d16bf54bef0280df1f3742de6b3c9 /app-text
parentVersion bump. (diff)
downloadgentoo-2-137b5b1b215e7ba47b70a24176a0d632744c5fa0.tar.gz
gentoo-2-137b5b1b215e7ba47b70a24176a0d632744c5fa0.tar.bz2
gentoo-2-137b5b1b215e7ba47b70a24176a0d632744c5fa0.zip
Version bump.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dos2unix/ChangeLog7
-rw-r--r--app-text/dos2unix/dos2unix-6.0.2.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index d258ab4016f5..057126920ebe 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/dos2unix
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.100 2012/07/27 05:50:02 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.101 2012/09/06 22:06:44 radhermit Exp $
+
+*dos2unix-6.0.2 (06 Sep 2012)
+
+ 06 Sep 2012; Tim Harder <radhermit@gentoo.org> +dos2unix-6.0.2.ebuild:
+ Version bump.
*dos2unix-6.0.1 (27 Jul 2012)
diff --git a/app-text/dos2unix/dos2unix-6.0.2.ebuild b/app-text/dos2unix/dos2unix-6.0.2.ebuild
new file mode 100644
index 000000000000..c2b44bde2a10
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-6.0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-6.0.2.ebuild,v 1.1 2012/09/06 22:06:44 radhermit Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls"
+
+RDEPEND="
+ !app-text/hd2u
+ !app-text/unix2dos
+ virtual/libintl"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/^CC/s|=|?=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(use nls && echo "LDFLAGS_EXTRA=$(lintl)" || echo "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(use nls || echo "ENABLE_NLS=") install
+}