summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-13 21:54:22 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-13 21:54:22 +0000
commit12790320098f8ca2fc38d8a26883c8da366ce7fb (patch)
treea97c1bd411d016d659dc9f41c623e5b55513f1b5 /app-text
parentfixed typo in deps (diff)
downloadgentoo-2-12790320098f8ca2fc38d8a26883c8da366ce7fb.tar.gz
gentoo-2-12790320098f8ca2fc38d8a26883c8da366ce7fb.tar.bz2
gentoo-2-12790320098f8ca2fc38d8a26883c8da366ce7fb.zip
php fix
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sablotron/ChangeLog14
-rw-r--r--app-text/sablotron/files/digest-sablotron-0.901
-rw-r--r--app-text/sablotron/files/digest-sablotron-0.95-r11
-rw-r--r--app-text/sablotron/files/sablotron-0.95-gentoo.patch26
-rw-r--r--app-text/sablotron/sablotron-0.95-r1.ebuild (renamed from app-text/sablotron/sablotron-0.90.ebuild)21
5 files changed, 55 insertions, 8 deletions
diff --git a/app-text/sablotron/ChangeLog b/app-text/sablotron/ChangeLog
index 2853334b4c9a..401e788e8b8f 100644
--- a/app-text/sablotron/ChangeLog
+++ b/app-text/sablotron/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for app-text/sablotron
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.3 2002/07/10 20:54:45 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.4 2002/07/13 21:54:21 seemant Exp $
+
+*sablotron-0.95-r1 (13 Jul 2002)
+
+ 13 Jul 2002; Seemant Kulleen <seemant@gentoo.org> sablotron-0.95-r1.ebuild
+ files/digest-sablotron-0.95-r1 files/sablotron-0.95-gentoo.patch :
+
+ gentoo@gonzo.ch (Roman Weber) submitted this after doing some excellent
+ research:
+ Added a patch that PHP compiles with sablotron enabled.
+ Source: http://bugs.php.net/bug.php?id=18184
+
+ Closes bug #4908.
*sablotron-0.95 (10 Jul 2002)
diff --git a/app-text/sablotron/files/digest-sablotron-0.90 b/app-text/sablotron/files/digest-sablotron-0.90
deleted file mode 100644
index 7190bc9d4435..000000000000
--- a/app-text/sablotron/files/digest-sablotron-0.90
+++ /dev/null
@@ -1 +0,0 @@
-MD5 48af1160b228310dd2dbc65b28075b61 Sablot-0.90.tar.gz 346863
diff --git a/app-text/sablotron/files/digest-sablotron-0.95-r1 b/app-text/sablotron/files/digest-sablotron-0.95-r1
new file mode 100644
index 000000000000..dd356f90f2a8
--- /dev/null
+++ b/app-text/sablotron/files/digest-sablotron-0.95-r1
@@ -0,0 +1 @@
+MD5 5dbcb6eabe8a962f9b84719cdb100390 Sablot-0.95.tar.gz 373842
diff --git a/app-text/sablotron/files/sablotron-0.95-gentoo.patch b/app-text/sablotron/files/sablotron-0.95-gentoo.patch
new file mode 100644
index 000000000000..c20cc3c3affc
--- /dev/null
+++ b/app-text/sablotron/files/sablotron-0.95-gentoo.patch
@@ -0,0 +1,26 @@
+*** sxpath.h Fri Jun 7 21:01:31 2002
+--- sxpath.h Thu Jun 27 13:35:17 2002
+***************
+*** 66,74 ****
+ typedef void *QueryContext;
+
+ /*option constants */
+! const unsigned long SXPF_DISPOSE_NAMES = 1;
+! const unsigned long SXPF_DISPOSE_VALUES = 2;
+! const unsigned long SXPF_SUPPORTS_UNPARSED_ENTITIES = 4;
+
+ /*
+ * DOM handler functions
+--- 66,77 ----
+ typedef void *QueryContext;
+
+ /*option constants */
+! typedef enum
+! {
+! SXPF_DISPOSE_NAMES = 0x1,
+! SXPF_DISPOSE_VALUES = 0x2,
+! SXPF_SUPPORTS_UNPARSED_ENTITIES =0x4
+! } SXPFlags;
+
+ /*
+ * DOM handler functions
diff --git a/app-text/sablotron/sablotron-0.90.ebuild b/app-text/sablotron/sablotron-0.95-r1.ebuild
index e98c07a6cb5e..8ce4069a0719 100644
--- a/app-text/sablotron/sablotron-0.90.ebuild
+++ b/app-text/sablotron/sablotron-0.95-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.90.ebuild,v 1.2 2002/07/11 06:30:19 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.95-r1.ebuild,v 1.1 2002/07/13 21:54:22 seemant Exp $
MY_P="Sablot-${PV}"
S=${WORKDIR}/${MY_P}
@@ -8,18 +8,27 @@ DESCRIPTION="An XSLT Parser in C++"
SRC_URI="http://www.gingerall.com/perl/rd?url=sablot/${MY_P}.tar.gz"
HOMEPAGE="http://www.gingerall.com/charlie-bin/get/webGA/act/sablotron.act"
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="x86"
+
DEPEND=">=sys-devel/gcc-2.95.2
>=dev-libs/expat-1.95.1
virtual/glibc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src/engine
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die
+}
src_compile() {
- ./configure --prefix=/usr --host=${CHOST} || die
- pmake || die
+ econf || die
+ emake || die
}
src_install () {
- make prefix=${D}/usr install || die
- dodoc README* RELEASE
- dodoc src/TODO
+ einstall prefix=${D}/usr || die
+ dodoc README* RELEASE
+ dodoc src/TODO
}