summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-04-09 04:36:31 +0000
committerMamoru Komachi <usata@gentoo.org>2005-04-09 04:36:31 +0000
commit1268a88a2d8b0b9b2ff8543dafa86beebd3e6bb7 (patch)
tree4c4764a9d7a8d5b0c820a07dc75ecce62916f3bd /app-text
parentadded app-text/djvu:nsplugin (diff)
downloadgentoo-2-1268a88a2d8b0b9b2ff8543dafa86beebd3e6bb7.tar.gz
gentoo-2-1268a88a2d8b0b9b2ff8543dafa86beebd3e6bb7.tar.bz2
gentoo-2-1268a88a2d8b0b9b2ff8543dafa86beebd3e6bb7.zip
Added several USE flags requested on bug #83311. Thanks to Diego Petteno <dgp85@users.sourceforge.net>.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/djvu/ChangeLog9
-rw-r--r--app-text/djvu/Manifest8
-rw-r--r--app-text/djvu/djvu-3.5.14-r1.ebuild65
-rw-r--r--app-text/djvu/files/digest-djvu-3.5.14-r11
-rw-r--r--app-text/djvu/files/gentoo-acdesktop.m462
5 files changed, 141 insertions, 4 deletions
diff --git a/app-text/djvu/ChangeLog b/app-text/djvu/ChangeLog
index 43f1029585c6..8e339a5351dc 100644
--- a/app-text/djvu/ChangeLog
+++ b/app-text/djvu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/djvu
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.19 2005/01/01 16:08:56 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.20 2005/04/09 04:36:31 usata Exp $
+
+*djvu-3.5.14-r1 (09 Apr 2005)
+
+ 09 Apr 2005; Mamoru KOMACHI <usata@gentoo.org> +files/gentoo-acdesktop.m4,
+ +djvu-3.5.14-r1.ebuild:
+ Added several USE flags requested on bug #83311. Thanks to Diego Petteno
+ <dgp85@users.sourceforge.net> for the patch.
16 Oct 2004; Jason Wever <weeve@gentoo.org> djvu-3.5.14.ebuild:
Stable on sparc.
diff --git a/app-text/djvu/Manifest b/app-text/djvu/Manifest
index 43ad9c54deea..fc2c2385dbc3 100644
--- a/app-text/djvu/Manifest
+++ b/app-text/djvu/Manifest
@@ -1,6 +1,8 @@
-MD5 a271e859b03105a47ee8951b00b67eec ChangeLog 2182
MD5 9597e2dc0afb409e42c4848e255abf08 djvu-3.5.12.ebuild 1051
+MD5 5d3ec0d1a87f77e87a2d1cca3d9f5141 djvu-3.5.14-r1.ebuild 1605
+MD5 a271e859b03105a47ee8951b00b67eec ChangeLog 2182
MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
-MD5 c745d000c44db4e7a24b614f0f86374b djvu-3.5.14.ebuild 1117
-MD5 376a63d9cbc58a7737d37680734f0ee0 files/digest-djvu-3.5.12 69
MD5 4a5cc41ce600d15a29fd720f279aaaf1 files/digest-djvu-3.5.14 69
+MD5 0da6de34d8db09192d2c881416108427 files/gentoo-acdesktop.m4 2491
+MD5 376a63d9cbc58a7737d37680734f0ee0 files/digest-djvu-3.5.12 69
+MD5 4a5cc41ce600d15a29fd720f279aaaf1 files/digest-djvu-3.5.14-r1 69
diff --git a/app-text/djvu/djvu-3.5.14-r1.ebuild b/app-text/djvu/djvu-3.5.14-r1.ebuild
new file mode 100644
index 000000000000..89854245076a
--- /dev/null
+++ b/app-text/djvu/djvu-3.5.14-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.14-r1.ebuild,v 1.1 2005/04/09 04:36:31 usata Exp $
+
+inherit nsplugins flag-o-matic fdo-mime
+
+MY_P="${PN}libre-${PV}"
+
+DESCRIPTION="DjVu viewers, encoders and utilities."
+HOMEPAGE="http://djvu.sourceforge.net"
+SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE="xml qt jpeg tiff debug threads nls pic nsplugin kde"
+
+DEPEND="jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( media-libs/tiff )
+ qt? ( >=x11-libs/qt-2.3 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ # Replace autochecking acdesktop.m4 with a gentoo-specific one
+ cp ${FILESDIR}/gentoo-acdesktop.m4 ${S}/gui/desktop/acdesktop.m4
+
+ cd ${S}
+ aclocal -I config -I gui/desktop || die "aclocal failed"
+ autoconf || die "autoconf failed"
+ libtoolize --copy --force
+}
+
+src_compile() {
+ # assembler problems and hence non-building with pentium4
+ # <obz@gentoo.org>
+ replace-flags -march=pentium4 -march=pentium3
+
+ if use kde; then
+ export kde_mimelnk=/usr/share/mimelnk
+ fi
+
+ econf --enable-desktopfiles \
+ $(use_enable xml xmltools) \
+ $(use_with qt) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ $(use_with pic) \
+ $(use_enable threads) \
+ $(use_enable nls i18n) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ if ! use nsplugin; then
+ sed -e 's:nsdjvu::' -i ${S}/gui/Makefile
+ fi
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} plugindir=${D}/usr/lib/${PLUGINS_DIR} install
+}
diff --git a/app-text/djvu/files/digest-djvu-3.5.14-r1 b/app-text/djvu/files/digest-djvu-3.5.14-r1
new file mode 100644
index 000000000000..7773823ac2f6
--- /dev/null
+++ b/app-text/djvu/files/digest-djvu-3.5.14-r1
@@ -0,0 +1 @@
+MD5 a9b60d0c47d6b98e321100d329c7f3b3 djvulibre-3.5.14.tar.gz 1742428
diff --git a/app-text/djvu/files/gentoo-acdesktop.m4 b/app-text/djvu/files/gentoo-acdesktop.m4
new file mode 100644
index 000000000000..61e59245d483
--- /dev/null
+++ b/app-text/djvu/files/gentoo-acdesktop.m4
@@ -0,0 +1,62 @@
+dnl Copyright (c) 2002 Leon Bottou and Yann Le Cun.
+dnl Copyright (c) 2001 AT&T
+dnl
+dnl Most of these macros are derived from macros listed
+dnl at the GNU Autoconf Macro Archive
+dnl http://www.gnu.org/software/ac-archive/
+dnl
+dnl This program is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 2 of the License, or
+dnl (at your option) any later version.
+dnl
+dnl This program is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+dnl GNU General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with this program; if not, write to the Free Software
+dnl Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA02111 USA
+dnl
+
+dnl -------------------------------------------------------
+dnl @synopsis AC_VARIFY(varname)
+dnl Replace expansion of $libdir, $datadir, $bindir, $prefix
+dnl by references to the variable.
+dnl -------------------------------------------------------
+AC_DEFUN([AC_VARIFY],[
+ xdir="`eval echo \"$libdir\"`"
+ $1=`echo [$]$1 | sed -e 's:^'"$xdir"'/:${libdir}/:'`
+ xdir="`eval echo \"$datadir\"`"
+ $1=`echo [$]$1 | sed -e 's:^'"$xdir"'/:${datadir}/:'`
+ xdir="`eval echo \"$bindir\"`"
+ $1=`echo [$]$1 | sed -e 's:^'"$xdir"'/:${bindir}/:'`
+ xdir="`eval echo \"$prefix\"`"
+ $1=`echo [$]$1 | sed -e 's:^'"$xdir"'/:${prefix}/:'`
+])
+
+
+dnl -------------------------------------------------------
+dnl @synopsis AC_LOCATE_DESKTOP_DIRS
+dnl Define installation paths for desktop config files
+dnl (mime types, menu entries, icons, etc.)
+dnl -------------------------------------------------------
+AC_DEFUN([AC_FIND_DESKTOP_DIRS],[
+ dtop_applications=/usr/share/applications # XDG menu entries
+ dtop_icons=/usr/share/icons # KDE-style icon directories
+ dtop_mime_info=/usr/share/mime-info # Gnome mime database
+ dtop_application_registry=/usr/share/application-registry # Gnome mime associations
+ dtop_mimelnk=${kde_mimelnk} # KDE mime database
+
+ AC_SUBST(dtop_applications)
+ AC_SUBST(dtop_icons)
+ AC_SUBST(dtop_pixmaps)
+ AC_SUBST(dtop_mime_info)
+ AC_SUBST(dtop_application_registry)
+ AC_SUBST(dtop_applnk)
+ AC_SUBST(dtop_mimelnk)
+ AC_SUBST(dtop_menu)
+])
+
+