summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-14 16:36:35 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-14 16:36:35 +0000
commit0b7c6dea62715eb5e155df458f0dbe4abcfd1f29 (patch)
tree991b27d0fdbe6a7b45ad9eae9a511c242c10991d /app-text
parentRemove old. (diff)
downloadgentoo-2-0b7c6dea62715eb5e155df458f0dbe4abcfd1f29.tar.gz
gentoo-2-0b7c6dea62715eb5e155df458f0dbe4abcfd1f29.tar.bz2
gentoo-2-0b7c6dea62715eb5e155df458f0dbe4abcfd1f29.zip
[QA] EAPI 1 -> 5. Revision bump. Verbose building, remove Application category, emake -j1, added dependencies.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/notecase/ChangeLog12
-rw-r--r--app-text/notecase/notecase-1.9.8-r1.ebuild (renamed from app-text/notecase/notecase-1.9.8.ebuild)34
2 files changed, 31 insertions, 15 deletions
diff --git a/app-text/notecase/ChangeLog b/app-text/notecase/ChangeLog
index 04eec9727a95..86331276e292 100644
--- a/app-text/notecase/ChangeLog
+++ b/app-text/notecase/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/notecase
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/ChangeLog,v 1.29 2012/05/04 03:33:17 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/ChangeLog,v 1.30 2014/05/14 16:36:35 tomwij Exp $
+
+*notecase-1.9.8-r1 (14 May 2014)
+
+ 14 May 2014; Tom Wijsman <TomWij@gentoo.org> +notecase-1.9.8-r1.ebuild,
+ -notecase-1.9.8.ebuild:
+ [QA] EAPI 1 -> 5. Revision bump. Verbose building, remove Application
+ category, emake -j1, added dependencies.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> notecase-1.9.8.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -149,4 +156,3 @@
14 May 2007; Raúl Porcel <armin76@gentoo.org>
+files/notecase-1.3.6-CFLAGS.patch, +metadata.xml, +notecase-1.5.6.ebuild:
New import, bug 144475
-
diff --git a/app-text/notecase/notecase-1.9.8.ebuild b/app-text/notecase/notecase-1.9.8-r1.ebuild
index 415cc760e375..730048e1f751 100644
--- a/app-text/notecase/notecase-1.9.8.ebuild
+++ b/app-text/notecase/notecase-1.9.8-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/notecase-1.9.8.ebuild,v 1.5 2012/05/04 03:33:17 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/notecase-1.9.8-r1.ebuild,v 1.1 2014/05/14 16:36:35 tomwij Exp $
-EAPI="1"
+EAPI="5"
inherit eutils fdo-mime
@@ -15,19 +15,16 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="gnome nls"
-RDEPEND=">=x11-libs/gtk+-2.6:2"
+RDEPEND="sys-libs/zlib:0
+ >=x11-libs/gtk+-2.6:2
+ x11-libs/libX11:0"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig:*"
# test doesn't work
RESTRICT="test"
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Respect CFLAGS and don't use --as-needed by default
epatch "${FILESDIR}/notecase-1.7.2-CFLAGS.patch"
epatch "${FILESDIR}"/${P}-gcc44.patch
@@ -44,10 +41,23 @@ src_unpack() {
sed -i -e 's/notecase$(EXE) poinstall/notecase$(EXE)/g' \
Makefile || die "nls sed failed"
}
+
+ # Verbose building, fix as-needed support and missing libs.
+ sed -e 's/^\(Q[CL]*=\)@.*$/\1/' \
+ -e 's:\(-o $(BIN)/notecase$(EXE) .*\) \($(GTKLIBS)\):\2 -lX11 -lz \1:' \
+ -i Makefile || die
+
+ # Remove Application category from .desktop file.
+ sed -i 's/^\(Categories=\)Application;/\1/' docs/notecase.desktop || die
+}
+
+src_compile() {
+ emake -j1
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ default
+
dodoc readme.txt
}