summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-10-28 19:20:07 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-10-28 19:20:07 +0000
commit0b3ae04d600953ca57829223a334704953bfcae7 (patch)
tree664ef9cd745be73911f86c8a674d3ad5b48687bd /app-text
parentVersion bump. (diff)
downloadgentoo-2-0b3ae04d600953ca57829223a334704953bfcae7.tar.gz
gentoo-2-0b3ae04d600953ca57829223a334704953bfcae7.tar.bz2
gentoo-2-0b3ae04d600953ca57829223a334704953bfcae7.zip
EAPI4, drop unused doc IUSE, add ~amd64, add static-libs IUSE, respect AR
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/psiconv/ChangeLog10
-rw-r--r--app-text/psiconv/psiconv-0.8.3-r1.ebuild32
2 files changed, 39 insertions, 3 deletions
diff --git a/app-text/psiconv/ChangeLog b/app-text/psiconv/ChangeLog
index a2fce5b61075..5ab48429ed91 100644
--- a/app-text/psiconv/ChangeLog
+++ b/app-text/psiconv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/psiconv
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/psiconv/ChangeLog,v 1.9 2008/04/21 17:05:02 phreak Exp $
+# Copyright 2000-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/psiconv/ChangeLog,v 1.10 2012/10/28 19:20:07 ago Exp $
+
+*psiconv-0.8.3-r1 (28 Oct 2012)
+
+ 28 Oct 2012; Agostino Sarubbo <ago@gentoo.org> +psiconv-0.8.3-r1.ebuild:
+ EAPI4, drop unused doc IUSE, add ~amd64, add static-libs IUSE, respect AR
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
@@ -24,4 +29,3 @@
Psiconv is a standalone tool for the reading and conversion of Psion
documents. It also provides a lib used by AbiWord to read same with a
plugin. Ebuild submitted by: MG <markgilbert@hotpop.com> in bug #28717
-
diff --git a/app-text/psiconv/psiconv-0.8.3-r1.ebuild b/app-text/psiconv/psiconv-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..8135d5bcc750
--- /dev/null
+++ b/app-text/psiconv/psiconv-0.8.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/psiconv/psiconv-0.8.3-r1.ebuild,v 1.1 2012/10/28 19:20:07 ago Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="An interpreter for Psion 5(MX) file formats"
+HOMEPAGE="http://huizen.dds.nl/~frodol/psiconv"
+SRC_URI="http://huizen.dds.nl/~frodol/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="static-libs"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+DEPEND="virtual/libc"
+RDEPEND=""
+
+src_prepare() {
+ tc-export AR
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || rm -fr "${D}"usr/lib*/lib${PN}.la
+}