summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-18 09:18:34 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-18 09:18:34 +0000
commit0ac760dd01a7b42df9e369d21f71fbaf3f07ab8c (patch)
treed8d3d58c8891061332a117a658cdbdcdd059655a /app-text
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-0ac760dd01a7b42df9e369d21f71fbaf3f07ab8c.tar.gz
gentoo-2-0ac760dd01a7b42df9e369d21f71fbaf3f07ab8c.tar.bz2
gentoo-2-0ac760dd01a7b42df9e369d21f71fbaf3f07ab8c.zip
version bump. cleaned up src_install, installed compat scripts to ispell-aspell and spell-aspell
Diffstat (limited to 'app-text')
-rw-r--r--app-text/aspell/ChangeLog11
-rw-r--r--app-text/aspell/Manifest4
-rw-r--r--app-text/aspell/aspell-0.50.5.ebuild60
-rw-r--r--app-text/aspell/files/digest-aspell-0.50.51
-rw-r--r--app-text/aspell/metadata.xml5
5 files changed, 78 insertions, 3 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index ad41a0f67193..17f25320a9de 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/aspell
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.28 2003/11/15 03:01:26 agriffis Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.29 2004/02/18 09:18:33 liquidx Exp $
+
+*aspell-0.50.5 (18 Feb 2004)
+
+ 18 Feb 2004; Alastair Tse <liquidx@gentoo.org> aspell-0.50.5.ebuild,
+ metadata.xml:
+ version bump. cleaned up src_install, installed compat scripts to
+ ispell-aspell and spell-aspell
14 Nov 2003; Aron Griffis <agriffis@gentoo.org> aspell-0.50.4.1.ebuild:
Stable on ia64
diff --git a/app-text/aspell/Manifest b/app-text/aspell/Manifest
index 3416e1713c7d..fd140526e035 100644
--- a/app-text/aspell/Manifest
+++ b/app-text/aspell/Manifest
@@ -1,7 +1,9 @@
MD5 10e9049162955e05a92f85e43bb135fa ChangeLog 5735
MD5 e04e4e87f5d0511c429244ea515c24f7 aspell-0.50.3.ebuild 1481
MD5 e051108a586ab0c2f50a187714839f37 aspell-0.50.4.1.ebuild 1434
-MD5 b266f4134f47fc1c8152daa6d4276f26 files/digest-aspell-0.50.3 65
+MD5 ba2a54b08708852808c3c3c863713a41 aspell-0.50.5.ebuild 1390
MD5 4fa550930c5e5fb38177ac9f77619891 files/01-gcc3.3-assert.patch 309
MD5 f956a4b48687a0823d0d5d7608b567e9 files/02-gcc3.3-constcast.patch 453
+MD5 b266f4134f47fc1c8152daa6d4276f26 files/digest-aspell-0.50.3 65
MD5 9d6c4f620a419b9ef08ddaf327adff75 files/digest-aspell-0.50.4.1 67
+MD5 1b5d84b6b88a3dfe388ad2e4b1f48155 files/digest-aspell-0.50.5 66
diff --git a/app-text/aspell/aspell-0.50.5.ebuild b/app-text/aspell/aspell-0.50.5.ebuild
new file mode 100644
index 000000000000..7bdded9c82ae
--- /dev/null
+++ b/app-text/aspell/aspell-0.50.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.5.ebuild,v 1.1 2004/02/18 09:18:33 liquidx Exp $
+
+inherit libtool
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm -amd64 ~ia64"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+pkg_setup() {
+ if [ ${ARCH} = "ppc" ] ; then
+ CXXFLAGS="-O2 -fsigned-char"
+ CFLAGS=${CXXFLAGS}
+ fi
+}
+
+src_compile() {
+ elibtoolize --reverse-deps
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ dodoc README* TODO
+
+ make DESTDIR=${D} install || die
+ mv ${D}/usr/share/doc/${PF}/man-html ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/man-text ${D}/usr/share/doc/${PF}/text
+
+ # install ispell/aspell compatibility scripts
+ exeinto /usr/bin
+ newexe scripts/ispell ispell-aspell
+ newexe scripts/spell spell-aspell
+
+ cd examples
+ make clean || die
+ docinto examples
+ dodoc ${S}/examples/*
+
+}
+
+pkg_postinst() {
+ einfo "You will need to install a dictionary now. Please choose an"
+ einfo "aspell-<LANG> dictionary from the app-dicts category"
+ einfo "After installing an aspell dictionary for your language(s),"
+ einfo "You may use the aspell-import utility to import your personal"
+ einfo "dictionaries from ispell, pspell and the older aspell"
+}
diff --git a/app-text/aspell/files/digest-aspell-0.50.5 b/app-text/aspell/files/digest-aspell-0.50.5
new file mode 100644
index 000000000000..d497ea8286ff
--- /dev/null
+++ b/app-text/aspell/files/digest-aspell-0.50.5
@@ -0,0 +1 @@
+MD5 14403d2ea5ded5d3fc9bb259bf65aab5 aspell-0.50.5.tar.gz 1016586
diff --git a/app-text/aspell/metadata.xml b/app-text/aspell/metadata.xml
new file mode 100644
index 000000000000..8f9450df306e
--- /dev/null
+++ b/app-text/aspell/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>app-dicts</herd>
+</pkgmetadata>