summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-27 23:10:41 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-27 23:10:41 +0000
commit069d4d11dfddb58580928682d54a6a6af80f9922 (patch)
tree0bd45c1bb430fc23a61fa58d6839103067013657 /app-text
parentadd keyring use flag for app-text/evince and fix description where needed. (diff)
downloadgentoo-2-069d4d11dfddb58580928682d54a6a6af80f9922.tar.gz
gentoo-2-069d4d11dfddb58580928682d54a6a6af80f9922.tar.bz2
gentoo-2-069d4d11dfddb58580928682d54a6a6af80f9922.zip
New version for GNOME 2.22. Uses GIO, lots of bug and crash fixes. Uses libspectre in place of ghostscript. gnome-keyring is now optional.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/evince/ChangeLog9
-rw-r--r--app-text/evince/evince-2.22.0.ebuild78
-rw-r--r--app-text/evince/files/evince-2.22.0-gtk-doc-die-die-die.patch27
3 files changed, 113 insertions, 1 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index 49ed733b3c9d..93afa5a9abb1 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/evince
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.135 2008/02/04 04:00:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.136 2008/03/27 23:10:40 eva Exp $
+
+*evince-2.22.0 (27 Mar 2008)
+
+ 27 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/evince-2.22.0-gtk-doc-die-die-die.patch, +evince-2.22.0.ebuild:
+ New version for GNOME 2.22. Uses GIO, lots of bug and crash fixes. Uses
+ libspectre in place of ghostscript. gnome-keyring is now optional.
04 Feb 2008; Jeroen Roovers <jer@gentoo.org> evince-2.20.2.ebuild:
Stable for HPPA (bug #208366).
diff --git a/app-text/evince/evince-2.22.0.ebuild b/app-text/evince/evince-2.22.0.ebuild
new file mode 100644
index 000000000000..26c02db339ea
--- /dev/null
+++ b/app-text/evince/evince-2.22.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-2.22.0.ebuild,v 1.1 2008/03/27 23:10:40 eva Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus djvu doc dvi gnome keyring t1lib tiff"
+
+RDEPEND="
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.15.6
+ keyring? ( >=gnome-base/gnome-keyring-2.20.1 )
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/libgnome-2.14
+ >=x11-themes/gnome-icon-theme-2.17.1
+ >=dev-libs/libxml2-2.5
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-2
+ gnome? ( >=gnome-base/nautilus-2.10 )
+ >=app-text/poppler-bindings-0.6
+ dvi? (
+ virtual/tetex
+ t1lib? ( >=media-libs/t1lib-5.0.0 )
+ )
+ tiff? ( >=media-libs/tiff-3.6 )
+ djvu? ( >=app-text/djvu-3.5.17 )
+ >=app-text/libspectre-0.2.0"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=sys-devel/automake-1.9
+ >=dev-util/intltool-0.35
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+ELTCONF="--portage"
+RESTRICT="test"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --enable-comics
+ --enable-impress
+ $(use_enable dbus)
+ $(use_enable djvu)
+ $(use_enable dvi)
+ $(use_with keyring)
+ $(use_enable t1lib)
+ $(use_enable tiff)
+ $(use_enable gnome nautilus)"
+
+ if ! built_with_use app-text/poppler-bindings gtk; then
+ einfo "Please re-emerge app-text/poppler-bindings with the gtk USE flag set"
+ die "poppler-bindings needs gtk flag set"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix .desktop file so menu item shows up
+ epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
+
+ # Make dbus actually switchable
+ epatch "${FILESDIR}"/${PN}-0.6.1-dbus-switch.patch
+
+ use doc || epatch "${FILESDIR}/${PN}-2.22.0-gtk-doc-die-die-die.patch"
+
+ eautoreconf
+}
diff --git a/app-text/evince/files/evince-2.22.0-gtk-doc-die-die-die.patch b/app-text/evince/files/evince-2.22.0-gtk-doc-die-die-die.patch
new file mode 100644
index 000000000000..6103c4c34ee1
--- /dev/null
+++ b/app-text/evince/files/evince-2.22.0-gtk-doc-die-die-die.patch
@@ -0,0 +1,27 @@
+--- configure.ac.orig 2008-03-11 19:09:44.000000000 -0700
++++ configure.ac 2008-03-11 19:10:37.000000000 -0700
+@@ -29,7 +29,11 @@
+ GNOME_CXX_WARNINGS
+ GNOME_DEBUG_CHECK
+
++dnl Crazy hack for dropping dep on gtk-doc
++AC_DEFUN(GTK_DOC_CHECK, [])
+ GTK_DOC_CHECK(1.0)
++AM_CONDITIONAL(ENABLE_GTK_DOC, 0, [])
++AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, 0, [])
+
+ GETTEXT_PACKAGE=evince
+ AC_SUBST(GETTEXT_PACKAGE)
+--- help/Makefile.old.am 2008-03-15 12:54:08.000000000 +0100
++++ help/Makefile.am 2008-03-15 12:54:40.000000000 +0100
+@@ -1,4 +1,9 @@
+-SUBDIRS = reference
++
++SUBDIRS =
++
++if ENABLE_GTK_DOC
++SUBDIRS += reference
++endif
+
+ include $(top_srcdir)/gnome-doc-utils.make
+ dist-hook: doc-dist-hook