summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-07 15:35:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-07 15:35:08 +0000
commit0349959eb66249579058c65cc95eb9c6bbf3d11e (patch)
tree280ad75f7b83c5c38fa2c836753e288abad180d1 /app-text
parentStable for ia64, wrt bug #469752 (diff)
downloadgentoo-2-0349959eb66249579058c65cc95eb9c6bbf3d11e.tar.gz
gentoo-2-0349959eb66249579058c65cc95eb9c6bbf3d11e.tar.bz2
gentoo-2-0349959eb66249579058c65cc95eb9c6bbf3d11e.zip
install texmf files in texmf-site so that texlive 2013 finds them
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dvipdfmx/ChangeLog8
-rw-r--r--app-text/dvipdfmx/dvipdfmx-20110311-r1.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/app-text/dvipdfmx/ChangeLog b/app-text/dvipdfmx/ChangeLog
index cb46374baecf..cae8b7083ac3 100644
--- a/app-text/dvipdfmx/ChangeLog
+++ b/app-text/dvipdfmx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/dvipdfmx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dvipdfmx/ChangeLog,v 1.75 2013/04/27 08:32:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvipdfmx/ChangeLog,v 1.76 2013/07/07 15:35:08 aballier Exp $
+
+*dvipdfmx-20110311-r1 (07 Jul 2013)
+
+ 07 Jul 2013; Alexis Ballier <aballier@gentoo.org>
+ +dvipdfmx-20110311-r1.ebuild:
+ install texmf files in texmf-site so that texlive 2013 finds them
27 Apr 2013; Patrick Lauer <patrick@gentoo.org> dvipdfmx-20110311.ebuild:
Automake 1.13 fix
diff --git a/app-text/dvipdfmx/dvipdfmx-20110311-r1.ebuild b/app-text/dvipdfmx/dvipdfmx-20110311-r1.ebuild
new file mode 100644
index 000000000000..faf651107a44
--- /dev/null
+++ b/app-text/dvipdfmx/dvipdfmx-20110311-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvipdfmx/dvipdfmx-20110311-r1.ebuild,v 1.1 2013/07/07 15:35:08 aballier Exp $
+
+EAPI=3
+inherit autotools eutils texlive-common
+
+DESCRIPTION="DVI to PDF translator with multi-byte character support"
+HOMEPAGE="http://project.ktug.or.kr/dvipdfmx/"
+SRC_URI="http://project.ktug.or.kr/${PN}/snapshot/latest/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND="app-text/libpaper
+ >=media-libs/libpng-1.2:0
+ sys-libs/zlib
+ dev-libs/kpathsea
+ app-text/libpaper"
+RDEPEND="${DEPEND}
+ virtual/tex-base
+ >=app-text/poppler-0.12.3-r3
+ app-text/poppler-data"
+
+src_prepare() {
+ epatch "${FILESDIR}"/20090708-fix_file_collisions.patch
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die
+ eautoreconf
+}
+
+src_install() {
+ # Override dvipdfmx.cfg default installation location so that it is easy to
+ # modify it and it gets config protected. Symlink it from the old location.
+ emake configdatadir="${EPREFIX}/etc/texmf/dvipdfmx" \
+ glyphlistdatadir="${EPREFIX}/usr/share/texmf-site/fonts/map/glyphlist" \
+ mapdatadir="${EPREFIX}/usr/share/texmf-site/fonts/map/dvipdfmx" \
+ DESTDIR="${D}" \
+ install || die
+ dosym /etc/texmf/dvipdfmx/dvipdfmx.cfg /usr/share/texmf-site/dvipdfmx/dvipdfmx.cfg || die
+
+ # Symlink poppler-data cMap, bug #201258
+ dosym /usr/share/poppler/cMap /usr/share/texmf-site/fonts/cmap/cMap || die
+ dodoc AUTHORS ChangeLog README || die
+
+ # Remove symlink conflicting with app-text/dvipdfm (bug #295235)
+ rm "${ED}"/usr/bin/ebb
+}
+
+pkg_postinst() {
+ etexmf-update
+}
+
+pkg_postrm() {
+ etexmf-update
+}