summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-12-30 17:42:10 +0000
committerAlex Alexander <wired@gentoo.org>2010-12-30 17:42:10 +0000
commit7bed02e8cc8cce2638567b00eb2dbd7312a827f9 (patch)
tree09407ebabd3087638d6998612629d493cf93a51b /app-text/zathura
parentAdded upstream patch to kill the multitudes of QPainter::...: Painter not act... (diff)
downloadgentoo-2-7bed02e8cc8cce2638567b00eb2dbd7312a827f9.tar.gz
gentoo-2-7bed02e8cc8cce2638567b00eb2dbd7312a827f9.tar.bz2
gentoo-2-7bed02e8cc8cce2638567b00eb2dbd7312a827f9.zip
added patch for poppler-0.16, bug #349941
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'app-text/zathura')
-rw-r--r--app-text/zathura/ChangeLog6
-rw-r--r--app-text/zathura/files/zathura-poppler-0.16.patch13
-rw-r--r--app-text/zathura/zathura-0.0.8.2.ebuild8
3 files changed, 23 insertions, 4 deletions
diff --git a/app-text/zathura/ChangeLog b/app-text/zathura/ChangeLog
index f9a6740774d2..211149fceb55 100644
--- a/app-text/zathura/ChangeLog
+++ b/app-text/zathura/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/zathura
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/ChangeLog,v 1.13 2010/12/30 12:10:51 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/ChangeLog,v 1.14 2010/12/30 17:42:10 wired Exp $
+
+ 30 Dec 2010; Alex Alexander <wired@gentoo.org> zathura-0.0.8.2.ebuild,
+ +files/zathura-poppler-0.16.patch:
+ added patch for poppler-0.16, bug #349941
30 Dec 2010; Alex Alexander <wired@gentoo.org> zathura-0.0.7.ebuild,
zathura-0.0.8.ebuild, zathura-0.0.8.1.ebuild, zathura-0.0.8.2.ebuild:
diff --git a/app-text/zathura/files/zathura-poppler-0.16.patch b/app-text/zathura/files/zathura-poppler-0.16.patch
new file mode 100644
index 000000000000..79c22bb28851
--- /dev/null
+++ b/app-text/zathura/files/zathura-poppler-0.16.patch
@@ -0,0 +1,13 @@
+patch that fixes poppler-0.16 compatibility
+
+http://pkgs.fedoraproject.org/gitweb/?p=zathura.git;a=blob;f=zathura-0.0.8.1-poppler-0.15-fix.patch;h=1e586b3cca2be43c7f70c7c2532ea4b2371892e8;hb=master
+--- zathura-0.0.8.1/zathura.c.poppler15
++++ zathura-0.0.8.1/zathura.c
+@@ -4300,7 +4300,7 @@ cb_view_button_release(GtkWidget* widget
+
+ /* get selected text */
+ g_static_mutex_lock(&(Zathura.Lock.pdflib_lock));
+- char* selected_text = poppler_page_get_text(
++ char* selected_text = poppler_page_get_selected_text(
+ Zathura.PDF.pages[Zathura.PDF.page_number]->page,SELECTION_STYLE,
+ &rectangle);
diff --git a/app-text/zathura/zathura-0.0.8.2.ebuild b/app-text/zathura/zathura-0.0.8.2.ebuild
index d791c51ab0d6..b71a09a5dc52 100644
--- a/app-text/zathura/zathura-0.0.8.2.ebuild
+++ b/app-text/zathura/zathura-0.0.8.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/zathura-0.0.8.2.ebuild,v 1.2 2010/12/30 12:10:51 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/zathura-0.0.8.2.ebuild,v 1.3 2010/12/30 17:42:10 wired Exp $
EAPI=2
-inherit savedconfig toolchain-funcs
+inherit savedconfig toolchain-funcs eutils
DESCRIPTION="A highly customizable and functional PDF viewer based on poppler and GTK+"
HOMEPAGE="http://zathura.pwmt.org/"
@@ -17,13 +17,15 @@ IUSE=""
RDEPEND=">=x11-libs/cairo-1.8.8
>=dev-libs/glib-2.22.4:2
>=x11-libs/gtk+-2.18.6:2
- <app-text/poppler-0.16[cairo]
>=app-text/poppler-0.12.3[cairo]"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
restore_config config.def.h
+
+ # bug #349941
+ has_version ">=app-text/poppler-0.15.0" && epatch "${FILESDIR}"/"${PN}"-poppler-0.16.patch
}
src_compile() {