summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-09-06 17:42:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-09-06 17:42:21 +0000
commitbf15da7622b2a7d3ff9467b201f8a178251f935f (patch)
tree7d11a11807a250115ebea49788b653af7e69507f /app-text/zathura/zathura-0.2.1.ebuild
parentmail-filter/postgrey add targrey patch, thanks to slepnoga (diff)
downloadgentoo-2-bf15da7622b2a7d3ff9467b201f8a178251f935f.tar.gz
gentoo-2-bf15da7622b2a7d3ff9467b201f8a178251f935f.tar.bz2
gentoo-2-bf15da7622b2a7d3ff9467b201f8a178251f935f.zip
Remove 0 byte manpages in src_prepare() for rst2man.py to generate them again wrt #434140 by José Romildo Malaquias
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'app-text/zathura/zathura-0.2.1.ebuild')
-rw-r--r--app-text/zathura/zathura-0.2.1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-text/zathura/zathura-0.2.1.ebuild b/app-text/zathura/zathura-0.2.1.ebuild
index b414d3d4fb9e..7fdeec83c5c4 100644
--- a/app-text/zathura/zathura-0.2.1.ebuild
+++ b/app-text/zathura/zathura-0.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/zathura-0.2.1.ebuild,v 1.1 2012/09/03 18:43:25 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/zathura/zathura-0.2.1.ebuild,v 1.2 2012/09/06 17:42:21 ssuominen Exp $
EAPI=4
inherit eutils multilib toolchain-funcs
@@ -28,7 +28,7 @@ pkg_setup() {
ZATHURA_GTK_VERSION=2
WITH_SQLITE=$(usex sqlite 1 0)
LIBDIR='${PREFIX}'/$(get_libdir)
- RSTTOMAN="$(type -P rst2man.py || echo true)"
+ RSTTOMAN="$(use doc && type -P rst2man.py)"
CC="$(tc-getCC)"
SFLAGS=""
VERBOSE=1
@@ -36,6 +36,12 @@ pkg_setup() {
)
}
+src_prepare() {
+ # http://bugs.pwmt.org/msg816
+ # these are 0 byte files in dist tarball wrt #434140
+ rm *.{1,5}
+}
+
src_compile() {
emake "${myzathuraconf[@]}"
}
@@ -43,7 +49,4 @@ src_compile() {
src_install() {
emake "${myzathuraconf[@]}" install
dodoc AUTHORS
-
- # For rst2man.py and type -P hack in pkg_setup()
- use doc || rm -rf "${ED}"/usr/share/man
}