summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-06-19 03:28:39 +0000
committerMike Gilbert <floppym@gentoo.org>2012-06-19 03:28:39 +0000
commit27f721ce25c41d718ed68a02269e891316de2454 (patch)
tree4536240ee29f109fa3c61338f7277c5b2d740b55 /app-text/xml2doc
parentChange mask on sci-electronics/kicad to >=sci-electronics/kicad-99999999 beca... (diff)
downloadgentoo-2-27f721ce25c41d718ed68a02269e891316de2454.tar.gz
gentoo-2-27f721ce25c41d718ed68a02269e891316de2454.tar.bz2
gentoo-2-27f721ce25c41d718ed68a02269e891316de2454.zip
Respect CC, bug 243764.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-text/xml2doc')
-rw-r--r--app-text/xml2doc/ChangeLog7
-rw-r--r--app-text/xml2doc/xml2doc-20030510-r1.ebuild21
2 files changed, 16 insertions, 12 deletions
diff --git a/app-text/xml2doc/ChangeLog b/app-text/xml2doc/ChangeLog
index b12eca14136f..5f58a8bf2db1 100644
--- a/app-text/xml2doc/ChangeLog
+++ b/app-text/xml2doc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/xml2doc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/ChangeLog,v 1.26 2011/02/22 16:36:27 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/ChangeLog,v 1.27 2012/06/19 03:28:39 floppym Exp $
+
+ 19 Jun 2012; Mike Gilbert <floppym@gentoo.org> xml2doc-20030510-r1.ebuild:
+ Respect CC, bug 243764.
22 Feb 2011; Tomáš Chvátal <scarabeus@gentoo.org>
xml2doc-20030510-r1.ebuild:
diff --git a/app-text/xml2doc/xml2doc-20030510-r1.ebuild b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
index b8e001aae8c1..0bd73faeb304 100644
--- a/app-text/xml2doc/xml2doc-20030510-r1.ebuild
+++ b/app-text/xml2doc/xml2doc-20030510-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/xml2doc-20030510-r1.ebuild,v 1.10 2011/02/22 16:36:27 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/xml2doc-20030510-r1.ebuild,v 1.11 2012/06/19 03:28:39 floppym Exp $
-inherit eutils
+EAPI=4
+
+inherit eutils toolchain-funcs
DESCRIPTION="Tool to convert simple XML to a variety of formats (pdf, html, txt, manpage)"
@@ -20,24 +22,23 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Fix pointer-related bug detected by a QA notice.
epatch "${FILESDIR}/${PN}-pointer_fix.patch"
# Don't strip symbols from binary (bug #152266)
sed -i -e '/^\s*strip/d' \
- -e '/^CC=/d' \
-e 's/^\t$(CC) $(LFLAGS).*/\t$(LINK.o) $(L_PDF) $^ -lxml2 -o $(BIN)/' \
-e '/^\t$(CC) $(CFLAGS) /d' \
src/Makefile.in
}
-src_compile() {
+src_configure() {
econf --disable-pdf
- emake || die "Compilation failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
cd "${S}/doc"
"${S}"/src/xml2doc -oM manpage.xml xml2doc.1 || die