summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-11-30 23:43:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-11-30 23:43:45 +0000
commitcea78c358d37474200032dbe5f3dcc69937a5390 (patch)
tree4897bcfab0da61531f6d9c04780f8a45ac9640f5 /app-text/xfbib
parentVersion bump. (diff)
downloadgentoo-2-cea78c358d37474200032dbe5f3dcc69937a5390.tar.gz
gentoo-2-cea78c358d37474200032dbe5f3dcc69937a5390.tar.bz2
gentoo-2-cea78c358d37474200032dbe5f3dcc69937a5390.zip
Port from libxfcegui4 to libxfce4ui. Validate xfbib.desktop using desktop-file-utils.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-text/xfbib')
-rw-r--r--app-text/xfbib/ChangeLog9
-rw-r--r--app-text/xfbib/files/xfbib-0.0.2-libxfce4ui.patch106
-rw-r--r--app-text/xfbib/files/xfbib-0.0.2-validate.patch19
-rw-r--r--app-text/xfbib/xfbib-0.0.2-r1.ebuild41
4 files changed, 174 insertions, 1 deletions
diff --git a/app-text/xfbib/ChangeLog b/app-text/xfbib/ChangeLog
index 4e155b3f989b..78bfe54285b6 100644
--- a/app-text/xfbib/ChangeLog
+++ b/app-text/xfbib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/xfbib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xfbib/ChangeLog,v 1.4 2012/11/15 19:45:56 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xfbib/ChangeLog,v 1.5 2012/11/30 23:43:45 ssuominen Exp $
+
+*xfbib-0.0.2-r1 (30 Nov 2012)
+
+ 30 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +xfbib-0.0.2-r1.ebuild,
+ +files/xfbib-0.0.2-libxfce4ui.patch, +files/xfbib-0.0.2-validate.patch:
+ Port from libxfcegui4 to libxfce4ui. Validate xfbib.desktop using
+ desktop-file-utils.
16 Nov 2012; Andreas Schuerch <nativemad@gentoo.org> xfbib-0.0.2.ebuild:
x86 stable, see bug 429484
diff --git a/app-text/xfbib/files/xfbib-0.0.2-libxfce4ui.patch b/app-text/xfbib/files/xfbib-0.0.2-libxfce4ui.patch
new file mode 100644
index 000000000000..0759dbf4e61d
--- /dev/null
+++ b/app-text/xfbib/files/xfbib-0.0.2-libxfce4ui.patch
@@ -0,0 +1,106 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=9568
+
+--- src/entry_edit_dialog.c
++++ src/entry_edit_dialog.c
+@@ -17,7 +17,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <config.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+
+ #include "entry_edit_dialog.h"
+ #include "entry.h"
+@@ -589,11 +589,13 @@
+ key = (char *) gtk_entry_get_text(GTK_ENTRY(key_entry));
+ if ((type = gtk_combo_box_get_active_text(GTK_COMBO_BOX(combobox))) == NULL) {
+ _DEBUG(("No type selected"));
+- xfce_warn(_("No type was selected"));
++ /* xfce_warn(_("No type was selected")); */
++ xfce_dialog_show_warning(NULL,NULL,_("No type was selected"));
+ continue;
+ } else if (strcmp(key, "") == 0) {
+ _DEBUG(("No key selected"));
+- xfce_warn(_("No key was selected"));
++ /* xfce_warn(_("No key was selected")); */
++ xfce_dialog_show_warning(NULL,NULL,_("No key was selected"));
+ continue;
+ } else {
+ if (selected == NULL) {
+--- src/menubar.c
++++ src/menubar.c
+@@ -15,7 +15,7 @@
+ */
+
+ #include <gtk/gtk.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <libintl.h>
+ #include <config.h>
+
+--- src/open.c
++++ src/open.c
+@@ -14,7 +14,7 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <config.h>
+ #include <string.h>
+ #include <stdlib.h>
+--- src/open_dialog.c
++++ src/open_dialog.c
+@@ -14,7 +14,7 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <libintl.h>
+ #include <string.h>
+ #include <stdlib.h>
+--- src/save_dialog.c
++++ src/save_dialog.c
+@@ -15,7 +15,7 @@
+ */
+
+ #include <libintl.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <config.h>
+
+ #include "xfbib.h"
+--- src/string_edit_dialog.c
++++ src/string_edit_dialog.c
+@@ -15,7 +15,7 @@
+ */
+
+ #include <gtk/gtk.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+
+ #include "debug.h"
+ #include "strings.h"
+--- src/treeview.c
++++ src/treeview.c
+@@ -14,7 +14,7 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <libintl.h>
+ #include <config.h>
+ #include <string.h>
+--- src/xfbib.c
++++ src/xfbib.c
+@@ -20,7 +20,7 @@
+
+ #include <gtk/gtk.h>
+ #include <stdlib.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <libintl.h>
+
+ #include "window.h"
diff --git a/app-text/xfbib/files/xfbib-0.0.2-validate.patch b/app-text/xfbib/files/xfbib-0.0.2-validate.patch
new file mode 100644
index 000000000000..a072b730c3a6
--- /dev/null
+++ b/app-text/xfbib/files/xfbib-0.0.2-validate.patch
@@ -0,0 +1,19 @@
+--- xfbib.desktop
++++ xfbib.desktop
+@@ -1,13 +1,11 @@
+-
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=Xfbib
+ Exec=xfbib
+ Icon=xfbib
+ Type=Application
+ Comment=A BibTeX editor for Xfce
+-Terminal=0
+-MimeType=text/x-bibtex
+-Categories=Application;Office;GTK;
++Terminal=false
++MimeType=text/x-bibtex;
++Categories=Office;GTK;
+ GenericName=
+ StartupNotify=false
diff --git a/app-text/xfbib/xfbib-0.0.2-r1.ebuild b/app-text/xfbib/xfbib-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..dde6019c8f60
--- /dev/null
+++ b/app-text/xfbib/xfbib-0.0.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xfbib/xfbib-0.0.2-r1.ebuild,v 1.1 2012/11/30 23:43:45 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="a lightweight BibTeX editor"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfbib"
+SRC_URI="http://goodies.xfce.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.12
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/${P}-validate.patch
+ "${FILESDIR}"/${P}-libxfce4ui.patch
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
+
+src_prepare() {
+ # This is to prevent eautoreconfigure:
+ sed -i -e 's:libxfcegui4-1.0:libxfce4ui-1:' configure || die
+ sed -i -e 's:$(LIBXFCE4UTIL_CFLAGS):& $(LIBXFCEGUI4_CFLAGS):' src/Makefile.in || die
+
+ xfconf_src_prepare
+}