summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-07-12 16:41:06 +0000
committerMarinus Schraal <foser@gentoo.org>2004-07-12 16:41:06 +0000
commit7221b749ba851af0cc99a03cf0a53bb2d18c61c3 (patch)
treec19af1ae90a392b711e7d014f3db5dcbef459104 /app-text/wv/wv-1.0.0-r1.ebuild
parentoptionally enable nettle support (Manifest recommit) (diff)
downloadgentoo-2-7221b749ba851af0cc99a03cf0a53bb2d18c61c3.tar.gz
gentoo-2-7221b749ba851af0cc99a03cf0a53bb2d18c61c3.tar.bz2
gentoo-2-7221b749ba851af0cc99a03cf0a53bb2d18c61c3.zip
add vulnerability fix + rev bump
Diffstat (limited to 'app-text/wv/wv-1.0.0-r1.ebuild')
-rw-r--r--app-text/wv/wv-1.0.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-text/wv/wv-1.0.0-r1.ebuild b/app-text/wv/wv-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..912c95b3b31a
--- /dev/null
+++ b/app-text/wv/wv-1.0.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv/wv-1.0.0-r1.ebuild,v 1.1 2004/07/12 16:41:06 foser Exp $
+
+inherit eutils
+
+DESCRIPTION="Tool for conversion of MSWord doc and rtf files to something readable"
+SRC_URI="mirror://sourceforge/wvware/${P}.tar.gz"
+HOMEPAGE="http://www.wvware.com"
+
+IUSE="xml2 wmf"
+KEYWORDS="x86 ppc sparc hppa alpha ia64 amd64"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="sys-libs/zlib
+ media-libs/libpng
+ wmf? ( >=media-libs/libwmf-0.2.2 )
+ xml2? ( dev-libs/libxml2 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Fix vulnerability (#56595)
+ epatch ${FILESDIR}/${P}-fix_overflow.patch
+
+}
+
+src_compile() {
+
+ econf \
+ `use_with xml2 libxml2` \
+ `use_with wmf libwmf` \
+ --with-docdir=/usr/share/doc/${PF} \
+ || die
+
+ make || die
+
+}
+
+src_install () {
+
+ einstall
+
+ insinto /usr/include
+ doins wvinternal.h
+
+ rm -f ${D}/usr/share/man/man1/wvConvert.1
+ dosym /usr/share/man/man1/wvWare.1 /usr/share/man/man1/wvConvert.1
+
+}