summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-01 22:44:15 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-01 22:44:15 +0000
commitc6cafbd425596e8a1aef7aeca22ed63479b46e25 (patch)
tree4ae78023603abd24aae09f408e13a7676b3e96d3 /app-text/unpaper
parentMask app-text/unpaper[libav] since it requires masked libav version. (diff)
downloadgentoo-2-c6cafbd425596e8a1aef7aeca22ed63479b46e25.tar.gz
gentoo-2-c6cafbd425596e8a1aef7aeca22ed63479b46e25.tar.bz2
gentoo-2-c6cafbd425596e8a1aef7aeca22ed63479b46e25.zip
Introduce USE=libav to control the preferred implementation. Add subslot op to force rebuilds on ABI change.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-text/unpaper')
-rw-r--r--app-text/unpaper/ChangeLog11
-rw-r--r--app-text/unpaper/unpaper-6.1-r1.ebuild42
-rw-r--r--app-text/unpaper/unpaper-9999.ebuild10
3 files changed, 57 insertions, 6 deletions
diff --git a/app-text/unpaper/ChangeLog b/app-text/unpaper/ChangeLog
index 19dd25d6b2ee..df6f39e01195 100644
--- a/app-text/unpaper/ChangeLog
+++ b/app-text/unpaper/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/unpaper
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/unpaper/ChangeLog,v 1.13 2014/10/26 23:07:48 flameeyes Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/unpaper/ChangeLog,v 1.14 2015/02/01 22:44:15 mgorny Exp $
+
+*unpaper-6.1-r1 (01 Feb 2015)
+
+ 01 Feb 2015; Michał Górny <mgorny@gentoo.org> +unpaper-6.1-r1.ebuild,
+ unpaper-9999.ebuild:
+ Introduce USE=libav to control the preferred implementation. Add subslot op to
+ force rebuilds on ABI change.
*unpaper-6.1 (26 Oct 2014)
diff --git a/app-text/unpaper/unpaper-6.1-r1.ebuild b/app-text/unpaper/unpaper-6.1-r1.ebuild
new file mode 100644
index 000000000000..40683305876a
--- /dev/null
+++ b/app-text/unpaper/unpaper-6.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/unpaper/unpaper-6.1-r1.ebuild,v 1.1 2015/02/01 22:44:15 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-2 autotools
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="libav test"
+
+RDEPEND="
+ libav? ( >=media-video/libav-10:0=[encode] )
+ !libav? ( >=media-video/ffmpeg-2:0=[encode] )"
+DEPEND="dev-libs/libxslt
+ app-text/docbook-xsl-ns-stylesheets
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+# gcc can generate slightly different code that leads to slightly different
+# images. Wait until we get a better testsuite.
+RESTRICT="test"
+
+if [[ ${PV} == 9999 ]]; then
+ src_prepare() {
+ eautoreconf
+ autotools-utils_src_prepare
+ }
+fi
diff --git a/app-text/unpaper/unpaper-9999.ebuild b/app-text/unpaper/unpaper-9999.ebuild
index 8789805d3e7e..d75b4b245292 100644
--- a/app-text/unpaper/unpaper-9999.ebuild
+++ b/app-text/unpaper/unpaper-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/unpaper/unpaper-9999.ebuild,v 1.6 2014/10/26 23:07:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/unpaper/unpaper-9999.ebuild,v 1.7 2015/02/01 22:44:15 mgorny Exp $
EAPI=5
@@ -20,9 +20,11 @@ HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
LICENSE="GPL-2"
SLOT="0"
-IUSE="test"
+IUSE="libav test"
-RDEPEND="|| ( >=media-video/libav-10[encode] >=media-video/ffmpeg-2[encode] )"
+RDEPEND="
+ libav? ( >=media-video/libav-10:0=[encode] )
+ !libav? ( >=media-video/ffmpeg-2:0=[encode] )"
DEPEND="dev-libs/libxslt
app-text/docbook-xsl-ns-stylesheets
virtual/pkgconfig