summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-05 09:11:03 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-05 09:11:03 +0000
commit6f02634b14e3f19824c017f32842f3dd7f16d5fc (patch)
tree19f53fef4a3d1405d32eaf1ef9538dabd12b2d38 /app-text/unix2dos/unix2dos-2.2-r1.ebuild
parentFix implicit RDEPEND assignment. (diff)
downloadgentoo-2-6f02634b14e3f19824c017f32842f3dd7f16d5fc.tar.gz
gentoo-2-6f02634b14e3f19824c017f32842f3dd7f16d5fc.tar.bz2
gentoo-2-6f02634b14e3f19824c017f32842f3dd7f16d5fc.zip
Some Clean up
(Portage version: 2.2.0_alpha12/cvs/Linux x86_64)
Diffstat (limited to 'app-text/unix2dos/unix2dos-2.2-r1.ebuild')
-rw-r--r--app-text/unix2dos/unix2dos-2.2-r1.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/app-text/unix2dos/unix2dos-2.2-r1.ebuild b/app-text/unix2dos/unix2dos-2.2-r1.ebuild
index 939535c88b78..a7a41c888f98 100644
--- a/app-text/unix2dos/unix2dos-2.2-r1.ebuild
+++ b/app-text/unix2dos/unix2dos-2.2-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/unix2dos/unix2dos-2.2-r1.ebuild,v 1.11 2010/03/20 16:12:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/unix2dos/unix2dos-2.2-r1.ebuild,v 1.12 2011/01/05 09:11:03 jlec Exp $
+
+EAPI="3"
inherit eutils toolchain-funcs
@@ -14,16 +16,17 @@ KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 sh sparc x86 ~amd64-linux ~x86-li
IUSE=""
RDEPEND="!>=app-text/dos2unix-5"
+DEPEND=""
-S=${WORKDIR}
+S="${WORKDIR}"
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-mkstemp.patch
- epatch "${FILESDIR}"/${P}-segfault.patch
- epatch "${FILESDIR}"/${P}-manpage.patch
- epatch "${FILESDIR}"/${P}-workaround-rename-EXDEV.patch
- epatch "${FILESDIR}"/${P}-headers.patch
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-mkstemp.patch \
+ "${FILESDIR}"/${P}-segfault.patch \
+ "${FILESDIR}"/${P}-manpage.patch \
+ "${FILESDIR}"/${P}-workaround-rename-EXDEV.patch \
+ "${FILESDIR}"/${P}-headers.patch
}
src_compile() {
@@ -32,5 +35,5 @@ src_compile() {
src_install() {
dobin unix2dos || die
- doman unix2dos.1
+ doman unix2dos.1 || die
}