summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-19 00:01:30 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-19 00:01:30 +0000
commit00a77d48c62fee86ab93db023d09385a37626c0b (patch)
tree30432cbc5599b30e63657981464530e3cfe97e36 /app-text/u2ps
parentFix potential buffer overflow in identity application (#339355) (diff)
downloadgentoo-2-00a77d48c62fee86ab93db023d09385a37626c0b.tar.gz
gentoo-2-00a77d48c62fee86ab93db023d09385a37626c0b.tar.bz2
gentoo-2-00a77d48c62fee86ab93db023d09385a37626c0b.zip
Moved from sunrise overlay. Thanks to Jure Varlec <jure.varlec@gmail.com>. Bug #335117
(Portage version: 2.1.9.31/cvs/Linux x86_64)
Diffstat (limited to 'app-text/u2ps')
-rw-r--r--app-text/u2ps/ChangeLog11
-rw-r--r--app-text/u2ps/metadata.xml15
-rw-r--r--app-text/u2ps/u2ps-0.8.1.ebuild45
3 files changed, 71 insertions, 0 deletions
diff --git a/app-text/u2ps/ChangeLog b/app-text/u2ps/ChangeLog
new file mode 100644
index 000000000000..ef1e52cb21f4
--- /dev/null
+++ b/app-text/u2ps/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/u2ps
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/u2ps/ChangeLog,v 1.1 2011/01/19 00:01:30 hwoarang Exp $
+
+*u2ps-0.8.1 (18 Jan 2011)
+
+ 18 Jan 2011; Markos Chandras <hwoarang@gentoo.org> +u2ps-0.8.1.ebuild,
+ +metadata.xml:
+ Moved from sunrise overlay. Thanks to Jure Varlec <jure.varlec@gmail.com>.
+ Bug #335117
+
diff --git a/app-text/u2ps/metadata.xml b/app-text/u2ps/metadata.xml
new file mode 100644
index 000000000000..41fe3bf0641c
--- /dev/null
+++ b/app-text/u2ps/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<use>
+ <flag name='fonts'>Install a more complete set of unicode fonts</flag>
+</use>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-text/u2ps/u2ps-0.8.1.ebuild b/app-text/u2ps/u2ps-0.8.1.ebuild
new file mode 100644
index 000000000000..e0008cd3e66f
--- /dev/null
+++ b/app-text/u2ps/u2ps-0.8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/u2ps/u2ps-0.8.1.ebuild,v 1.1 2011/01/19 00:01:30 hwoarang Exp $
+
+EAPI=2
+
+DESCRIPTION="A text to PostScript converter like a2ps, but supports UTF-8"
+HOMEPAGE="http://u2ps.berlios.de/"
+SRC_URI="!fonts? ( mirror://berlios/${PN}/${P}.tar.gz )
+ fonts? ( mirror://berlios/${PN}/${PN}-full-${PV}.tar.gz )"
+
+LICENSE="GPL-3 GPL-3-with-font-exception free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fonts"
+
+DEPEND="
+ >=dev-lang/perl-5.6
+ dev-perl/Text-CharWidth
+ app-text/ghostscript-gpl
+"
+RDEPEND="${DEPEND}"
+
+use fonts && S="${WORKDIR}/${PN}-full-${PV}"
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --with-perl=/usr/bin/perl \
+ --with-gs=/usr/bin/gs \
+ || die 'configure failed'
+}
+
+src_compile() {
+ emake || die 'make failed'
+ emake man || die 'make man failed'
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die 'install failed'
+ dodoc README DESIGN || die 'dodoc failed'
+ doman man/u2ps.1 || die 'doman failed'
+}