summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-08-13 10:59:38 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-08-13 10:59:38 +0000
commit87832906a90f09023a4fe17732e0cff575c6a6d1 (patch)
treeb24066807f234a3a7ce7b699d957a7fc7954b528 /app-text/tokyodystopia
parentChanged elog comment concerning iptables to make sure people install a recent... (diff)
downloadgentoo-2-87832906a90f09023a4fe17732e0cff575c6a6d1.tar.gz
gentoo-2-87832906a90f09023a4fe17732e0cff575c6a6d1.tar.bz2
gentoo-2-87832906a90f09023a4fe17732e0cff575c6a6d1.zip
Bump, fixes thanks to Johan Bergstroem. Fixes #331561
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text/tokyodystopia')
-rw-r--r--app-text/tokyodystopia/ChangeLog8
-rw-r--r--app-text/tokyodystopia/files/remove_docinst.patch13
-rw-r--r--app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild45
3 files changed, 65 insertions, 1 deletions
diff --git a/app-text/tokyodystopia/ChangeLog b/app-text/tokyodystopia/ChangeLog
index 7093c7177213..f6973de46f9d 100644
--- a/app-text/tokyodystopia/ChangeLog
+++ b/app-text/tokyodystopia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/tokyodystopia
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tokyodystopia/ChangeLog,v 1.3 2010/03/28 12:36:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/tokyodystopia/ChangeLog,v 1.4 2010/08/13 10:59:38 patrick Exp $
+
+*tokyodystopia-0.9.15 (13 Aug 2010)
+
+ 13 Aug 2010; Patrick Lauer <patrick@gentoo.org>
+ +tokyodystopia-0.9.15.ebuild, +files/remove_docinst.patch:
+ Bump, fixes thanks to Johan Bergstroem. Fixes #331561
*tokyodystopia-0.9.14 (28 Mar 2010)
diff --git a/app-text/tokyodystopia/files/remove_docinst.patch b/app-text/tokyodystopia/files/remove_docinst.patch
new file mode 100644
index 000000000000..d513f54b753c
--- /dev/null
+++ b/app-text/tokyodystopia/files/remove_docinst.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 8846c38..29ac11e 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -117,8 +117,6 @@ install :
+ cp -Rf $(COMMANDFILES) $(DESTDIR)$(BINDIR)
+ mkdir -p $(DESTDIR)$(LIBEXECDIR)
+ cp -Rf $(CGIFILES) $(DESTDIR)$(LIBEXECDIR)
+- mkdir -p $(DESTDIR)$(DATADIR)
+- cp -Rf $(DOCUMENTFILES) $(DESTDIR)$(DATADIR)
+ mkdir -p $(DESTDIR)$(MAN1DIR)
+ cd man && cp -Rf $(MAN1FILES) $(DESTDIR)$(MAN1DIR)
+ mkdir -p $(DESTDIR)$(MAN3DIR)
diff --git a/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild b/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
new file mode 100644
index 000000000000..b442c37ae81e
--- /dev/null
+++ b/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tokyodystopia/tokyodystopia-0.9.15.ebuild,v 1.1 2010/08/13 10:59:38 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A fulltext search engine for Tokyo Cabinet"
+HOMEPAGE="http://fallabs.com/tokyodystopia/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-db/tokyocabinet"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+ epatch "${FILESDIR}/fix_ldconfig.patch"
+ epatch "${FILESDIR}/remove_docinst.patch"
+}
+
+src_configure() {
+ econf --libexecdir=/usr/libexec/${PN} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ dohtml doc/* || die
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}