summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-07 10:31:40 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-07 10:31:40 +0000
commit2e805f89afd2375fb7e13ea8ae9ca22888794b93 (patch)
tree04aa6b77f5889031e6a39d4590320bf4a5e8d596 /app-text/sgml-common
parentexperimental xemacs-gamma-21.4.7.ebuild (diff)
downloadgentoo-2-2e805f89afd2375fb7e13ea8ae9ca22888794b93.tar.gz
gentoo-2-2e805f89afd2375fb7e13ea8ae9ca22888794b93.tar.bz2
gentoo-2-2e805f89afd2375fb7e13ea8ae9ca22888794b93.zip
updating sgml-common
Diffstat (limited to 'app-text/sgml-common')
-rw-r--r--app-text/sgml-common/ChangeLog6
-rw-r--r--app-text/sgml-common/files/sgml-common-0.6.3-install-catalog.in163
-rw-r--r--app-text/sgml-common/sgml-common-0.6.3.ebuild64
3 files changed, 232 insertions, 1 deletions
diff --git a/app-text/sgml-common/ChangeLog b/app-text/sgml-common/ChangeLog
index 104a78bb42b7..0bad591b5b5b 100644
--- a/app-text/sgml-common/ChangeLog
+++ b/app-text/sgml-common/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for app-text/sgml-common
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/ChangeLog,v 1.2 2002/03/31 12:13:56 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/ChangeLog,v 1.3 2002/05/07 10:31:40 spider Exp $
+*sgml-common-0.6.3 (08 May 2002)
+ 08 May 2002; Spider <spider@gentoo.org> sgml-common-0.6.3.ebuild:
+ the old version was removed from the server, responding to bug on irc.
+
*sgml-common-0.6.1-r1 (31 Mar 2002)
31 Mar 2002; Seemant Kulleen <seemant@gentoo.org> sgml-common-0.6.1-r1.ebuild:
diff --git a/app-text/sgml-common/files/sgml-common-0.6.3-install-catalog.in b/app-text/sgml-common/files/sgml-common-0.6.3-install-catalog.in
new file mode 100644
index 000000000000..ad0d8b988db8
--- /dev/null
+++ b/app-text/sgml-common/files/sgml-common-0.6.3-install-catalog.in
@@ -0,0 +1,163 @@
+#!/bin/sh
+# Script to install a catalog in the centralized SGML catalog
+# Send any comments to Eric Bischoff <eric@caldera.de>
+# This program is under GPL license. See LICENSE file for details.
+
+# Set help message
+SGML_HELP_MESSAGE="Usage: `basename $0` [<option>] <action>\n\
+where <option> is:\n\
+\040 -d|--delegate: \t\t\t Use DELEGATE instead of CATALOG\n\
+and where <action> is:\n\
+\040 -a|--add <centralized> <ordinary>: \t Declare ordinary catalog in the centralized catalog\n\
+\040 -r|--remove <centralized> <ordinary>:\t Remove ordinary catalog from the centralized catalog\n\
+\040 -h, --help: \t\t\t\t Print this help message and exit\n\
+\040 -v, --version: \t\t\t Print the version number and exit\n"
+
+# Set version message
+SGML_VERSION_MESSAGE="sgml-common version @VERSION@ (install-catalog version 1.0)"
+
+# Set type of pointer
+SGML_POINTER="CATALOG"
+
+# Set action to be performed
+SGML_ACTION=""
+
+# Set catalogs
+SGML_CENTRALIZED=""
+SGML_ORDINARY=""
+
+# Process options
+case $1 in
+ -d|--delegate) SGML_POINTER="DELEGATE"
+ shift 1
+ ;;
+esac
+
+# Process actions
+case $1 in
+ -a|--add) SGML_ACTION="addition"
+ SGML_CENTRALIZED=$2
+ SGML_ORDINARY=$3
+ ;;
+ -r|--remove) if [ -z "$3" -o "$3" = "--version" ]
+ then
+ echo "install-catalog: Old syntax; doing nothing"
+ exit 0
+ fi
+ SGML_ACTION="removal"
+ SGML_CENTRALIZED=$2
+ SGML_ORDINARY=$3
+ ;;
+ -h|--help) echo -e $SGML_HELP_MESSAGE
+ exit 0
+ ;;
+ -v|--version) echo -e $SGML_VERSION_MESSAGE
+ exit 0
+ ;;
+ --install) echo "install-catalog: Old syntax; doing nothing"
+ exit 0
+ ;;
+ *) echo -e $SGML_HELP_MESSAGE >&2
+ exit 1
+ ;;
+esac
+
+# Check that the super catalog can be created and changed and deleted
+if [ ! -w ${ROOT}etc/sgml ]
+then
+ echo "`basename $0`: unable to write in ${ROOT}etc/sgml." >&2
+ exit 2
+fi
+case $SGML_ACTION in
+ addition)
+ if [ -e ${ROOT}etc/sgml/catalog -a ! -w ${ROOT}etc/sgml/catalog ]
+ then
+ echo "`basename $0`: can not modify \"${ROOT}etc/sgml/catalog\"." >&2
+ exit 2
+ fi
+ ;;
+ removal)
+ if [ ! -w ${ROOT}etc/sgml/catalog ]
+ then
+ echo "`basename $0`: can not modify \"${ROOT}etc/sgml/catalog\"." >&2
+ exit 2
+ fi
+ ;;
+esac
+
+# Check that the centralized catalog can be created, changed and deleted
+if [ -z "$SGML_CENTRALIZED" ]
+then
+ echo -e $SGML_HELP_MESSAGE >&2
+ exit 1
+fi
+case $SGML_ACTION in
+ addition)
+ if [ -e $SGML_CENTRALIZED -a ! -w $SGML_CENTRALIZED ]
+ then
+ echo "`basename $0`: can not modify \"$SGML_CENTRALIZED\"." >&2
+ exit 2
+ fi
+ ;;
+ removal)
+ if [ ! -w $SGML_CENTRALIZED ]
+ then
+ echo "`basename $0`: can not modify \"$SGML_CENTRALIZED\"." >&2
+ exit 2
+ fi
+ ;;
+esac
+
+# Check that we have at least one ordinary package to process
+if [ -z "$SGML_ORDINARY" ]
+then
+ echo -e $SGML_HELP_MESSAGE >&2
+ exit 1
+fi
+case $SGML_ACTION in
+ addition)
+ if [ ! -s $SGML_ORDINARY ]
+ then
+ echo "`basename $0`: \"$SGML_ORDINARY\" does not exist or is empty." >&2
+ exit 2
+ fi
+ ;;
+esac
+
+# Installation or removal of pointers
+case $SGML_ACTION in
+ addition)
+ echo "`basename $0`: addition of $SGML_ORDINARY in $SGML_CENTRALIZED"
+ if grep -q $SGML_ORDINARY $SGML_CENTRALIZED 2>/dev/null
+ then
+ echo "Warning: $SGML_ORDINARY is already installed in the centralized catalog $SGML_CENTRALIZED" >&2
+ else
+ echo "$SGML_POINTER $SGML_ORDINARY" >> $SGML_CENTRALIZED
+ fi
+ grep -q $SGML_CENTRALIZED ${ROOT}etc/sgml/catalog 2>/dev/null
+ if [ $? -ne 0 ]
+ then
+ echo "`basename $0`: addition of $SGML_CENTRALIZED in ${ROOT}etc/sgml/catalog"
+ echo "$SGML_POINTER $SGML_CENTRALIZED" >> ${ROOT}etc/sgml/catalog
+ fi
+ ;;
+ removal)
+ echo "`basename $0`: removal of $SGML_ORDINARY from $SGML_CENTRALIZED"
+ if grep -q $SGML_ORDINARY $SGML_CENTRALIZED 2>/dev/null
+ then
+ sed -e "\:$SGML_POINTER $SGML_ORDINARY:d" < $SGML_CENTRALIZED > ${SGML_CENTRALIZED}.new
+ mv ${SGML_CENTRALIZED}.new $SGML_CENTRALIZED
+ else
+ echo "Warning: $SGML_ORDINARY was not found in the centralized catalog $SGML_CENTRALIZED" >&2
+ fi
+ if [ ! -s $SGML_CENTRALIZED ]
+ then
+ rm $SGML_CENTRALIZED
+ echo "`basename $0`: removal of $SGML_CENTRALIZED from ${ROOT}etc/sgml/catalog"
+ sed -e "\:$SGML_POINTER $SGML_CENTRALIZED:d" < ${ROOT}etc/sgml/catalog > ${ROOT}etc/sgml/catalog.new
+ mv ${ROOT}etc/sgml/catalog.new ${ROOT}etc/sgml/catalog
+ fi
+ ;;
+esac
+
+exit 0
diff --git a/app-text/sgml-common/sgml-common-0.6.3.ebuild b/app-text/sgml-common/sgml-common-0.6.3.ebuild
new file mode 100644
index 000000000000..931ce75bcb99
--- /dev/null
+++ b/app-text/sgml-common/sgml-common-0.6.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/sgml-common-0.6.3.ebuild,v 1.1 2002/05/07 10:31:40 spider Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Base ISO character entities and utilities for SGML"
+SRC_URI="ftp://ftp.kde.org/pub/kde/devel/docbook/SOURCES/${P}.tgz
+ http://download.sourceforge.net/pub/mirrors/kde/devel/docbook/SOURCES/${P}.tgz"
+HOMEPAGE="http://www.iso.ch/cate/3524030.html"
+
+src_unpack() {
+
+ unpack ${A}
+ # We use a hacked version of install-catalog that supports the ROOT variable
+ cp ${FILESDIR}/${P}-install-catalog.in ${S}/bin
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man || die
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ mandir=${D}/usr/share/man \
+ docdir=${D}/usr/share/doc \
+ install || die
+
+}
+
+pkg_postinst() {
+ if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ]
+ then
+ install-catalog --add \
+ /etc/sgml/sgml-ent.cat \
+ /usr/share/sgml/sgml-iso-entities-8879.1986/catalog
+
+ install-catalog --add \
+ /etc/sgml/sgml-docbook.cat \
+ /etc/sgml/sgml-ent.cat
+ else
+ echo "install-catalog not found!"
+ fi
+}
+
+pkg_prerm() {
+ if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ]
+ then
+ install-catalog --remove \
+ /etc/sgml/sgml-docbook.cat \
+ /etc/sgml/sgml-ent.cat
+
+ install-catalog --remove \
+ /etc/sgml/sgml-ent.cat \
+ /usr/share/sgml/sgml-iso-entities-8879.1986/catalog
+ fi
+}