summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-26 12:21:18 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-26 12:21:18 +0000
commite3059323450b44b85b31a5c4c3d31a5c5c108c9d (patch)
tree8001cfd0a2a16e64d54b9cf495d59344b3fb4504 /app-text/sablotron
parentadded changelog (diff)
downloadgentoo-2-e3059323450b44b85b31a5c4c3d31a5c5c108c9d.tar.gz
gentoo-2-e3059323450b44b85b31a5c4c3d31a5c5c108c9d.tar.bz2
gentoo-2-e3059323450b44b85b31a5c4c3d31a5c5c108c9d.zip
repoman fix
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/sablotron-0.95-r1.ebuild11
-rw-r--r--app-text/sablotron/sablotron-0.95.ebuild17
2 files changed, 19 insertions, 9 deletions
diff --git a/app-text/sablotron/sablotron-0.95-r1.ebuild b/app-text/sablotron/sablotron-0.95-r1.ebuild
index 3d38596866b0..1e798b0e29b7 100644
--- a/app-text/sablotron/sablotron-0.95-r1.ebuild
+++ b/app-text/sablotron/sablotron-0.95-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.95-r1.ebuild,v 1.5 2002/08/16 02:42:02 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.95-r1.ebuild,v 1.6 2002/08/26 12:21:18 seemant Exp $
MY_P="Sablot-${PV}"
S=${WORKDIR}/${MY_P}
@@ -21,12 +21,17 @@ src_unpack() {
}
src_compile() {
- econf || die
+
+ local myconf
+
+ use perl && myconf="--enable-perlconnect"
+
+ econf ${myconf} || die
make || die
}
src_install () {
- einstall prefix=${D}/usr || die
+ einstall || die
dodoc README* RELEASE
dodoc src/TODO
}
diff --git a/app-text/sablotron/sablotron-0.95.ebuild b/app-text/sablotron/sablotron-0.95.ebuild
index 9e0a3dd875b2..de0e7e6753b3 100644
--- a/app-text/sablotron/sablotron-0.95.ebuild
+++ b/app-text/sablotron/sablotron-0.95.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.95.ebuild,v 1.2 2002/08/16 02:42:02 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.95.ebuild,v 1.3 2002/08/26 12:21:18 seemant Exp $
MY_P="Sablot-${PV}"
S=${WORKDIR}/${MY_P}
@@ -12,18 +12,23 @@ SLOT="0"
LICENSE="MPL-1.1"
KEYWORDS="x86 sparc sparc64"
-DEPEND=">=sys-devel/gcc-2.95.2
- >=dev-libs/expat-1.95.1
- virtual/glibc"
+DEPEND=">=dev-libs/expat-1.95.1 "
src_compile() {
- econf || die
+
+ local myconf
+
+ use perl && myconf="--enable-perlconnect"
+
+ econf \
+ --enable-javascript \
+ ${myconf} || die
emake || die
}
src_install () {
- einstall prefix=${D}/usr || die
+ einstall || die
dodoc README* RELEASE
dodoc src/TODO
}