summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-18 10:04:18 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-18 10:04:18 +0000
commite0e2073d999ac8b34573716e806a332aed768f72 (patch)
tree8568b3d3c7aa4cd61b48b5a2038fdbf4cc6ff560 /app-text/rtf2html
parentKeyword ~ppc ~ppc64 in anticipation of stabilization, bug #394809 (diff)
downloadgentoo-2-e0e2073d999ac8b34573716e806a332aed768f72.tar.gz
gentoo-2-e0e2073d999ac8b34573716e806a332aed768f72.tar.bz2
gentoo-2-e0e2073d999ac8b34573716e806a332aed768f72.zip
Add debug USE-flag, improve CFLAGS handling
(Portage version: 2.2.0_alpha140/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text/rtf2html')
-rw-r--r--app-text/rtf2html/ChangeLog5
-rw-r--r--app-text/rtf2html/rtf2html-0.2.0-r1.ebuild12
2 files changed, 13 insertions, 4 deletions
diff --git a/app-text/rtf2html/ChangeLog b/app-text/rtf2html/ChangeLog
index 0ddd0461054e..d94aa4d97bc9 100644
--- a/app-text/rtf2html/ChangeLog
+++ b/app-text/rtf2html/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/rtf2html
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/ChangeLog,v 1.6 2012/10/18 09:36:24 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/ChangeLog,v 1.7 2012/10/18 10:04:18 pinkbyte Exp $
+
+ 18 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> rtf2html-0.2.0-r1.ebuild:
+ Add debug USE-flag, improve CFLAGS handling
18 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> rtf2html-0.2.0-r1.ebuild:
Fix issue with incorrect parsing of '-g' compile flag in configure script.
diff --git a/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
index e981c4eec5b4..712c34f06a45 100644
--- a/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
+++ b/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild,v 1.3 2012/10/18 09:36:24 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rtf2html/rtf2html-0.2.0-r1.ebuild,v 1.4 2012/10/18 10:04:18 pinkbyte Exp $
EAPI="4"
-inherit base
+inherit base flag-o-matic
DESCRIPTION="RTF to HTML converter."
HOMEPAGE="http://rtf2html.sourceforge.net/"
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/rtf2html/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
+IUSE="debug"
DEPEND=""
RDEPEND="${DEPEND}"
@@ -23,7 +23,13 @@ DOCS=( ChangeLog README )
PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
src_prepare() {
+ # CFLAGS are incorrectly parsed, so handle this here
sed -i -e '/CFLAGS=$(echo $CFLAGS/d' configure || die 'sed on configure failed'
+ use !debug && filter-flags "-g*"
base_src_prepare
}
+
+src_configure() {
+ econf $(use_enable debug)
+}