summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2005-02-01 21:46:51 +0000
committerKito Danya Dietrich <kito@gentoo.org>2005-02-01 21:46:51 +0000
commitbd22b7873685dfafa8246e549060a5a339f03a07 (patch)
tree2948583314f3c3fca09061008113ec5994614666 /app-text/recode
parentAdded to Portage, fixes Bug 48011. (diff)
downloadgentoo-2-bd22b7873685dfafa8246e549060a5a339f03a07.tar.gz
gentoo-2-bd22b7873685dfafa8246e549060a5a339f03a07.tar.bz2
gentoo-2-bd22b7873685dfafa8246e549060a5a339f03a07.zip
added ~ppc-macos keyword and patch
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-text/recode')
-rw-r--r--app-text/recode/ChangeLog5
-rw-r--r--app-text/recode/files/recode-3.6-ppc-macos.diff29
-rw-r--r--app-text/recode/recode-3.6-r1.ebuild15
3 files changed, 45 insertions, 4 deletions
diff --git a/app-text/recode/ChangeLog b/app-text/recode/ChangeLog
index 5c6713cadaad..cb5d63b19aa6 100644
--- a/app-text/recode/ChangeLog
+++ b/app-text/recode/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/recode
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/ChangeLog,v 1.29 2005/01/01 16:33:05 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/ChangeLog,v 1.30 2005/02/01 21:46:51 kito Exp $
+
+ 01 Feb 2005; Kito <kito@gentoo.org> recode-3.6-r1.ebuild:
+ added ~ppc-macos and patch
07 Nov 2004; Markus Rothe <corsair@gentoo.org> recode-3.6-r1.ebuild:
Stable on ppc64; bug #60442
diff --git a/app-text/recode/files/recode-3.6-ppc-macos.diff b/app-text/recode/files/recode-3.6-ppc-macos.diff
new file mode 100644
index 000000000000..bc005049957f
--- /dev/null
+++ b/app-text/recode/files/recode-3.6-ppc-macos.diff
@@ -0,0 +1,29 @@
+diff -uNr recode/src/Makefile.in recode-new/src/Makefile.in
+--- recode/src/Makefile.in Mon Jan 22 12:14:16 2001
++++ recode-new/src/Makefile.in Tue Feb 1 14:03:47 2005
+@@ -165,11 +165,11 @@
+ strip-data$U.lo testdump$U.lo ucs$U.lo utf16$U.lo utf7$U.lo utf8$U.lo \
+ varia$U.lo vn$U.lo flat$U.lo html$U.lo lat1ltex$U.lo lat1txte$U.lo \
+ rfc1345$U.lo texinfo$U.lo base64$U.lo dump$U.lo endline$U.lo \
+-permut$U.lo quoted$U.lo
++permut$U.lo quoted$U.lo error.lo xstrdup.lo
+ PROGRAMS = $(bin_PROGRAMS)
+
+ recode_OBJECTS = main$U.o freeze$U.o mixed$U.o
+-recode_DEPENDENCIES = librecode.la ../lib/libreco.a
++recode_DEPENDENCIES = librecode.la
+ recode_LDFLAGS =
+ CFLAGS = @CFLAGS@
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+diff -uNr recode/src/request.c recode-new/src/request.c
+--- recode/src/request.c Wed Jun 28 13:40:21 2000
++++ recode-new/src/request.c Tue Feb 1 14:05:13 2005
+@@ -1073,7 +1073,7 @@
+ if (task->output.cursor + 4 >= task->output.limit)
+ {
+ RECODE_OUTER outer = task->request->outer;
+- size_t old_size = task->output.limit - task->output.buffer;
++ size_t old_size = task->output.cursor - task->output.buffer;
+ size_t new_size = task->output.cursor + 4 - task->output.buffer;
+
+ /* FIXME: Rethink about how the error should be reported. */
diff --git a/app-text/recode/recode-3.6-r1.ebuild b/app-text/recode/recode-3.6-r1.ebuild
index e5141f62ee7c..f2c30be16db1 100644
--- a/app-text/recode/recode-3.6-r1.ebuild
+++ b/app-text/recode/recode-3.6-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6-r1.ebuild,v 1.19 2005/01/01 16:33:05 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6-r1.ebuild,v 1.20 2005/02/01 21:46:51 kito Exp $
-inherit flag-o-matic eutils gcc
+inherit flag-o-matic eutils gcc libtool
DESCRIPTION="Convert files between various character sets"
HOMEPAGE="http://www.gnu.org/software/recode/"
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc sparc x86 ppc64"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc sparc x86 ppc64 ~ppc-macos"
IUSE="nls"
DEPEND="virtual/libc
@@ -21,6 +21,13 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${WORKDIR}/${P}-debian.diff"
+
+ if use ppc-macos; then
+ epatch ${FILESDIR}/${P}-ppc-macos.diff
+ cp ${S}/lib/error.c ${S}/lib/xstrdup.c ${S}/src/ || die "file copy failed"
+ elibtoolize
+ LDFLAGS="${LDFLAGS} -L${S}/lib -liconv -lintl"
+ fi
}
src_compile() {
@@ -36,4 +43,6 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS BACKLOG ChangeLog NEWS README THANKS TODO
+
+ use ppc-macos && rm ${D}/usr/lib/charset.alias
}