summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-04 22:13:24 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-04 22:13:24 +0000
commit034bf12975276cff813806c6e12edd43cb1427e7 (patch)
treeac8a51e39e5932a3ffdc7e033d5c0b99b6b4746d /app-text/psutils
parentportage puts $ARCH into $USE for you (diff)
downloadgentoo-2-034bf12975276cff813806c6e12edd43cb1427e7.tar.gz
gentoo-2-034bf12975276cff813806c6e12edd43cb1427e7.tar.bz2
gentoo-2-034bf12975276cff813806c6e12edd43cb1427e7.zip
arm KEYWORDS
Diffstat (limited to 'app-text/psutils')
-rw-r--r--app-text/psutils/psutils-1.17.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/app-text/psutils/psutils-1.17.ebuild b/app-text/psutils/psutils-1.17.ebuild
index 0bd9ad99e378..b3857b340bf0 100644
--- a/app-text/psutils/psutils-1.17.ebuild
+++ b/app-text/psutils/psutils-1.17.ebuild
@@ -1,33 +1,36 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/psutils/psutils-1.17.ebuild,v 1.22 2004/08/30 04:53:49 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/psutils/psutils-1.17.ebuild,v 1.23 2004/11/04 22:13:24 vapier Exp $
-S=${WORKDIR}/${PN}
DESCRIPTION="PostScript Utilities"
-SRC_URI="ftp://ftp.enst.fr/pub/unix/a2ps/${P}.tar.gz"
HOMEPAGE="http://www.tardis.ed.ac.uk/~ajcd/psutils"
-KEYWORDS="ia64 x86 ppc sparc alpha amd64 hppa mips ppc64"
-IUSE=""
-SLOT="0"
+SRC_URI="ftp://ftp.enst.fr/pub/unix/a2ps/${P}.tar.gz"
+
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
+IUSE=""
-DEPEND="virtual/libc dev-lang/perl"
RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- sed -e "s:/usr/local:\$(DESTDIR)/usr:" \
- -e "s:-DUNIX -O:-DUNIX ${CFLAGS}:" ${S}/Makefile.unix > ${S}/Makefile
+ sed \
+ -e "s:/usr/local:\$(DESTDIR)/usr:" \
+ -e "s:-DUNIX -O:-DUNIX ${CFLAGS}:" \
+ ${S}/Makefile.unix > ${S}/Makefile
}
src_compile() {
-
make || die
-
}
src_install () {
dodir /usr/{bin,share/man}
make DESTDIR=${D} install || die
- dodoc README LICENSE
+ dodoc README
}