summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-28 17:58:47 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-28 17:58:47 +0000
commitef155ce104942c8cf250ea0effa930a822efaa6c (patch)
tree866559feea82ff1bb34f014cd05a29b8c0b1a954 /app-text/pspresent
parentAdd dev-python/oauth2. (diff)
downloadgentoo-2-ef155ce104942c8cf250ea0effa930a822efaa6c.tar.gz
gentoo-2-ef155ce104942c8cf250ea0effa930a822efaa6c.tar.bz2
gentoo-2-ef155ce104942c8cf250ea0effa930a822efaa6c.zip
Respect LDFLAGS (bug #335715), CC, CFLAGS.
(Portage version: 2.2_rc86/cvs/Linux i686)
Diffstat (limited to 'app-text/pspresent')
-rw-r--r--app-text/pspresent/ChangeLog10
-rw-r--r--app-text/pspresent/pspresent-1.2.ebuild35
-rw-r--r--app-text/pspresent/pspresent-1.3-r1.ebuild (renamed from app-text/pspresent/pspresent-1.2-r1.ebuild)34
3 files changed, 29 insertions, 50 deletions
diff --git a/app-text/pspresent/ChangeLog b/app-text/pspresent/ChangeLog
index 4d6dbb2292cc..ce7f95c03c4e 100644
--- a/app-text/pspresent/ChangeLog
+++ b/app-text/pspresent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pspresent
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pspresent/ChangeLog,v 1.27 2009/12/26 17:32:04 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspresent/ChangeLog,v 1.28 2010/09/28 17:58:47 jer Exp $
+
+*pspresent-1.3-r1 (28 Sep 2010)
+
+ 28 Sep 2010; Jeroen Roovers <jer@gentoo.org> -pspresent-1.2.ebuild,
+ -pspresent-1.2-r1.ebuild, +pspresent-1.3-r1.ebuild:
+ Respect LDFLAGS (bug #335715), CC, CFLAGS.
26 Dec 2009; Peter Volkov <pva@gentoo.org> pspresent-1.2.ebuild,
pspresent-1.2-r1.ebuild, pspresent-1.3.ebuild:
diff --git a/app-text/pspresent/pspresent-1.2.ebuild b/app-text/pspresent/pspresent-1.2.ebuild
deleted file mode 100644
index e3d4e10b465c..000000000000
--- a/app-text/pspresent/pspresent-1.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pspresent/pspresent-1.2.ebuild,v 1.12 2009/12/26 17:32:04 pva Exp $
-
-IUSE="xinerama"
-
-DESCRIPTION="A tool to display full-screen PostScript presentations."
-SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
-HOMEPAGE="http://www.cse.unsw.edu.au/~matthewc/pspresent/"
-
-RDEPEND="x11-libs/libX11
- xinerama? ( x11-libs/libXinerama )
- app-text/ghostscript-gpl"
-DEPEND="${RDEPEND}
- x11-proto/xproto
- xinerama? ( x11-proto/xineramaproto )
- >=sys-apps/sed-4"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ppc x86"
-
-src_compile()
-{
- if ! use xinerama ; then
- sed -i -e "/^XINERAMA/s/^/#/g" Makefile
- fi
- make pspresent || die "make failed"
-}
-
-src_install()
-{
- dobin pspresent
- doman pspresent.1
-}
diff --git a/app-text/pspresent/pspresent-1.2-r1.ebuild b/app-text/pspresent/pspresent-1.3-r1.ebuild
index 9082b270fd92..4e211b0c5cee 100644
--- a/app-text/pspresent/pspresent-1.2-r1.ebuild
+++ b/app-text/pspresent/pspresent-1.3-r1.ebuild
@@ -1,12 +1,19 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pspresent/pspresent-1.2-r1.ebuild,v 1.5 2009/12/26 17:32:04 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspresent/pspresent-1.3-r1.ebuild,v 1.1 2010/09/28 17:58:47 jer Exp $
-IUSE="xinerama"
+EAPI="2"
+
+inherit toolchain-funcs
DESCRIPTION="A tool to display full-screen PostScript presentations."
SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
HOMEPAGE="http://www.cse.unsw.edu.au/~matthewc/pspresent/"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE="xinerama"
+KEYWORDS="~amd64 ~ppc ~x86"
RDEPEND="x11-libs/libX11
xinerama? ( x11-libs/libXinerama )
@@ -16,20 +23,21 @@ DEPEND="${RDEPEND}
xinerama? ( x11-proto/xineramaproto )
>=sys-apps/sed-4"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-src_compile()
-{
+src_prepare() {
if ! use xinerama ; then
- sed -i -e "/^XINERAMA/s/^/#/g" Makefile
+ sed -i -e "/^XINERAMA/s/^/#/g" Makefile || die "sed Makefile"
fi
- emake || die "emake failed"
+ sed -i Makefile \
+ -e 's|= -Wall -O2|+= -Wall|g' \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
}
-src_install()
-{
+src_install() {
dobin pspresent
doman pspresent.1
}