summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-15 00:19:22 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-15 00:19:22 +0000
commit03e78f3533a34e13f94d4ac4b1923b82544bb789 (patch)
tree659e9375fa210bd07db460e5a0099ec955e1e612 /app-text/psiconv/psiconv-0.8.3.ebuild
parentnew package to convert Psion documents (diff)
downloadgentoo-2-03e78f3533a34e13f94d4ac4b1923b82544bb789.tar.gz
gentoo-2-03e78f3533a34e13f94d4ac4b1923b82544bb789.tar.bz2
gentoo-2-03e78f3533a34e13f94d4ac4b1923b82544bb789.zip
new package to convert Psion documents
Diffstat (limited to 'app-text/psiconv/psiconv-0.8.3.ebuild')
-rw-r--r--app-text/psiconv/psiconv-0.8.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/psiconv/psiconv-0.8.3.ebuild b/app-text/psiconv/psiconv-0.8.3.ebuild
new file mode 100644
index 000000000000..5f95f4721be6
--- /dev/null
+++ b/app-text/psiconv/psiconv-0.8.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/psiconv/psiconv-0.8.3.ebuild,v 1.1 2003/09/15 00:19:21 seemant Exp $
+
+IUSE="doc"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An interpreter for Psion 5(MX) file formats"
+HOMEPAGE="http://huizen.dds.nl/~frodol/psiconv"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+
+ use doc \
+ && myconf="${myconf} enable-html4-docs \
+ --enable-ascii-docs \
+ --enable-rtf-docs"
+
+ econf || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}