summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-24 17:24:06 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-24 17:24:06 +0000
commit83436472c3e879cb7abe1d4bc55403e36e7da611 (patch)
tree37aa83198c40d500a4c81745def431c451b8eed0 /app-text/poppler
parentStable on alpha, bug #298204 (diff)
downloadgentoo-2-83436472c3e879cb7abe1d4bc55403e36e7da611.tar.gz
gentoo-2-83436472c3e879cb7abe1d4bc55403e36e7da611.tar.bz2
gentoo-2-83436472c3e879cb7abe1d4bc55403e36e7da611.zip
Add proper patch instead of workaround for missing headers installation. Thanks to Maciej Mrozowski.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/ChangeLog7
-rw-r--r--app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch52
-rw-r--r--app-text/poppler/poppler-0.12.3-r1.ebuild17
3 files changed, 64 insertions, 12 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index 2f5ec14f6fbe..c42600a452c2 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.204 2010/01/24 16:06:18 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.205 2010/01/24 17:24:05 yngwin Exp $
+
+ 24 Jan 2010; Ben de Groot <yngwin@gentoo.org> poppler-0.12.3-r1.ebuild,
+ +files/poppler-0.12.3-fix-headers-installation.patch:
+ Add proper patch instead of workaround for missing headers installation.
+ Thanks to Maciej Mrozowski.
*poppler-0.12.3-r1 (24 Jan 2010)
diff --git a/app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch b/app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch
new file mode 100644
index 000000000000..9eafd877b819
--- /dev/null
+++ b/app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch
@@ -0,0 +1,52 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0cd32df..070be33 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -363,6 +363,11 @@ if(ENABLE_XPDF_HEADERS)
+ goo/FixedPoint.h
+ goo/gstrtod.h
+ DESTINATION include/poppler/goo)
++ if(PNG_FOUND)
++ install(FILES
++ goo/PNGWriter.h
++ DESTINATION include/poppler/goo)
++ endif(PNG_FOUND)
+ install(FILES
+ fofi/FoFiBase.h
+ fofi/FoFiEncodings.h
+@@ -374,6 +379,9 @@ if(ENABLE_XPDF_HEADERS)
+ install(FILES
+ poppler/JPEG2000Stream.h
+ DESTINATION include/poppler)
++ install(FILES
++ poppler/goo/JpegWriter.h
++ DESTINATION include/poppler/goo)
+ else(LIBOPENJPEG_FOUND)
+ install(FILES
+ poppler/JPXStream.h
+diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
+index 6ed9523..9f5d0e7 100644
+--- a/glib/CMakeLists.txt
++++ b/glib/CMakeLists.txt
+@@ -30,6 +30,7 @@ set(poppler_glib_public_headers
+ poppler-attachment.h
+ poppler-form-field.h
+ poppler-annot.h
++ poppler-layer.h
+ poppler.h
+ )
+
+diff --git a/qt4/src/Makefile.am b/qt4/src/Makefile.am
+index 7e982e7..10ac221 100644
+--- a/qt4/src/Makefile.am
++++ b/qt4/src/Makefile.am
+@@ -16,8 +16,7 @@ poppler_include_HEADERS = \
+ poppler-form.h \
+ poppler-optcontent.h \
+ poppler-export.h \
+- poppler-page-transition.h \
+- poppler-page-transition-private.h
++ poppler-page-transition.h
+
+ lib_LTLIBRARIES = libpoppler-qt4.la
+
diff --git a/app-text/poppler/poppler-0.12.3-r1.ebuild b/app-text/poppler/poppler-0.12.3-r1.ebuild
index 0c5c5906a44e..6b4406cf611b 100644
--- a/app-text/poppler/poppler-0.12.3-r1.ebuild
+++ b/app-text/poppler/poppler-0.12.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.12.3-r1.ebuild,v 1.1 2010/01/24 16:06:18 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.12.3-r1.ebuild,v 1.2 2010/01/24 17:24:05 yngwin Exp $
EAPI="2"
@@ -39,6 +39,7 @@ RDEPEND="${COMMON_DEPEND}
src_prepare() {
epatch "${FILESDIR}/${P}-cmake-disable-tests.patch"
+ epatch "${FILESDIR}/${P}-fix-headers-installation.patch"
}
src_configure() {
@@ -67,15 +68,9 @@ src_configure() {
src_install() {
cmake-utils_src_install
- if use glib; then
- # install missing header
- insinto /usr/include/poppler/glib/
- doins "${S}"/glib/poppler-layer.h
-
- if use doc; then
- # For now install gtk-doc there
- insinto /usr/share/gtk-doc/html/poppler
- doins -r "${S}"/glib/reference/html/* || die 'failed to install API documentation'
- fi
+ if use glib && use doc; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/* || die 'failed to install API documentation'
fi
}