summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-02-21 16:43:57 +0000
committerFabian Groffen <grobian@gentoo.org>2010-02-21 16:43:57 +0000
commit4b3d5217854ea9fd13cf7e7cc5bc294b53f28452 (patch)
treeacfff4b37680e1eaa2c1611ec041103482f94cb8 /app-text/poppler
parentalpha/arm/ia64/s390/sh/sparc stable wrt #301961 (diff)
downloadgentoo-2-4b3d5217854ea9fd13cf7e7cc5bc294b53f28452.tar.gz
gentoo-2-4b3d5217854ea9fd13cf7e7cc5bc294b53f28452.tar.bz2
gentoo-2-4b3d5217854ea9fd13cf7e7cc5bc294b53f28452.zip
Drop flag-o-matic ugly hack in favour of patch by upstream to solve Solaris -lrt problem
(Portage version: 2.2.00.15335-prefix/cvs/SunOS i386, RepoMan options: --force)
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/ChangeLog7
-rw-r--r--app-text/poppler/files/poppler-0.12.4-nanosleep-rt.patch43
-rw-r--r--app-text/poppler/poppler-0.12.4.ebuild8
3 files changed, 52 insertions, 6 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index 916ccc229242..2abb2d507dd5 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.224 2010/02/19 18:01:06 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.225 2010/02/21 16:43:56 grobian Exp $
+
+ 21 Feb 2010; Fabian Groffen <grobian@gentoo.org> poppler-0.12.4.ebuild,
+ +files/poppler-0.12.4-nanosleep-rt.patch:
+ Drop flag-o-matic ugly hack in favour of patch by upstream to solve
+ Solaris -lrt problem
19 Feb 2010; Fabian Groffen <grobian@gentoo.org> poppler-0.12.4.ebuild:
make sure we link with -lrt on Solaris, problem reported upstream
diff --git a/app-text/poppler/files/poppler-0.12.4-nanosleep-rt.patch b/app-text/poppler/files/poppler-0.12.4-nanosleep-rt.patch
new file mode 100644
index 000000000000..a2843bfd7f6e
--- /dev/null
+++ b/app-text/poppler/files/poppler-0.12.4-nanosleep-rt.patch
@@ -0,0 +1,43 @@
+http://bugs.freedesktop.org/show_bug.cgi?id=26650
+
+diff --git a/ConfigureChecks.cmake b/ConfigureChecks.cmake
+index 6049c9a..04de970 100644
+--- a/ConfigureChecks.cmake
++++ b/ConfigureChecks.cmake
+@@ -49,3 +49,8 @@ check_for_dir("dirent.h" HAVE_DIRENT_H)
+ check_for_dir("ndir.h" HAVE_NDIR_H)
+ check_for_dir("sys/dir.h" HAVE_SYS_DIR_H)
+ check_for_dir("sys/ndir.h" HAVE_SYS_NDIR_H)
++
++check_function_exists("nanosleep" HAVE_NANOSLEEP)
++if(NOT HAVE_NANOSLEEP)
++ check_library_exists("rt" "nanosleep" "" LIB_RT_HAS_NANOSLEEP)
++endif(NOT HAVE_NANOSLEEP)
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index 2c6ec36..eada899 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -1,12 +1,17 @@
+
+ if (ENABLE_SPLASH)
+
+- set (perf_test_SRCS
+- perf-test.cc
+- perf-test-preview-dummy.cc
+- )
+- add_executable(perf-test ${perf_test_SRCS})
+- target_link_libraries(perf-test poppler)
++ if (HAVE_NANOSLEEP OR LIB_RT_HAS_NANOSLEEP)
++ set (perf_test_SRCS
++ perf-test.cc
++ perf-test-preview-dummy.cc
++ )
++ add_executable(perf-test ${perf_test_SRCS})
++ target_link_libraries(perf-test poppler)
++ if (LIB_RT_HAS_NANOSLEEP)
++ target_link_libraries(perf-test rt)
++ endif (LIB_RT_HAS_NANOSLEEP)
++ endif (HAVE_NANOSLEEP OR LIB_RT_HAS_NANOSLEEP)
+
+ endif (ENABLE_SPLASH)
+
diff --git a/app-text/poppler/poppler-0.12.4.ebuild b/app-text/poppler/poppler-0.12.4.ebuild
index dacac9101e69..7f47d043521d 100644
--- a/app-text/poppler/poppler-0.12.4.ebuild
+++ b/app-text/poppler/poppler-0.12.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.12.4.ebuild,v 1.2 2010/02/19 18:01:06 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.12.4.ebuild,v 1.3 2010/02/21 16:43:56 grobian Exp $
EAPI="2"
-inherit cmake-utils flag-o-matic
+inherit cmake-utils
DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
HOMEPAGE="http://poppler.freedesktop.org/"
@@ -46,6 +46,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-0.12.3-darwin-gtk-link.patch
epatch "${FILESDIR}"/${P}-config.patch #304407
epatch "${FILESDIR}"/${PN}-0.12.3-cairo-downscale.patch #303817
+ epatch "${FILESDIR}"/${PN}-0.12.4-nanosleep-rt.patch
}
src_configure() {
@@ -68,9 +69,6 @@ src_configure() {
$(cmake-utils_use exceptions USE_EXCEPTIONS)
)
- # http://bugs.freedesktop.org/show_bug.cgi?id=26650
- [[ ${CHOST} == *-solaris* ]] && append-ldflags -lrt # for nanosleep
-
cmake-utils_src_configure
}