summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2012-05-17 23:39:44 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2012-05-17 23:39:44 +0000
commit33e0a7ace2d204eb17290856f3928f079f9e1d2f (patch)
tree896b5dd466e2b3a49049611f17b5ec5cb669367a /app-text/poppler
parentMask poppler-0.20.0 (diff)
downloadgentoo-2-33e0a7ace2d204eb17290856f3928f079f9e1d2f.tar.gz
gentoo-2-33e0a7ace2d204eb17290856f3928f079f9e1d2f.tar.bz2
gentoo-2-33e0a7ace2d204eb17290856f3928f079f9e1d2f.zip
Version bump, bug 413035.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/ChangeLog9
-rw-r--r--app-text/poppler/files/poppler-0.20.0-lcms-automagic.patch112
-rw-r--r--app-text/poppler/metadata.xml1
-rw-r--r--app-text/poppler/poppler-0.20.0.ebuild109
4 files changed, 230 insertions, 1 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index f1121845e9af..d49aab3e2be9 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.317 2012/05/06 20:34:59 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.318 2012/05/17 23:39:44 reavertm Exp $
+
+*poppler-0.20.0 (17 May 2012)
+
+ 17 May 2012; Maciej Mrozowski <reavertm@gentoo.org>
+ +files/poppler-0.20.0-lcms-automagic.patch, +poppler-0.20.0.ebuild,
+ metadata.xml:
+ Version bump, bug 413035.
06 May 2012; Brent Baude <ranger@gentoo.org> poppler-0.18.4-r1.ebuild:
Marking poppler-0.18.4-r1 ppc for bug 412701
diff --git a/app-text/poppler/files/poppler-0.20.0-lcms-automagic.patch b/app-text/poppler/files/poppler-0.20.0-lcms-automagic.patch
new file mode 100644
index 000000000000..0d022141747d
--- /dev/null
+++ b/app-text/poppler/files/poppler-0.20.0-lcms-automagic.patch
@@ -0,0 +1,112 @@
+diff -ruN poppler-0.20.0/cmake/modules/FindLCMS2.cmake my/cmake/modules/FindLCMS2.cmake
+--- poppler-0.20.0/cmake/modules/FindLCMS2.cmake 1970-01-01 01:00:00.000000000 +0100
++++ my/cmake/modules/FindLCMS2.cmake 2012-05-18 01:22:01.349427369 +0200
+@@ -0,0 +1,73 @@
++# - Find LCMS2
++# Find the LCMS2 includes and library
++# This module defines
++# LCMS2_INCLUDE_DIR, where to find lcms.h
++# LCMS2_LIBRARIES, the libraries needed to use LCMS2.
++# LCMS2_VERSION, The value of LCMS_VERSION defined in lcms.h
++# LCMS2_FOUND, If false, do not try to use LCMS2.
++
++
++# Copyright (c) 2008, Adrian Page, <adrian@pagenet.plus.com>
++# Copyright (c) 2009, Cyrille Berger, <cberger@cberger.net>
++#
++# Redistribution and use is allowed according to the terms of the BSD license.
++# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
++
++
++# use pkg-config to get the directories and then use these values
++# in the FIND_PATH() and FIND_LIBRARY() calls
++if(NOT WIN32)
++ find_package(PkgConfig)
++ pkg_check_modules(PC_LCMS2 lcms2)
++ set(LCMS2_DEFINITIONS ${PC_LCMS2_CFLAGS_OTHER})
++endif(NOT WIN32)
++
++find_path(LCMS2_INCLUDE_DIR lcms2.h
++ PATHS
++ ${PC_LCMS2_INCLUDEDIR}
++ ${PC_LCMS2_INCLUDE_DIRS}
++ PATH_SUFFIXES lcms2 liblcms2
++)
++
++find_library(LCMS2_LIBRARIES NAMES lcms2 liblcms2 lcms-2 liblcms-2
++ PATHS
++ ${PC_LCMS2_LIBDIR}
++ ${PC_LCMS2_LIBRARY_DIRS}
++ PATH_SUFFIXES lcms2
++)
++
++if(LCMS2_INCLUDE_DIR AND LCMS2_LIBRARIES)
++ set(LCMS2_FOUND TRUE)
++else(LCMS2_INCLUDE_DIR AND LCMS2_LIBRARIES)
++ set(LCMS2_FOUND FALSE)
++endif(LCMS2_INCLUDE_DIR AND LCMS2_LIBRARIES)
++
++if(LCMS2_FOUND)
++ file(READ ${LCMS2_INCLUDE_DIR}/lcms2.h LCMS2_VERSION_CONTENT)
++ string(REGEX MATCH "#define LCMS_VERSION[ ]*[0-9]*\n" LCMS2_VERSION_MATCH ${LCMS2_VERSION_CONTENT})
++ if(LCMS2_VERSION_MATCH)
++ string(REGEX REPLACE "#define LCMS_VERSION[ ]*([0-9]*)\n" "\\1" LCMS2_VERSION ${LCMS2_VERSION_MATCH})
++ if(NOT LCMS2_FIND_QUIETLY)
++ string(SUBSTRING ${LCMS2_VERSION} 0 1 LCMS2_MAJOR_VERSION)
++ string(SUBSTRING ${LCMS2_VERSION} 1 2 LCMS2_MINOR_VERSION)
++ message(STATUS "Found lcms version ${LCMS2_MAJOR_VERSION}.${LCMS2_MINOR_VERSION}, ${LCMS2_LIBRARIES}")
++ endif(NOT LCMS2_FIND_QUIETLY)
++ else(LCMS2_VERSION_MATCH)
++ if(NOT LCMS2_FIND_QUIETLY)
++ message(STATUS "Found lcms2 but failed to find version ${LCMS2_LIBRARIES}")
++ endif(NOT LCMS2_FIND_QUIETLY)
++ set(LCMS2_VERSION NOTFOUND)
++ endif(LCMS2_VERSION_MATCH)
++else(LCMS2_FOUND)
++ if(NOT LCMS2_FIND_QUIETLY)
++ if(LCMS2_FIND_REQUIRED)
++ message(FATAL_ERROR "Required package lcms2 NOT found")
++ else(LCMS2_FIND_REQUIRED)
++ message(STATUS "lcms2 NOT found")
++ endif(LCMS2_FIND_REQUIRED)
++ endif(NOT LCMS2_FIND_QUIETLY)
++endif(LCMS2_FOUND)
++
++mark_as_advanced(LCMS2_INCLUDE_DIR LCMS2_LIBRARIES LCMS2_VERSION)
++
++
+diff -ruN poppler-0.20.0/CMakeLists.txt my/CMakeLists.txt
+--- poppler-0.20.0/CMakeLists.txt 2012-05-10 21:08:51.000000000 +0200
++++ my/CMakeLists.txt 2012-05-18 01:14:34.103419581 +0200
+@@ -29,6 +29,7 @@
+ option(ENABLE_CPP "Compile poppler cpp wrapper." ON)
+ option(ENABLE_LIBOPENJPEG "Use libopenjpeg for JPX streams." ON)
+ option(ENABLE_LCMS "Use liblcms for color management." ON)
++option(ENABLE_LCMS2 "Use liblcms2 for color management." ON)
+ option(ENABLE_LIBCURL "Build libcurl based HTTP support." OFF)
+ option(ENABLE_ZLIB "Build with zlib (not totally safe)." OFF)
+ option(USE_FIXEDPOINT "Use fixed point arithmetic in the Splash backend" OFF)
+@@ -136,16 +137,14 @@
+ set(ENABLE_LIBOPENJPEG ${LIBOPENJPEG_FOUND})
+ set(HAVE_OPENJPEG_H ON)
+ endif(ENABLE_LIBOPENJPEG)
+-if(ENABLE_LCMS)
++if(ENABLE_LCMS2)
+ find_package(LCMS2)
+- if(LCMS2_FOUND)
+- set(USE_CMS ${LCMS2_FOUND})
+- else(LCMS2_FOUND)
+- find_package(LCMS)
+- set(USE_CMS ${LCMS_FOUND})
+- set(USE_LCMS1 ${LCMS_FOUND})
+- endif(LCMS2_FOUND)
+-endif(ENABLE_LCMS)
++ set(USE_CMS ${LCMS2_FOUND})
++elseif(ENABLE_LCMS)
++ find_package(LCMS)
++ set(USE_CMS ${LCMS_FOUND})
++ set(USE_LCMS1 ${LCMS_FOUND})
++endif(ENABLE_LCMS2)
+ if(ENABLE_LIBCURL)
+ find_package(CURL)
+ include_directories(${CURL_INCLUDE_DIR})
diff --git a/app-text/poppler/metadata.xml b/app-text/poppler/metadata.xml
index f938028802cf..f7e043fd3da5 100644
--- a/app-text/poppler/metadata.xml
+++ b/app-text/poppler/metadata.xml
@@ -10,6 +10,7 @@
<use>
<flag name='exceptions'>Enable exceptions throwing.</flag>
<flag name='introspection'>Enable GObject introspection.</flag>
+ <flag name='lcms1'>Prefer liblcms1 implementation over liblcms2.</flag>
<flag name='utils'>Install command-line PDF converters and various utilities.</flag>
<flag name='xpdf-headers'></flag>
</use>
diff --git a/app-text/poppler/poppler-0.20.0.ebuild b/app-text/poppler/poppler-0.20.0.ebuild
new file mode 100644
index 000000000000..eead20c4e8c4
--- /dev/null
+++ b/app-text/poppler/poppler-0.20.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.20.0.ebuild,v 1.1 2012/05/17 23:39:44 reavertm Exp $
+
+EAPI="4"
+
+inherit cmake-utils
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="http://poppler.freedesktop.org/"
+SRC_URI="http://poppler.freedesktop.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="cairo cjk curl cxx debug doc +introspection jpeg jpeg2k lcms1 +lcms png qt4 tiff +utils +xpdf-headers"
+
+REQUIRED_USE="
+ lcms1? ( lcms )
+"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12 )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg )
+ jpeg2k? ( media-libs/openjpeg )
+ lcms? (
+ lcms1? ( =media-libs/lcms-1* )
+ !lcms1? ( media-libs/lcms:2 )
+ )
+ png? ( >=media-libs/libpng-1.4:0 )
+ qt4? (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-libs/poppler
+ !dev-libs/poppler-glib
+ !dev-libs/poppler-qt3
+ !dev-libs/poppler-qt4
+ !app-text/poppler-utils
+ cjk? ( >=app-text/poppler-data-0.4.4 )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-lcms-automagic.patch"
+)
+
+DOCS=(AUTHORS ChangeLog NEWS README README-XPDF TODO)
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ $(cmake-utils_use_enable curl LIBCURL)
+ $(cmake-utils_use_enable cxx CPP)
+ $(cmake-utils_use_enable jpeg2k LIBOPENJPEG)
+ $(cmake-utils_use_enable utils)
+ $(cmake-utils_use_enable xpdf-headers XPDF_HEADERS)
+ $(cmake-utils_use_with cairo)
+ $(cmake-utils_use_with introspection GObjectIntrospection)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with qt4)
+ $(cmake-utils_use_with tiff)
+ )
+ if use lcms; then
+ mycmakeargs+=(
+ $(cmake-utils_use_enable lcms1 LCMS)
+ $(cmake-utils_use_enable !lcms1 LCMS2)
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use cairo && use doc; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/* || die 'failed to install API documentation'
+ fi
+}
+
+pkg_postinst() {
+ ewarn "After upgrading app-text/poppler you may need to reinstall packages"
+ ewarn "linking to it. If you're not a portage-2.2_rc user, you're advised"
+ ewarn "to run revdep-rebuild"
+}