summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-04-30 07:02:23 +0000
committerZac Medico <zmedico@gentoo.org>2010-04-30 07:02:23 +0000
commit8ac491a9a96ea8fb7c13556503e56a1f36995862 (patch)
tree1a83c52baa54b18727b026832eb168a822449df3 /app-text/podofo
parentMIME-Base64-3.09 is not part of perl-5.10.1 so remove wrong provider (diff)
downloadgentoo-2-8ac491a9a96ea8fb7c13556503e56a1f36995862.tar.gz
gentoo-2-8ac491a9a96ea8fb7c13556503e56a1f36995862.tar.bz2
gentoo-2-8ac491a9a96ea8fb7c13556503e56a1f36995862.zip
0.8.0 version bump. Thanks to Tim Harder <radhermit@gmail.com> in bug #317835.
(Portage version: 2.2_rc67_p98/cvs/Linux i686)
Diffstat (limited to 'app-text/podofo')
-rw-r--r--app-text/podofo/ChangeLog8
-rw-r--r--app-text/podofo/podofo-0.8.0.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/app-text/podofo/ChangeLog b/app-text/podofo/ChangeLog
index ed6cc09829d7..ca0ce0dbde3d 100644
--- a/app-text/podofo/ChangeLog
+++ b/app-text/podofo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/podofo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/ChangeLog,v 1.8 2010/02/16 22:31:07 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/ChangeLog,v 1.9 2010/04/30 07:02:23 zmedico Exp $
+
+*podofo-0.8.0 (30 Apr 2010)
+
+ 30 Apr 2010; Zac Medico <zmedico@gentoo.org> +podofo-0.8.0.ebuild:
+ 0.8.0 version bump. Thanks to Tim Harder <radhermit@gmail.com> in bug
+ #317835.
16 Feb 2010; Christian Faulhammer <fauli@gentoo.org> podofo-0.7.0.ebuild:
stable x86, bug 302249
diff --git a/app-text/podofo/podofo-0.8.0.ebuild b/app-text/podofo/podofo-0.8.0.ebuild
new file mode 100644
index 000000000000..851ec81e1e33
--- /dev/null
+++ b/app-text/podofo/podofo-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.8.0.ebuild,v 1.1 2010/04/30 07:02:23 zmedico Exp $
+
+EAPI=2
+inherit cmake-utils multilib
+
+DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format."
+HOMEPAGE="http://sourceforge.net/projects/podofo/"
+SRC_URI="mirror://sourceforge/podofo/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+boost debug test"
+
+RDEPEND="dev-lang/lua
+ dev-libs/openssl
+ >=dev-libs/STLport-5.1.5
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/jpeg:0
+ media-libs/libpng
+ media-libs/tiff
+ sys-libs/zlib
+ boost? ( dev-util/boost-build )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )"
+
+DOCS="AUTHORS ChangeLog TODO"
+
+src_prepare() {
+ sed -i \
+ -e "s:LIBDIRNAME \"lib\":LIBDIRNAME \"$(get_libdir)\":" \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ mycmakeargs+=(
+ "-DPODOFO_BUILD_SHARED=1"
+ "-DPODOFO_HAVE_JPEG_LIB=1"
+ "-DPODOFO_HAVE_PNG_LIB=1"
+ "-DPODOFO_HAVE_TIFF_LIB=1"
+ "-DWANT_FONTCONFIG=1"
+ "-DUSE_STLPORT=1"
+ $(cmake-utils_use_want boost)
+ $(cmake-utils_use_has test CPPUNIT)
+ )
+
+ cmake-utils_src_configure
+}